From 00a68be75a010ccb328fec778bf292ca77b64dae Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:57:33 +0200
Subject: [PATCH] gnu: Add texlive-papermas.

* gnu/packages/tex.scm (texlive-papermas): New variable.
---
 gnu/packages/tex.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dbd838205f..33392e1111 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -91304,6 +91304,27 @@ commands for revisions.")
 folding paper CD cases.")
     (license license:lppl)))
 
+(define-public texlive-papermas
+  (package
+    (name "texlive-papermas")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/papermas/"
+                   "source/latex/papermas/"
+                   "tex/latex/papermas/")
+             (base32
+              "0cyw6lrhh6nh8rhwky6assda80rvgcc5djmdd9zl68svp373vxd2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/papermas")
+    (synopsis "Compute the mass of a printed version of a document")
+    (description
+     "The package computes the number of sheets of paper used by, and hence the
+mass of a document.  This is useful (for example) when calculating postal
+charges.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar