me
/
guix
Archived
1
0
Fork 0

gnu: xf86-input-wacom: Update to 0.34.2.

* gnu/packages/xdisorg.scm (xf86-input-wacom): Update to 0.34.2.
[source]: Remove obsolete patch.
* gnu/packages/patches/xf86-input-wacom-xorg-abi-25.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Marius Bakke 2017-06-05 14:58:01 +02:00
parent 0c70d8097f
commit 00c5e3e5fc
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 51 deletions

View File

@ -1066,7 +1066,6 @@ dist_patch_DATA = \
%D%/packages/patches/xcb-proto-python3-whitespace.patch \
%D%/packages/patches/wxwidgets-fix-windowGTK.patch \
%D%/packages/patches/xdotool-fix-makefile.patch \
%D%/packages/patches/xf86-input-wacom-xorg-abi-25.patch \
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
%D%/packages/patches/xf86-video-ast-remove-mibstore.patch \
%D%/packages/patches/xf86-video-geode-glibc-2.20.patch \

View File

@ -1,46 +0,0 @@
Resolves a test compatibility issue with xorg >= 1.19.
Upstream bug report:
https://sourceforge.net/p/linuxwacom/bugs/329/
Patch copied from upstream source repository:
https://sourceforge.net/p/linuxwacom/xf86-input-wacom/ci/f0dedf7a610ac97bc45738492b98ce4f1e0514ec/
From f0dedf7a610ac97bc45738492b98ce4f1e0514ec Mon Sep 17 00:00:00 2001
From: Jason Gerecke <killertofu@gmail.com>
Date: Wed, 18 Jan 2017 09:00:10 -0800
Subject: [PATCH] tests: Fix compilation under ABI 25 and greater
diff --git a/test/fake-symbols.c b/test/fake-symbols.c
index 6f2c10a..e649fb9 100644
--- a/test/fake-symbols.c
+++ b/test/fake-symbols.c
@@ -493,6 +493,7 @@ void TimerFree(OsTimerPtr timer)
{
}
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 24
int
xf86BlockSIGIO (void)
{
@@ -503,6 +504,15 @@ void
xf86UnblockSIGIO (int wasset)
{
}
+#else
+void input_lock (void)
+{
+}
+
+void input_unlock (void)
+{
+}
+#endif
/* This is not the same as the X server one, but it'll do for the tests */
#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
--
2.11.1

View File

@ -823,7 +823,7 @@ Wacom tablet applet.")
(define-public xf86-input-wacom
(package
(name "xf86-input-wacom")
(version "0.34.0")
(version "0.34.2")
(source (origin
(method url-fetch)
(uri (string-append
@ -831,9 +831,7 @@ Wacom tablet applet.")
name "-" version ".tar.bz2"))
(sha256
(base32
"0idhkigl0pnyp08sqm6bqfb4h20v6rjrb71z1gdv59gk7d7qwpgi"))
(patches
(search-patches "xf86-input-wacom-xorg-abi-25.patch"))))
"073bf12ka1mcqvr1sviixb51bsfx37jalrj9xw53f10i2kdvkl9a"))))
(arguments
`(#:configure-flags
(list (string-append "--with-sdkdir="