me
/
guix
Archived
1
0
Fork 0

gnu: giac: Fix build.

* gnu/packages/algebra.scm (giac)[source]<origin>: Add a patch to fix build
issue with Pari-GP 2.15.
[arguments]<#:phase>: Skip another test.
* gnu/packages/patches/giac-pari-gp-anyarg.patch: New file.
* gnu/local.mk: Register it.

This fixes <https://issues.guix.gnu.org/58274>.
master
Nicolas Goaziou 2022-10-07 21:42:17 +02:00
parent 0169aee33e
commit 00ef6c18d5
No known key found for this signature in database
GPG Key ID: DA00B4F048E92F2D
3 changed files with 37 additions and 2 deletions

View File

@ -1187,6 +1187,7 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-id.patch \
%D%/packages/patches/ghostscript-no-header-uuid.patch \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
%D%/packages/patches/giac-pari-gp-anyarg.patch \
%D%/packages/patches/giara-fix-login.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-networking-gnutls-binding.patch \

View File

@ -339,7 +339,12 @@ precision.")
"~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz"))
(sha256
(base32 "1zh7bf0ag4vbyyj5n8lbvy2ivp0kshms40ra5lq1ff035rpx230j"))))
(base32 "1zh7bf0ag4vbyyj5n8lbvy2ivp0kshms40ra5lq1ff035rpx230j"))
(patches
;; Patch borrowed from Sage math team. Giac 1.9.0-21 does not build
;; since Pari-GP 2.15 upgrade. Reported upstream here:
;; <https://xcas.univ-grenoble-alpes.fr/forum/viewtopic.php?f=3&t=2800>.
(search-patches "giac-pari-gp-anyarg.patch"))))
(build-system gnu-build-system)
(arguments
(list
@ -355,9 +360,10 @@ precision.")
(find-files "doc" "^Makefile"))
(("/bin/cp") (which "cp")))))
(add-after 'unpack 'disable-failing-test
;; FIXME: Test failing. Not sure why.
;; FIXME: Tests failing. Not sure why.
(lambda _
(substitute* "check/Makefile.in"
(("chk_fhan4") "")
(("chk_fhan11") ""))))
(add-after 'install 'fix-doc
(lambda _

View File

@ -0,0 +1,28 @@
From 041d16b521d8231e5b441015f08bb386f9d2a51c Mon Sep 17 00:00:00 2001
From: Vincent Delecroix <20100.delecroix@gmail.com*>
Date: Thu, 15 Sep 2022 12:11:01 +0200
Subject: ANYARG giac patch
---
diff --git a/src/pari.cc b/src/pari.cc
index 76ce8e1..50d08ab 100644
--- a/src/pari.cc
+++ b/src/pari.cc
@@ -40,6 +40,13 @@ using namespace std;
#ifdef HAVE_LIBPARI
+// Anyarg disappeared from PARI 2.15.0
+#ifdef __cplusplus
+# define ANYARG ...
+#else
+# define ANYARG
+#endif
+
#ifdef HAVE_PTHREAD_H
#include <pthread.h>
#endif
--
cgit v1.0-1-gd88e