gnutls: fix the test-suite for 32 bits systems.
* gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch: New file. * gnu-system.am: Add it here... * gnu/packages/gnutls.scm (gnutls): ... and use it here. Thanks to Nikos Mavrogiannopoulos for providing this patch: http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/6778master
parent
88a0b7b051
commit
013ce67b19
|
@ -188,6 +188,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/glib-tests-prlimit.patch \
|
gnu/packages/patches/glib-tests-prlimit.patch \
|
||||||
gnu/packages/patches/glibc-bootstrap-system.patch \
|
gnu/packages/patches/glibc-bootstrap-system.patch \
|
||||||
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
||||||
|
gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch \
|
||||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||||
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||||
gnu/packages/patches/guile-default-utf8.patch \
|
gnu/packages/patches/guile-default-utf8.patch \
|
||||||
|
|
|
@ -23,6 +23,7 @@
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
#:use-module ((gnu packages compression)
|
#:use-module ((gnu packages compression)
|
||||||
#:renamer (symbol-prefix-proc 'guix:))
|
#:renamer (symbol-prefix-proc 'guix:))
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages nettle)
|
#:use-module (gnu packages nettle)
|
||||||
#:use-module (gnu packages guile)
|
#:use-module (gnu packages guile)
|
||||||
#:use-module (gnu packages perl)
|
#:use-module (gnu packages perl)
|
||||||
|
@ -65,12 +66,18 @@ portable, and only require an ANSI C89 platform.")
|
||||||
(base32
|
(base32
|
||||||
"1zi2kq3vcbqdy9khl7r6pgk4hgwibniasm9k6siasdvqjijq3ymb"))))
|
"1zi2kq3vcbqdy9khl7r6pgk4hgwibniasm9k6siasdvqjijq3ymb"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
`(#:patches (list (assoc-ref %build-inputs
|
||||||
|
"patch/fix-tests"))
|
||||||
|
#:patch-flags '("-p0")))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)))
|
`(("pkg-config" ,pkg-config)))
|
||||||
(inputs
|
(inputs
|
||||||
`(("guile" ,guile-2.0)
|
`(("guile" ,guile-2.0)
|
||||||
("zlib" ,guix:zlib)
|
("zlib" ,guix:zlib)
|
||||||
("perl" ,perl)))
|
("perl" ,perl)
|
||||||
|
("patch/fix-tests"
|
||||||
|
,(search-patch "gnutls-fix-tests-on-32-bits-system.patch"))))
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("libtasn1" ,libtasn1)
|
`(("libtasn1" ,libtasn1)
|
||||||
("nettle" ,nettle)
|
("nettle" ,nettle)
|
||||||
|
|
|
@ -0,0 +1,36 @@
|
||||||
|
From b12040aeab5fbaf02677571db1d8bf1995bd5ee0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
||||||
|
Date: Sun, 2 Jun 2013 12:10:06 +0200
|
||||||
|
Subject: [PATCH] Avoid comparing the expiration date to prevent false positive
|
||||||
|
error in 32-bit systems.
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/cert-tests/pem-decoding | 6 ++++--
|
||||||
|
1 files changed, 4 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tests/cert-tests/pem-decoding b/tests/cert-tests/pem-decoding
|
||||||
|
index fe769ec..f8c6372 100755
|
||||||
|
--- tests/cert-tests/pem-decoding
|
||||||
|
+++ tests/cert-tests/pem-decoding
|
||||||
|
@@ -61,7 +61,9 @@ if test "$rc" != "0"; then
|
||||||
|
exit $rc
|
||||||
|
fi
|
||||||
|
|
||||||
|
-diff $srcdir/complex-cert.pem tmp-pem.pem
|
||||||
|
+cat $srcdir/complex-cert.pem |grep -v "Not After:" >tmp1
|
||||||
|
+cat $srcdir/tmp-pem.pem |grep -v "Not After:" >tmp2
|
||||||
|
+diff tmp1 tmp2
|
||||||
|
rc=$?
|
||||||
|
|
||||||
|
if test "$rc" != "0"; then
|
||||||
|
@@ -69,6 +71,6 @@ if test "$rc" != "0"; then
|
||||||
|
exit $rc
|
||||||
|
fi
|
||||||
|
|
||||||
|
-rm -f tmp-pem.pem
|
||||||
|
+rm -f tmp-pem.pem tmp1 tmp2
|
||||||
|
|
||||||
|
exit 0
|
||||||
|
--
|
||||||
|
1.7.1
|
||||||
|
|
Reference in New Issue