gnu: Boost: Update to 1.72.0.
* gnu/packages/patches/boost-dumpversion.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/boost.scm (boost): Update to 1.72.0. [source](uri): Remove defunct mirror. [source](patches): Remove. [arguments]: Adjust /bin/sh substitutions. Remove obsolete workaround.master
parent
9d2c24d227
commit
02fef9619b
|
@ -750,7 +750,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||||
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
|
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
|
||||||
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
|
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
|
||||||
%D%/packages/patches/boost-dumpversion.patch \
|
|
||||||
%D%/packages/patches/byobu-writable-status.patch \
|
%D%/packages/patches/byobu-writable-status.patch \
|
||||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||||
%D%/packages/patches/calibre-remove-test-bs4.patch \
|
%D%/packages/patches/calibre-remove-test-bs4.patch \
|
||||||
|
|
|
@ -12,6 +12,7 @@
|
||||||
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
|
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
|
||||||
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
|
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||||
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
|
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
|
||||||
|
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -46,21 +47,17 @@
|
||||||
(define-public boost
|
(define-public boost
|
||||||
(package
|
(package
|
||||||
(name "boost")
|
(name "boost")
|
||||||
(version "1.70.0")
|
(version "1.72.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (let ((version-with-underscores
|
(uri (let ((version-with-underscores
|
||||||
(string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)))
|
(string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)))
|
||||||
(list (string-append "mirror://sourceforge/boost/boost/" version
|
(string-append "https://dl.bintray.com/boostorg/release/"
|
||||||
"/boost_" version-with-underscores ".tar.bz2")
|
version "/source/boost_"
|
||||||
(string-append "https://dl.bintray.com/boostorg/release/"
|
version-with-underscores ".tar.bz2")))
|
||||||
version "/source/boost_"
|
|
||||||
version-with-underscores ".tar.bz2"))))
|
|
||||||
(patches
|
|
||||||
(search-patches "boost-dumpversion.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))))
|
"08h7cv61fd0lzb4z50xanfqn0pdgvizjrpd1kcdgj725pisb5jar"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("icu4c" ,icu4c)
|
(inputs `(("icu4c" ,icu4c)
|
||||||
("zlib" ,zlib)))
|
("zlib" ,zlib)))
|
||||||
|
@ -75,11 +72,6 @@
|
||||||
#:make-flags
|
#:make-flags
|
||||||
(list "threading=multi" "link=shared"
|
(list "threading=multi" "link=shared"
|
||||||
|
|
||||||
;; XXX: Disable installation of Boosts modular CMake config scripts
|
|
||||||
;; which conflicts in 1.70.0 with the ones provided by CMake.
|
|
||||||
;; See <https://bugs.gnu.org/36721>.
|
|
||||||
"--no-cmake-config"
|
|
||||||
|
|
||||||
;; Set the RUNPATH to $libdir so that the libs find each other.
|
;; Set the RUNPATH to $libdir so that the libs find each other.
|
||||||
(string-append "linkflags=-Wl,-rpath="
|
(string-append "linkflags=-Wl,-rpath="
|
||||||
(assoc-ref %outputs "out") "/lib")
|
(assoc-ref %outputs "out") "/lib")
|
||||||
|
@ -109,9 +101,8 @@
|
||||||
(out (assoc-ref outputs "out")))
|
(out (assoc-ref outputs "out")))
|
||||||
(substitute* '("libs/config/configure"
|
(substitute* '("libs/config/configure"
|
||||||
"libs/spirit/classic/phoenix/test/runtest.sh"
|
"libs/spirit/classic/phoenix/test/runtest.sh"
|
||||||
"tools/build/src/engine/execunix.c"
|
"tools/build/src/engine/execunix.cpp"
|
||||||
"tools/build/src/engine/Jambase"
|
"tools/build/src/engine/Jambase")
|
||||||
"tools/build/src/engine/jambase.c")
|
|
||||||
(("/bin/sh") (which "sh")))
|
(("/bin/sh") (which "sh")))
|
||||||
|
|
||||||
(setenv "SHELL" (which "sh"))
|
(setenv "SHELL" (which "sh"))
|
||||||
|
|
|
@ -1,24 +0,0 @@
|
||||||
This issue is described here: https://github.com/openwrt/packages/pull/8685
|
|
||||||
and has not been solved as of 1.70.0 release.
|
|
||||||
|
|
||||||
--- a/tools/build/src/tools/common.jam
|
|
||||||
+++ b/tools/build/src/tools/common.jam
|
|
||||||
@@ -973,18 +973,6 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- # From GCC 5, versioning changes and minor becomes patch
|
|
||||||
- if $(tag) = gcc && [ numbers.less 4 $(version[1]) ]
|
|
||||||
- {
|
|
||||||
- version = $(version[1]) ;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- # Ditto, from Clang 4
|
|
||||||
- if ( $(tag) = clang || $(tag) = clangw ) && [ numbers.less 3 $(version[1]) ]
|
|
||||||
- {
|
|
||||||
- version = $(version[1]) ;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
# On intel, version is not added, because it does not matter and it is the
|
|
||||||
# version of vc used as backend that matters. Ideally, we should encode the
|
|
||||||
# backend version but that would break compatibility with V1.
|
|
Reference in New Issue