gnu: emacs-kv: Fix build.
Build fails with emacs-next cause of copypasted test defined two times. * gnu/packages/patches/emacs-kv-fix-tests.patch: New file. * gnu/packages/emacs-xyz.scm (emacs-kv): Use it here. * gnu/local.mk (dist_patch_DATA): Register it here.master
parent
6cdde65bb5
commit
0336372296
|
@ -1051,6 +1051,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/emacs-telega-test-env.patch \
|
%D%/packages/patches/emacs-telega-test-env.patch \
|
||||||
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
||||||
%D%/packages/patches/emacs-yasnippet-fix-tests.patch \
|
%D%/packages/patches/emacs-yasnippet-fix-tests.patch \
|
||||||
|
%D%/packages/patches/emacs-kv-fix-tests.patch \
|
||||||
%D%/packages/patches/enjarify-setup-py.patch \
|
%D%/packages/patches/enjarify-setup-py.patch \
|
||||||
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
|
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
|
||||||
%D%/packages/patches/erlang-man-path.patch \
|
%D%/packages/patches/erlang-man-path.patch \
|
||||||
|
|
|
@ -17951,7 +17951,9 @@ formatting rules for that language.")
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0r0lz2s6gvy04fwnafai668jsf4546h4k6zd6isx5wpk0n33pj5m"))))
|
"0r0lz2s6gvy04fwnafai668jsf4546h4k6zd6isx5wpk0n33pj5m"))
|
||||||
|
(patches
|
||||||
|
(search-patches "emacs-kv-fix-tests.patch"))))
|
||||||
(build-system emacs-build-system)
|
(build-system emacs-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #t
|
`(#:tests? #t
|
||||||
|
|
|
@ -0,0 +1,30 @@
|
||||||
|
From 4702849bfe7462fb6c6303786dac1b670c8f0f8f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Tropin <andrew@trop.in>
|
||||||
|
Date: Wed, 14 Sep 2022 09:17:31 +0300
|
||||||
|
Subject: [PATCH] remove copypasted kvaq test
|
||||||
|
|
||||||
|
---
|
||||||
|
kv-tests.el | 7 -------
|
||||||
|
1 file changed, 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/kv-tests.el b/kv-tests.el
|
||||||
|
index 1713e5e..abd6a24 100644
|
||||||
|
--- a/kv-tests.el
|
||||||
|
+++ b/kv-tests.el
|
||||||
|
@@ -105,13 +105,6 @@
|
||||||
|
(should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
|
||||||
|
(should-not (kvaq "b" '((:a . :b)("a" . "b")))))
|
||||||
|
|
||||||
|
-(ert-deftest kvaq ()
|
||||||
|
- "Test the simple assq."
|
||||||
|
- (should (equal :b (kvaq :a '((:a . :b)("a" . "b")))))
|
||||||
|
- (should (equal 2 (kvaq 1 '((1 . 2)("a" . "b")))))
|
||||||
|
- (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
|
||||||
|
- (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
|
||||||
|
-
|
||||||
|
(ert-deftest kvaqc ()
|
||||||
|
"Test the simple assq."
|
||||||
|
(should (equal :b (kvaqc :a '((:a . :b)("a" . "b")))))
|
||||||
|
--
|
||||||
|
2.37.3
|
||||||
|
|
Reference in New Issue