gnu: dbacl: Fix failing check phase.
* gnu/packages/patches/dbacl-icheck-multiple-definitions.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/textutils.scm (dbacl) [source]: Apply patch. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>master
parent
f5d502f7f4
commit
03ab1a2762
|
@ -1035,6 +1035,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/date-output-pkg-config-files.patch \
|
%D%/packages/patches/date-output-pkg-config-files.patch \
|
||||||
%D%/packages/patches/datefudge-gettimeofday.patch \
|
%D%/packages/patches/datefudge-gettimeofday.patch \
|
||||||
%D%/packages/patches/dbacl-include-locale.h.patch \
|
%D%/packages/patches/dbacl-include-locale.h.patch \
|
||||||
|
%D%/packages/patches/dbacl-icheck-multiple-definitions.patch \
|
||||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||||
%D%/packages/patches/dbus-c++-gcc-compat.patch \
|
%D%/packages/patches/dbus-c++-gcc-compat.patch \
|
||||||
%D%/packages/patches/dbus-c++-threading-mutex.patch \
|
%D%/packages/patches/dbus-c++-threading-mutex.patch \
|
||||||
|
|
|
@ -0,0 +1,33 @@
|
||||||
|
From f5df6813e305372e25b8a2124c491293a176e115 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Danny O'Brien <danny@spesh.com>
|
||||||
|
Date: Fri, 3 Feb 2023 16:48:59 -0800
|
||||||
|
Subject: [PATCH] Fix failing build of icheck.
|
||||||
|
|
||||||
|
Building icheck fails with a duplicate symbol definition
|
||||||
|
error. This allows the icheck executable to compile.
|
||||||
|
|
||||||
|
Submitted upstream[1] but not yet moderated/accepted.
|
||||||
|
|
||||||
|
[1] https://sourceforge.net/p/dbacl/discussion/239876/thread/87636b0114/
|
||||||
|
|
||||||
|
---
|
||||||
|
src/icheck.c | 3 ---
|
||||||
|
1 file changed, 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/icheck.c b/src/icheck.c
|
||||||
|
index efbb6a5..12a3b7a 100644
|
||||||
|
--- a/src/icheck.c
|
||||||
|
+++ b/src/icheck.c
|
||||||
|
@@ -39,9 +39,6 @@ extern regex_count_t regex_count;
|
||||||
|
extern empirical_t empirical;
|
||||||
|
|
||||||
|
extern int cmd;
|
||||||
|
-char *progname = "icheck";
|
||||||
|
-char *inputfile = "";
|
||||||
|
-long inputline = 0;
|
||||||
|
|
||||||
|
extern long system_pagesize;
|
||||||
|
extern void *in_iobuf;
|
||||||
|
--
|
||||||
|
2.39.1
|
||||||
|
|
|
@ -711,7 +711,8 @@ in a portable way.")
|
||||||
"dbacl-" version ".tar.gz"))
|
"dbacl-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1gas0112wqjvwn9qg3hxnawk7h3prr0w9b2h68f3p1ifd1kzn3gz"))
|
(base32 "1gas0112wqjvwn9qg3hxnawk7h3prr0w9b2h68f3p1ifd1kzn3gz"))
|
||||||
(patches (search-patches "dbacl-include-locale.h.patch"))))
|
(patches (search-patches "dbacl-include-locale.h.patch"
|
||||||
|
"dbacl-icheck-multiple-definitions.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:make-flags
|
`(#:make-flags
|
||||||
|
|
Reference in New Issue