gnu: Add gcc-arm-none-eabi-7-2018-q2-update.
* gnu/packages/embedded.scm (gcc-arm-none-eabi-7-2018-q2-update): New variable. * gnu/packages/patches/gcc-7-cross-environment-variables.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
c215051dcf
commit
04c4ef351f
|
@ -871,6 +871,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gcc-6-source-date-epoch-1.patch \
|
%D%/packages/patches/gcc-6-source-date-epoch-1.patch \
|
||||||
%D%/packages/patches/gcc-6-source-date-epoch-2.patch \
|
%D%/packages/patches/gcc-6-source-date-epoch-2.patch \
|
||||||
%D%/packages/patches/gcc-7-cross-mingw.patch \
|
%D%/packages/patches/gcc-7-cross-mingw.patch \
|
||||||
|
%D%/packages/patches/gcc-7-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-8-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-8-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-8-strmov-store-file-names.patch \
|
%D%/packages/patches/gcc-8-strmov-store-file-names.patch \
|
||||||
%D%/packages/patches/gcc-9-asan-fix-limits-include.patch \
|
%D%/packages/patches/gcc-9-asan-fix-limits-include.patch \
|
||||||
|
|
|
@ -207,6 +207,84 @@ usable on embedded products.")
|
||||||
"--disable-nls"))))
|
"--disable-nls"))))
|
||||||
(synopsis "Newlib variant for small systems with limited memory")))
|
(synopsis "Newlib variant for small systems with limited memory")))
|
||||||
|
|
||||||
|
|
||||||
|
;;; The following definitions are for the "7-2018-q2-update" variant of the
|
||||||
|
;;; ARM cross toolchain as offered on https://developer.arm.com
|
||||||
|
(define-public gcc-arm-none-eabi-7-2018-q2-update
|
||||||
|
(let ((xgcc (cross-gcc "arm-none-eabi"
|
||||||
|
#:xgcc gcc-7
|
||||||
|
#:xbinutils (cross-binutils "arm-none-eabi")))
|
||||||
|
(revision "1")
|
||||||
|
(svn-revision 261907))
|
||||||
|
(package (inherit xgcc)
|
||||||
|
(version (string-append "7-2018-q2-update-"
|
||||||
|
revision "." (number->string svn-revision)))
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method svn-fetch)
|
||||||
|
(uri (svn-reference
|
||||||
|
(url "svn://gcc.gnu.org/svn/gcc/branches/ARM/embedded-7-branch/")
|
||||||
|
(revision svn-revision)))
|
||||||
|
(file-name (string-append "gcc-arm-embedded-" version "-checkout"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"192ggs63bixf3irpijgfkjks73yx1r3a4i6grk1y0i0iny76pmx5"))
|
||||||
|
(patches
|
||||||
|
(append
|
||||||
|
(origin-patches (package-source gcc-7))
|
||||||
|
(search-patches "gcc-7-cross-environment-variables.patch")))))
|
||||||
|
(native-inputs
|
||||||
|
`(("gcc" ,gcc-5)
|
||||||
|
("flex" ,flex)
|
||||||
|
("isl" ,isl-0.18)
|
||||||
|
,@(alist-delete "isl" (package-native-inputs xgcc))))
|
||||||
|
(arguments
|
||||||
|
(substitute-keyword-arguments (package-arguments xgcc)
|
||||||
|
((#:phases phases)
|
||||||
|
`(modify-phases ,phases
|
||||||
|
(add-after 'unpack 'expand-version-string
|
||||||
|
(lambda _
|
||||||
|
(make-file-writable "gcc/DEV-PHASE")
|
||||||
|
(with-output-to-file "gcc/DEV-PHASE"
|
||||||
|
(lambda ()
|
||||||
|
(display "7-2018-q2-update")))
|
||||||
|
#t))
|
||||||
|
(add-after 'unpack 'fix-genmultilib
|
||||||
|
(lambda _
|
||||||
|
(substitute* "gcc/genmultilib"
|
||||||
|
(("#!/bin/sh") (string-append "#!" (which "sh"))))
|
||||||
|
#t))))
|
||||||
|
((#:configure-flags flags)
|
||||||
|
;; The configure flags are largely identical to the flags used by the
|
||||||
|
;; "GCC ARM embedded" project.
|
||||||
|
`(append (list "--enable-multilib"
|
||||||
|
"--with-newlib"
|
||||||
|
"--with-multilib-list=rmprofile"
|
||||||
|
"--with-host-libstdcxx=-static-libgcc -Wl,-Bstatic,-lstdc++,-Bdynamic -lm"
|
||||||
|
"--enable-plugins"
|
||||||
|
"--disable-decimal-float"
|
||||||
|
"--disable-libffi"
|
||||||
|
"--disable-libgomp"
|
||||||
|
"--disable-libmudflap"
|
||||||
|
"--disable-libquadmath"
|
||||||
|
"--disable-libssp"
|
||||||
|
"--disable-libstdcxx-pch"
|
||||||
|
"--disable-nls"
|
||||||
|
"--disable-shared"
|
||||||
|
"--disable-threads"
|
||||||
|
"--disable-tls")
|
||||||
|
(delete "--disable-multilib" ,flags)))))
|
||||||
|
(native-search-paths
|
||||||
|
(list (search-path-specification
|
||||||
|
(variable "CROSS_C_INCLUDE_PATH")
|
||||||
|
(files '("arm-none-eabi/include")))
|
||||||
|
(search-path-specification
|
||||||
|
(variable "CROSS_CPLUS_INCLUDE_PATH")
|
||||||
|
(files '("arm-none-eabi/include")))
|
||||||
|
(search-path-specification
|
||||||
|
(variable "CROSS_LIBRARY_PATH")
|
||||||
|
(files '("arm-none-eabi/lib"))))))))
|
||||||
|
|
||||||
(define (make-libstdc++-arm-none-eabi xgcc newlib)
|
(define (make-libstdc++-arm-none-eabi xgcc newlib)
|
||||||
(let ((libstdc++ (make-libstdc++ xgcc)))
|
(let ((libstdc++ (make-libstdc++ xgcc)))
|
||||||
(package (inherit libstdc++)
|
(package (inherit libstdc++)
|
||||||
|
|
|
@ -0,0 +1,67 @@
|
||||||
|
Search path environment variables for cross-compilers. See the discussion
|
||||||
|
at <http://gcc.gnu.org/ml/gcc/2013-02/msg00124.html>.
|
||||||
|
|
||||||
|
Note: Touch 'C_INCLUDE_PATH' et al. rather than 'CPATH', as discussed
|
||||||
|
at <http://bugs.gnu.org/22186>.
|
||||||
|
|
||||||
|
diff --git a/gcc/gcc.c b/gcc/gcc.c
|
||||||
|
index eced0d5..08dec2b 100644
|
||||||
|
--- a/gcc/gcc.c
|
||||||
|
+++ b/gcc/gcc.c
|
||||||
|
@@ -4317,7 +4317,7 @@ process_command (unsigned int decoded_options_count,
|
||||||
|
}
|
||||||
|
|
||||||
|
temp = env.get (LIBRARY_PATH_ENV);
|
||||||
|
- if (temp && *cross_compile == '0')
|
||||||
|
+ if (temp)
|
||||||
|
{
|
||||||
|
const char *startp, *endp;
|
||||||
|
char *nstore = (char *) alloca (strlen (temp) + 3);
|
||||||
|
diff --git a/gcc/incpath.c b/gcc/incpath.c
|
||||||
|
index 98fe5ec..96aff65 100644
|
||||||
|
--- a/gcc/incpath.c
|
||||||
|
+++ b/gcc/incpath.c
|
||||||
|
@@ -461,8 +461,8 @@ register_include_chains (cpp_reader *pfile, const char *sysroot,
|
||||||
|
int stdinc, int cxx_stdinc, int verbose)
|
||||||
|
{
|
||||||
|
static const char *const lang_env_vars[] =
|
||||||
|
- { "C_INCLUDE_PATH", "CPLUS_INCLUDE_PATH",
|
||||||
|
- "OBJC_INCLUDE_PATH", "OBJCPLUS_INCLUDE_PATH" };
|
||||||
|
+ { "CROSS_C_INCLUDE_PATH", "CROSS_CPLUS_INCLUDE_PATH",
|
||||||
|
+ "CROSS_OBJC_INCLUDE_PATH", "CROSS_OBJCPLUS_INCLUDE_PATH" };
|
||||||
|
cpp_options *cpp_opts = cpp_get_options (pfile);
|
||||||
|
size_t idx = (cpp_opts->objc ? 2: 0);
|
||||||
|
|
||||||
|
@@ -473,7 +473,7 @@ register_include_chains (cpp_reader *pfile, const char *sysroot,
|
||||||
|
|
||||||
|
/* CPATH and language-dependent environment variables may add to the
|
||||||
|
include chain. */
|
||||||
|
- add_env_var_paths ("CPATH", BRACKET);
|
||||||
|
+ add_env_var_paths ("CROSS_CPATH", BRACKET);
|
||||||
|
add_env_var_paths (lang_env_vars[idx], SYSTEM);
|
||||||
|
|
||||||
|
target_c_incpath.extra_pre_includes (sysroot, iprefix, stdinc);
|
||||||
|
diff --git a/gcc/system.h b/gcc/system.h
|
||||||
|
index 0cbf60a..3242c68 100644
|
||||||
|
--- a/gcc/system.h
|
||||||
|
+++ b/gcc/system.h
|
||||||
|
@@ -1169,4 +1169,6 @@ helper_const_non_const_cast (const char *p)
|
||||||
|
/* Get definitions of HOST_WIDE_INT. */
|
||||||
|
#include "hwint.h"
|
||||||
|
|
||||||
|
+#define LIBRARY_PATH_ENV "CROSS_LIBRARY_PATH"
|
||||||
|
+
|
||||||
|
#endif /* ! GCC_SYSTEM_H */
|
||||||
|
diff --git a/gcc/tlink.c b/gcc/tlink.c
|
||||||
|
index a2a7db0..2d96872 100644
|
||||||
|
--- a/gcc/tlink.c
|
||||||
|
+++ b/gcc/tlink.c
|
||||||
|
@@ -456,7 +456,7 @@ recompile_files (void)
|
||||||
|
file *f;
|
||||||
|
|
||||||
|
putenv (xstrdup ("COMPILER_PATH="));
|
||||||
|
- putenv (xstrdup ("LIBRARY_PATH="));
|
||||||
|
+ putenv (xstrdup (LIBRARY_PATH_ENV "="));
|
||||||
|
|
||||||
|
while ((f = file_pop ()) != NULL)
|
||||||
|
{
|
Reference in New Issue