me
/
guix
Archived
1
0
Fork 0

gnu: ceph: Fix breaking change in snappy.

* gnu/packages/storage.scm (ceph)[source]: Add patch.
* gnu/packages/patches/ceph-fix-snappy-breaking-change.patch: New file.
* gnu/local.mk: Add it.

Signed-off-by: Marius Bakke <marius@gnu.org>
master
Greg Hogan 2021-10-05 17:55:04 +00:00 committed by Marius Bakke
parent f86f7e24b3
commit 04c5d89482
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 18 additions and 1 deletions

View File

@ -919,6 +919,7 @@ dist_patch_DATA = \
%D%/packages/patches/cdparanoia-fpic.patch \
%D%/packages/patches/cdrtools-3.01-mkisofs-isoinfo.patch \
%D%/packages/patches/ceph-disable-cpu-optimizations.patch \
%D%/packages/patches/ceph-fix-snappy-breaking-change.patch \
%D%/packages/patches/chez-scheme-build-util-paths-backport.patch \
%D%/packages/patches/chmlib-inttypes.patch \
%D%/packages/patches/cl-asdf-config-directories.patch \

View File

@ -0,0 +1,13 @@
Patch tracked upstream at https://tracker.ceph.com/issues/50934
--- a/src/compressor/snappy/SnappyCompressor.h
+++ b/src/compressor/snappy/SnappyCompressor.h
@@ -96,7 +96,7 @@ class SnappyCompressor : public Compressor {
if (qat_enabled)
return qat_accel.decompress(p, compressed_len, dst);
#endif
- snappy::uint32 res_len = 0;
+ uint32_t res_len = 0;
BufferlistSource source_1(p, compressed_len);
if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
return -1;

View File

@ -2,6 +2,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@ -64,7 +65,9 @@
(base32
"0lmdri415hqczc9565s5m5568pnj97ipqxgnw6085kps0flwq5zh"))
(patches
(search-patches "ceph-disable-cpu-optimizations.patch"))
(search-patches
"ceph-disable-cpu-optimizations.patch"
"ceph-fix-snappy-breaking-change.patch"))
(modules '((guix build utils)))
(snippet
'(begin