me
/
guix
Archived
1
0
Fork 0

gnu: scilab: Improve package management robustness in scilab-cli.

* gnu/packages/maths.scm (scilab)[source]<origin>: Improve
  package management robustness in scilab-cli by allowing
  tbx_build_help to log the scilab mode incompatibility error and not
  process the rest of the function instead of failing with it.
* gnu/packages/patches/scilab-tbx_build_help.patch :
  Add patch.
* gnu/local.mk(dist_patch_DATA): Add
  gnu/packages/patches/scilab-tbx_build_help.patch.

Change-Id: I8ee94afb4aba906cbc8c7ca67f4c89aa0cf55ae6
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
Nicolas Graves 2024-04-10 09:15:15 +02:00 committed by Ludovic Courtès
parent 4dec5a30fe
commit 04d4e772e5
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 41 additions and 1 deletions

View File

@ -2051,6 +2051,7 @@ dist_patch_DATA = \
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
%D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scilab-better-compiler-detection.patch \
%D%/packages/patches/scilab-tbx_build_help.patch \
%D%/packages/patches/scons-test-environment.patch \
%D%/packages/patches/screen-hurd-path-max.patch \
%D%/packages/patches/scsh-nonstring-search-path.patch \

View File

@ -9724,7 +9724,8 @@ computation is supported via MPI.")
(sha256
(base32
"08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
(patches (search-patches "scilab-better-compiler-detection.patch"))
(patches (search-patches "scilab-better-compiler-detection.patch"
"scilab-tbx_build_help.patch"))
(modules '((guix build utils)
(ice-9 ftw)))
(snippet

View File

@ -0,0 +1,38 @@
From c59d78c5a5c8c187450f157cf7f8480455e8e6a2 Mon Sep 17 00:00:00 2001
From: Nicolas Graves <ngraves@ngraves.fr>
Date: Wed, 3 Apr 2024 03:32:23 +0200
Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
-nwni.
upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
---
.../modules_manager/macros/tbx_build_help.sci | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
index 7862e33a868..5593ee3dc04 100644
--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
+++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
@@ -58,12 +58,12 @@ function tbx_build_help(moduletitle, path)
// Check scilab mode
if and(getscilabmode() <> ["STD" "NW"]) then
- error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
+ msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
+ else
+ directory_language = basename(path);
+ default_language = "en_US"
+
+ xmltojar(path, moduletitle, directory_language, default_language);
end
- directory_language = basename(path);
- default_language = "en_US"
-
- xmltojar(path, moduletitle, directory_language, default_language);
-
endfunction
--
2.41.0