gnu: synfig, synfigstudio: Update to 1.2.2.
* gnu/packages/animation.scm (synfig-version): New variable. (etl)[version]: Use it. (synfig)[version]: Likewise. [source]: Update to 1.2.2. [native-inputs]: Add intltool. (synfigstudio)[version]: Use SYNFIG-VERSION. [source]: Update to 1.2.2. Remove obsolete patch. * gnu/packages/patches/synfigstudio-fix-ui-with-gtk3.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
36c8f1f1e6
commit
05f6b03217
|
@ -1281,7 +1281,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/swig-guile-gc.patch \
|
%D%/packages/patches/swig-guile-gc.patch \
|
||||||
%D%/packages/patches/swish-e-search.patch \
|
%D%/packages/patches/swish-e-search.patch \
|
||||||
%D%/packages/patches/swish-e-format-security.patch \
|
%D%/packages/patches/swish-e-format-security.patch \
|
||||||
%D%/packages/patches/synfigstudio-fix-ui-with-gtk3.patch \
|
|
||||||
%D%/packages/patches/stumpwm-fix-broken-read-one-line.patch \
|
%D%/packages/patches/stumpwm-fix-broken-read-one-line.patch \
|
||||||
%D%/packages/patches/t1lib-CVE-2010-2642.patch \
|
%D%/packages/patches/t1lib-CVE-2010-2642.patch \
|
||||||
%D%/packages/patches/t1lib-CVE-2011-0764.patch \
|
%D%/packages/patches/t1lib-CVE-2011-0764.patch \
|
||||||
|
|
|
@ -41,13 +41,15 @@
|
||||||
#:use-module (gnu packages qt)
|
#:use-module (gnu packages qt)
|
||||||
#:use-module (gnu packages video))
|
#:use-module (gnu packages video))
|
||||||
|
|
||||||
|
;; ETL, synfig, and Synfig Studio are updated in tandem.
|
||||||
|
(define synfig-version "1.2.2")
|
||||||
|
|
||||||
(define-public etl
|
(define-public etl
|
||||||
(package
|
(package
|
||||||
(name "etl")
|
(name "etl")
|
||||||
(version "1.2.2")
|
(version synfig-version)
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
;; Keep this synchronized with the synfig release version.
|
|
||||||
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
||||||
version "/source/ETL-" version ".tar.gz"))
|
version "/source/ETL-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
|
@ -65,7 +67,7 @@ C++ @dfn{Standard Template Library} (STL).")
|
||||||
(define-public synfig
|
(define-public synfig
|
||||||
(package
|
(package
|
||||||
(name "synfig")
|
(name "synfig")
|
||||||
(version "1.2.0")
|
(version synfig-version)
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
||||||
|
@ -73,7 +75,7 @@ C++ @dfn{Standard Template Library} (STL).")
|
||||||
".tar.gz"))
|
".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1gqx4gn4c73rqwhsgzx0a460gr9hadmi28csp75rx30qavqsj7k1"))))
|
"1vy27kl68sbg41sfasa58k3p2nc1xfalvzk3k9gich9h90rpnpsz"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
|
@ -131,7 +133,8 @@ C++ @dfn{Standard Template Library} (STL).")
|
||||||
("openexr" ,openexr)
|
("openexr" ,openexr)
|
||||||
("pango" ,pango)))
|
("pango" ,pango)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)))
|
`(("intltool" ,intltool)
|
||||||
|
("pkg-config" ,pkg-config)))
|
||||||
(home-page "https://www.synfig.org")
|
(home-page "https://www.synfig.org")
|
||||||
(synopsis "Vector-based 2D animation renderer")
|
(synopsis "Vector-based 2D animation renderer")
|
||||||
(description
|
(description
|
||||||
|
@ -143,7 +146,7 @@ for tweening, preventing the need to hand-draw each frame.")
|
||||||
(define-public synfigstudio
|
(define-public synfigstudio
|
||||||
(package
|
(package
|
||||||
(name "synfigstudio")
|
(name "synfigstudio")
|
||||||
(version "1.2.0")
|
(version synfig-version)
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
||||||
|
@ -151,16 +154,14 @@ for tweening, preventing the need to hand-draw each frame.")
|
||||||
".tar.gz"))
|
".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0fbckfbw8dzf0m2wv7vlmw492k1dqa3zf510z019d0as3zpnp6qm"))
|
"1ql92kh9z8w2j9yi3pr7hn7wh2r2j35xynwv9xlwyd7niackgykn"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
'(begin
|
'(begin
|
||||||
(substitute* "src/synfigapp/pluginmanager.cpp"
|
(substitute* "src/synfigapp/pluginmanager.cpp"
|
||||||
(("xmlpp::Node\\* n =") "const xmlpp::Node* n =")
|
(("xmlpp::Node\\* n =") "const xmlpp::Node* n =")
|
||||||
(("xmlpp::Node::NodeList") "xmlpp::Node::const_NodeList"))
|
(("xmlpp::Node::NodeList") "xmlpp::Node::const_NodeList"))
|
||||||
#t))
|
#t))))
|
||||||
(patches
|
|
||||||
(search-patches "synfigstudio-fix-ui-with-gtk3.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
|
|
|
@ -1,55 +0,0 @@
|
||||||
Downloaded from
|
|
||||||
https://github.com/synfig/synfig/commit/b9c3b73ee35b83c4d9183c800809040cef98b2f2.patch
|
|
||||||
|
|
||||||
Without this patch the UI of Synfig Studio (when built with the latest version
|
|
||||||
of GTK) displays very large buttons in the header of every frame.
|
|
||||||
|
|
||||||
This patch can be removed with the next release.
|
|
||||||
|
|
||||||
|
|
||||||
From b9c3b73ee35b83c4d9183c800809040cef98b2f2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: caryoscelus <caryoscelus@gmx.com>
|
|
||||||
Date: Wed, 25 Jan 2017 18:34:39 +0300
|
|
||||||
Subject: [PATCH] Fix dock drop area size
|
|
||||||
|
|
||||||
Fixes #227
|
|
||||||
|
|
||||||
By using Frame instead of Button we avoid intrusive Gtk themes
|
|
||||||
from forcing huge drop area size.
|
|
||||||
---
|
|
||||||
synfig-studio/src/gui/docks/dockdroparea.cpp | 15 ++++++++++-----
|
|
||||||
1 file changed, 10 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/gui/docks/dockdroparea.cpp b/synfig-studio/src/gui/docks/dockdroparea.cpp
|
|
||||||
index 0f8936fdb..e012282f0 100644
|
|
||||||
--- a/src/gui/docks/dockdroparea.cpp
|
|
||||||
+++ b/src/gui/docks/dockdroparea.cpp
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
#include "app.h"
|
|
||||||
#include "docks/dockdroparea.h"
|
|
||||||
#include "docks/dockmanager.h"
|
|
||||||
-#include <gtkmm/button.h>
|
|
||||||
+#include <gtkmm/frame.h>
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
@@ -61,10 +61,15 @@ DockDropArea::DockDropArea(Gtk::Widget *target):
|
|
||||||
std::vector<Gtk::TargetEntry> listTargets;
|
|
||||||
listTargets.push_back( Gtk::TargetEntry("SYNFIG_DOCK") );
|
|
||||||
|
|
||||||
- Gtk::Button *button_left = manage(new Gtk::Button());
|
|
||||||
- Gtk::Button *button_right = manage(new Gtk::Button());
|
|
||||||
- Gtk::Button *button_top = manage(new Gtk::Button());
|
|
||||||
- Gtk::Button *button_bottom = manage(new Gtk::Button());
|
|
||||||
+ Gtk::Frame *button_left = manage(new Gtk::Frame());
|
|
||||||
+ Gtk::Frame *button_right = manage(new Gtk::Frame());
|
|
||||||
+ Gtk::Frame *button_top = manage(new Gtk::Frame());
|
|
||||||
+ Gtk::Frame *button_bottom = manage(new Gtk::Frame());
|
|
||||||
+
|
|
||||||
+ button_left->set_size_request(20, 10);
|
|
||||||
+ button_right->set_size_request(20, 10);
|
|
||||||
+ button_top->set_size_request(20, 10);
|
|
||||||
+ button_bottom->set_size_request(20, 10);
|
|
||||||
|
|
||||||
button_left->drag_dest_set(listTargets);
|
|
||||||
button_right->drag_dest_set(listTargets);
|
|
Reference in New Issue