me
/
guix
Archived
1
0
Fork 0

gnu: ocaml-piqilib: Update to 0.6.15.

* gnu/packages/ocaml.scm (ocaml-piqilib): Update to 0.6.15.
[source]: Remove patch.
[native-inputs]: Remove camlp4.
[propagated-inputs]: Replace ulex with sedlex.
* gnu/packages/patches/ocaml-piqilib-Update-base64.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Julien Lepiller 2019-11-27 21:41:09 +01:00
parent 98a468ffd2
commit 05fe0a587a
No known key found for this signature in database
GPG Key ID: 43111F4520086A0C
3 changed files with 7 additions and 57 deletions

View File

@ -1195,7 +1195,6 @@ dist_patch_DATA = \
%D%/packages/patches/ocaml-dose3-Fix-for-ocaml-4.06.patch \
%D%/packages/patches/ocaml-dose3-dont-make-printconf.patch \
%D%/packages/patches/ocaml-dose3-Install-mli-cmx-etc.patch \
%D%/packages/patches/ocaml-piqilib-Update-base64.patch \
%D%/packages/patches/omake-fix-non-determinism.patch \
%D%/packages/patches/ola-readdir-r.patch \
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \

View File

@ -2821,7 +2821,7 @@ Format module of the OCaml standard library.")
(define-public ocaml-piqilib
(package
(name "ocaml-piqilib")
(version "0.6.14")
(version "0.6.15")
(source
(origin
(method git-fetch)
@ -2830,9 +2830,7 @@ Format module of the OCaml standard library.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0lyqllmfsxmwlg7qidy92kvxi9n39lvachmydcyi81f8p07ykd2d"))
(patches
(search-patches "ocaml-piqilib-Update-base64.patch"))))
(base32 "0v04hs85xv6d4ysqxyv1dik34dx49yab9shpi4x7iv19qlzl7csb"))))
(build-system ocaml-build-system)
(arguments
`(#:phases
@ -2868,13 +2866,12 @@ Format module of the OCaml standard library.")
(string-append stubs "/dllpiqilib_stubs.so"))
#t))))))
(native-inputs
`(("which" ,which)
("camlp4" ,camlp4)))
`(("which" ,which)))
(propagated-inputs
`(("xmlm" ,ocaml-xmlm)
("ulex" ,ocaml-ulex)
("easy-format" ,ocaml-easy-format)
("base64" ,ocaml-base64)))
`(("ocaml-xmlm" ,ocaml-xmlm)
("ocaml-sedlex" ,ocaml-sedlex)
("ocaml-easy-format" ,ocaml-easy-format)
("ocaml-base64" ,ocaml-base64)))
(home-page "http://piqi.org")
(synopsis "Data serialization and conversion library")
(description "Piqilib is the common library used by the piqi command-line

View File

@ -1,46 +0,0 @@
From 98abdbff3d5316a75f27d6a76fe09317d56f2a38 Mon Sep 17 00:00:00 2001
From: Vincent Bernardoff <vb@luminar.eu.org>
Date: Sun, 10 Feb 2019 14:47:07 +0100
Subject: [PATCH] Fix compilation with newer base64 versions
---
opam | 2 +-
piqilib/piqi_base64.ml | 9 ++++-----
2 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/opam b/opam
index 3a9128e..bb5a53f 100644
--- a/opam
+++ b/opam
@@ -26,6 +26,6 @@ depends: [
"easy-format"
"ulex"
"xmlm"
- "base64" {>="2.0.0"}
+ "base64" {>="3.1.0"}
]
dev-repo: "git://github.com/alavrik/piqi"
diff --git a/piqilib/piqi_base64.ml b/piqilib/piqi_base64.ml
index c5a6ae7..a98346e 100644
--- a/piqilib/piqi_base64.ml
+++ b/piqilib/piqi_base64.ml
@@ -18,12 +18,11 @@
(* TODO: add more base64 validation; the base64 library doesn't do any
* validation *)
let decode x =
- try
- B64.decode x
- with _ ->
- invalid_arg "Piqi_base64.decode"
+ match Base64.decode x with
+ | Error _ -> invalid_arg "Piqi_base64.decode"
+ | Ok v -> v
let encode x =
- B64.encode x
+ Base64.encode_exn x
--
2.21.0