gnu: mit-krb5: Update to 1.19.1.
* gnu/packages/patches/mit-krb5-hurd.patch: Adjust for 1.19.1. * gnu/packages/patches/mit-krb5-qualify-short-hostnames.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/kerberos.scm (mit-krb5): Update to 1.19.1. [source](patches): Remove obsolete patch. [arguments]: Remove trailing #t's and one obsolete subtitution.master
parent
5492b1b50c
commit
0689e1abed
|
@ -1397,7 +1397,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/minisat-friend-declaration.patch \
|
%D%/packages/patches/minisat-friend-declaration.patch \
|
||||||
%D%/packages/patches/minisat-install.patch \
|
%D%/packages/patches/minisat-install.patch \
|
||||||
%D%/packages/patches/mit-krb5-hurd.patch \
|
%D%/packages/patches/mit-krb5-hurd.patch \
|
||||||
%D%/packages/patches/mit-krb5-qualify-short-hostnames.patch \
|
|
||||||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||||
%D%/packages/patches/mpg321-CVE-2019-14247.patch \
|
%D%/packages/patches/mpg321-CVE-2019-14247.patch \
|
||||||
%D%/packages/patches/module-init-tools-moduledir.patch \
|
%D%/packages/patches/module-init-tools-moduledir.patch \
|
||||||
|
|
|
@ -54,7 +54,7 @@
|
||||||
(define-public mit-krb5
|
(define-public mit-krb5
|
||||||
(package
|
(package
|
||||||
(name "mit-krb5")
|
(name "mit-krb5")
|
||||||
(version "1.18")
|
(version "1.19.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (list
|
(uri (list
|
||||||
|
@ -64,11 +64,10 @@
|
||||||
(string-append "https://kerberos.org/dist/krb5/"
|
(string-append "https://kerberos.org/dist/krb5/"
|
||||||
(version-major+minor version)
|
(version-major+minor version)
|
||||||
"/krb5-" version ".tar.gz")))
|
"/krb5-" version ".tar.gz")))
|
||||||
(patches (search-patches "mit-krb5-qualify-short-hostnames.patch"
|
(patches (search-patches "mit-krb5-hurd.patch"))
|
||||||
"mit-krb5-hurd.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"121c5xsy3x0i4wdkrpw62yhvji6virbh6n30ypazkp0isws3k4bk"))))
|
"02xjpsfy84l6v7vjlxzhrl6mx2zrmxz0v01w2j33bv73nxzgh5ps"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("bison" ,bison)
|
`(("bison" ,bison)
|
||||||
|
@ -99,20 +98,14 @@
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(add-after 'unpack 'enter-source-directory
|
(add-after 'unpack 'enter-source-directory
|
||||||
(lambda _
|
(lambda _
|
||||||
(chdir "src")
|
(chdir "src")))
|
||||||
#t))
|
|
||||||
(add-before 'check 'pre-check
|
(add-before 'check 'pre-check
|
||||||
(lambda* (#:key inputs native-inputs #:allow-other-keys)
|
(lambda* (#:key inputs native-inputs #:allow-other-keys)
|
||||||
(let ((perl (assoc-ref (or native-inputs inputs) "perl")))
|
(let ((perl (assoc-ref (or native-inputs inputs) "perl")))
|
||||||
(substitute* "plugins/kdb/db2/libdb2/test/run.test"
|
(substitute* "plugins/kdb/db2/libdb2/test/run.test"
|
||||||
(("/bin/cat") (string-append perl "/bin/perl"))
|
(("/bin/cat") (string-append perl "/bin/perl"))
|
||||||
(("D/bin/sh") (string-append "D" (which "sh")))
|
(("D/bin/sh") (string-append "D" (which "sh")))
|
||||||
(("bindir=/bin/.") (string-append "bindir=" perl "/bin"))))
|
(("bindir=/bin/.") (string-append "bindir=" perl "/bin")))))))))
|
||||||
|
|
||||||
;; avoid service names since /etc/services is unavailable
|
|
||||||
(substitute* "tests/resolve/Makefile"
|
|
||||||
(("-p telnet") "-p 23"))
|
|
||||||
#t)))))
|
|
||||||
(synopsis "MIT Kerberos 5")
|
(synopsis "MIT Kerberos 5")
|
||||||
(description
|
(description
|
||||||
"Massachusetts Institute of Technology implementation of Kerberos.
|
"Massachusetts Institute of Technology implementation of Kerberos.
|
||||||
|
|
|
@ -148,18 +148,3 @@ index 7e981d4..d83b3b6 100644
|
||||||
+# define MAXPATHLEN 4096
|
+# define MAXPATHLEN 4096
|
||||||
+#endif
|
+#endif
|
||||||
#endif /* _DB_INT_H_ */
|
#endif /* _DB_INT_H_ */
|
||||||
diff --git a/src/tests/resolve/resolve.c b/src/tests/resolve/resolve.c
|
|
||||||
index 7339d21..38f7253 100644
|
|
||||||
--- a/src/tests/resolve/resolve.c
|
|
||||||
+++ b/src/tests/resolve/resolve.c
|
|
||||||
@@ -73,6 +73,10 @@ char *strchr();
|
|
||||||
#include <netinet/in.h>
|
|
||||||
#include <netdb.h>
|
|
||||||
|
|
||||||
+#ifndef MAXHOSTNAMELEN
|
|
||||||
+# define MAXHOSTNAMELEN 256
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
int
|
|
||||||
main(argc, argv)
|
|
||||||
int argc;
|
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
Fix a null pointer dereference when no DNS search path is configured.
|
|
||||||
This showed up as a segfault while running the gsasl test suite.
|
|
||||||
|
|
||||||
Taken from upstream:
|
|
||||||
https://github.com/krb5/krb5/commit/cd82bf377e7fad2409c76bf8b241920692f34fda
|
|
||||||
|
|
||||||
diff --git a/src/lib/krb5/os/dnsglue.c b/src/lib/krb5/os/dnsglue.c
|
|
||||||
index e35ca9d76c..0cd213fdd7 100644
|
|
||||||
--- a/src/lib/krb5/os/dnsglue.c
|
|
||||||
+++ b/src/lib/krb5/os/dnsglue.c
|
|
||||||
@@ -91,7 +91,7 @@ static int initparse(struct krb5int_dns_state *);
|
|
||||||
#define DECLARE_HANDLE(h) struct __res_state h
|
|
||||||
#define INIT_HANDLE(h) (memset(&h, 0, sizeof(h)), res_ninit(&h) == 0)
|
|
||||||
#define SEARCH(h, n, c, t, a, l) res_nsearch(&h, n, c, t, a, l)
|
|
||||||
-#define PRIMARY_DOMAIN(h) strdup(h.dnsrch[0])
|
|
||||||
+#define PRIMARY_DOMAIN(h) ((h.dnsrch[0] == NULL) ? NULL : strdup(h.dnsrch[0]))
|
|
||||||
#if HAVE_RES_NDESTROY
|
|
||||||
#define DESTROY_HANDLE(h) res_ndestroy(&h)
|
|
||||||
#else
|
|
||||||
@@ -104,7 +104,8 @@ static int initparse(struct krb5int_dns_state *);
|
|
||||||
#define DECLARE_HANDLE(h)
|
|
||||||
#define INIT_HANDLE(h) (res_init() == 0)
|
|
||||||
#define SEARCH(h, n, c, t, a, l) res_search(n, c, t, a, l)
|
|
||||||
-#define PRIMARY_DOMAIN(h) strdup(_res.defdname)
|
|
||||||
+#define PRIMARY_DOMAIN(h) \
|
|
||||||
+ ((_res.defdname == NULL) ? NULL : strdup(_res.defdname))
|
|
||||||
#define DESTROY_HANDLE(h)
|
|
||||||
|
|
||||||
#endif
|
|
Reference in New Issue