me
/
guix
Archived
1
0
Fork 0

gnu: make-bootstrap: Adapt glibc-bootstrap-system.patch for glibc-2.27.

* gnu/packages/patches/glibc-bootstrap-system.patch: Adapt for glibc-2.27.
master
Mark H Weaver 2018-03-25 02:31:49 -04:00
parent 0bc7c2e43d
commit 06b1d6954a
No known key found for this signature in database
GPG Key ID: 7CEF29847562C516
1 changed files with 7 additions and 7 deletions

View File

@ -15,16 +15,16 @@ instead uses the hard-coded absolute file name of `bash'.
} }
else if (pid < (pid_t) 0) else if (pid < (pid_t) 0)
--- b/libio/iopopen.c 2012-06-30 21:12:34.000000000 +0200 --- a/libio/iopopen.c
+++ b/libio/iopopen.c 2012-12-19 12:52:29.000000000 +0100 +++ b/libio/iopopen.c
@@ -226,7 +226,7 @@ _IO_new_proc_open (fp, command, mode) @@ -145,7 +145,7 @@ _IO_new_proc_open (fp, command, mode)
_IO_close (fd); __close_nocancel (fd);
} }
- _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0); - execl ("/bin/sh", "sh", "-c", command, (char *) 0);
+ execlp ("sh", "sh", "-c", command, (char *) 0); + execlp ("sh", "sh", "-c", command, (char *) 0);
_IO__exit (127); _exit (127);
} }
_IO_close (child_end); __close_nocancel (child_end);