gnu: sssd: Fix build with glibc-2.33
* gnu/packages/patches/sssd-collision-with-external-nss-symbol.patch: Commit from sssd repo * gnu/packages/sssd.scm: Add patch Signed-off-by: Ludovic Courtès <ludo@gnu.org>master
parent
59362e928e
commit
08b0f5c2a5
|
@ -1591,6 +1591,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/sdl-pango-sans-serif.patch \
|
||||
%D%/packages/patches/smalltalk-multiplication-overflow.patch \
|
||||
%D%/packages/patches/sqlite-hurd.patch \
|
||||
%D%/packages/patches/sssd-collision-with-external-nss-symbol.patch \
|
||||
%D%/packages/patches/strace-readlink-tests.patch \
|
||||
%D%/packages/patches/sunxi-tools-remove-sys-io.patch \
|
||||
%D%/packages/patches/p11-kit-hurd.patch \
|
||||
|
|
|
@ -0,0 +1,71 @@
|
|||
From fe9eeb51be06059721e873f77092b1e9ba08e6c1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Michal=20=C5=BDidek?= <mzidek@redhat.com>
|
||||
Date: Thu, 27 Feb 2020 06:50:40 +0100
|
||||
Subject: [PATCH] nss: Collision with external nss symbol
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
One of our internal static function names started
|
||||
to collide with external nss symbol. Additional
|
||||
sss_ suffix was added to avoid the collision.
|
||||
|
||||
This is needed to unblock Fedora Rawhide's
|
||||
SSSD build.
|
||||
|
||||
Reviewed-by: Pavel Březina <pbrezina@redhat.com>
|
||||
---
|
||||
src/responder/nss/nss_cmd.c | 18 ++++++++++--------
|
||||
1 file changed, 10 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/responder/nss/nss_cmd.c b/src/responder/nss/nss_cmd.c
|
||||
index 356aea1564..02706c4b94 100644
|
||||
--- a/src/responder/nss/nss_cmd.c
|
||||
+++ b/src/responder/nss/nss_cmd.c
|
||||
@@ -731,11 +731,13 @@ static void nss_getent_done(struct tevent_req *subreq)
|
||||
talloc_free(cmd_ctx);
|
||||
}
|
||||
|
||||
-static void nss_setnetgrent_done(struct tevent_req *subreq);
|
||||
+static void sss_nss_setnetgrent_done(struct tevent_req *subreq);
|
||||
|
||||
-static errno_t nss_setnetgrent(struct cli_ctx *cli_ctx,
|
||||
- enum cache_req_type type,
|
||||
- nss_protocol_fill_packet_fn fill_fn)
|
||||
+/* This function's name started to collide with external nss symbol,
|
||||
+ * so it has additional sss_* prefix unlike other functions here. */
|
||||
+static errno_t sss_nss_setnetgrent(struct cli_ctx *cli_ctx,
|
||||
+ enum cache_req_type type,
|
||||
+ nss_protocol_fill_packet_fn fill_fn)
|
||||
{
|
||||
struct nss_ctx *nss_ctx;
|
||||
struct nss_state_ctx *state_ctx;
|
||||
@@ -777,7 +779,7 @@ static errno_t nss_setnetgrent(struct cli_ctx *cli_ctx,
|
||||
goto done;
|
||||
}
|
||||
|
||||
- tevent_req_set_callback(subreq, nss_setnetgrent_done, cmd_ctx);
|
||||
+ tevent_req_set_callback(subreq, sss_nss_setnetgrent_done, cmd_ctx);
|
||||
|
||||
ret = EOK;
|
||||
|
||||
@@ -790,7 +792,7 @@ static errno_t nss_setnetgrent(struct cli_ctx *cli_ctx,
|
||||
return EOK;
|
||||
}
|
||||
|
||||
-static void nss_setnetgrent_done(struct tevent_req *subreq)
|
||||
+static void sss_nss_setnetgrent_done(struct tevent_req *subreq)
|
||||
{
|
||||
struct nss_cmd_ctx *cmd_ctx;
|
||||
errno_t ret;
|
||||
@@ -1040,8 +1042,8 @@ static errno_t nss_cmd_initgroups_ex(struct cli_ctx *cli_ctx)
|
||||
|
||||
static errno_t nss_cmd_setnetgrent(struct cli_ctx *cli_ctx)
|
||||
{
|
||||
- return nss_setnetgrent(cli_ctx, CACHE_REQ_NETGROUP_BY_NAME,
|
||||
- nss_protocol_fill_setnetgrent);
|
||||
+ return sss_nss_setnetgrent(cli_ctx, CACHE_REQ_NETGROUP_BY_NAME,
|
||||
+ nss_protocol_fill_setnetgrent);
|
||||
}
|
||||
|
||||
static errno_t nss_cmd_getnetgrent(struct cli_ctx *cli_ctx)
|
|
@ -3,6 +3,7 @@
|
|||
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2021 Timotej Lazar <timotej.lazar@araneo.si>
|
||||
;;; Copyright © 2021 Remco van 't Veer <remco@remworks.net>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -150,7 +151,8 @@ fundamental object types for C.")
|
|||
(base32
|
||||
"1h6hwibaf3xa2w6qpzjiiywmfj6zkgbz4r2isf3gd0xm6vq7n6if"))
|
||||
(patches (search-patches "sssd-fix-samba.patch"
|
||||
"sssd-system-directories.patch"))))
|
||||
"sssd-system-directories.patch"
|
||||
"sssd-collision-with-external-nss-symbol.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:make-flags
|
||||
|
|
Reference in New Issue