gnu: Add opensles.
* gnu/packages/audio.scm (opensles): New variable. * gnu/packages/patches/opensles-add-license-file.patch: New file. * gnu/local.mk (opensles-add-license-file.patch): New reference. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>master
parent
7508378d1f
commit
08d048a06b
|
@ -1371,6 +1371,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openssh-hurd.patch \
|
%D%/packages/patches/openssh-hurd.patch \
|
||||||
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
||||||
%D%/packages/patches/openscad-parser-boost-1.72.patch \
|
%D%/packages/patches/openscad-parser-boost-1.72.patch \
|
||||||
|
%D%/packages/patches/opensles-add-license-file.patch \
|
||||||
%D%/packages/patches/openssl-runpath.patch \
|
%D%/packages/patches/openssl-runpath.patch \
|
||||||
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
|
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
|
||||||
%D%/packages/patches/openssl-c-rehash-in.patch \
|
%D%/packages/patches/openssl-c-rehash-in.patch \
|
||||||
|
|
|
@ -129,6 +129,68 @@
|
||||||
#:use-module (srfi srfi-1)
|
#:use-module (srfi srfi-1)
|
||||||
#:use-module (srfi srfi-26))
|
#:use-module (srfi srfi-26))
|
||||||
|
|
||||||
|
(define-public opensles
|
||||||
|
(package
|
||||||
|
(name "opensles")
|
||||||
|
(version "1.1.0")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method git-fetch)
|
||||||
|
(uri
|
||||||
|
(git-reference
|
||||||
|
(url "https://github.com/KhronosGroup/OpenSL-ES-Registry.git")
|
||||||
|
(commit "ea5104bf37bf525c25e6ae2386586048179d0fda")))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
|
(sha256
|
||||||
|
(base32 "0j5bm7h3ahz66f23i9abwc0y10agfkpksnj6y078x2nichq66h4f"))
|
||||||
|
(patches
|
||||||
|
(search-patches "opensles-add-license-file.patch"))))
|
||||||
|
(build-system copy-build-system)
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'install 'clean
|
||||||
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
|
(let* ((out (assoc-ref outputs "out")))
|
||||||
|
(mkdir-p (string-append out "/etc"))
|
||||||
|
(mkdir-p (string-append out "/include"))
|
||||||
|
(mkdir-p (string-append out "/share"))
|
||||||
|
(rename-file
|
||||||
|
(string-append out "/api/1.1/OpenSLES_IID.c")
|
||||||
|
(string-append out "/etc/OpenSLES_IID.c"))
|
||||||
|
(rename-file
|
||||||
|
(string-append out "/api/1.1/OpenSLES.h")
|
||||||
|
(string-append out "/include/OpenSLES.h"))
|
||||||
|
(rename-file
|
||||||
|
(string-append out "/api/1.1/OpenSLES_Platform.h")
|
||||||
|
(string-append out "/include/OpenSLES_Platform.h"))
|
||||||
|
(rename-file
|
||||||
|
(string-append out "/api/1.1/README.txt")
|
||||||
|
(string-append out "/share/README.txt"))
|
||||||
|
(rename-file
|
||||||
|
(string-append out "/LICENSE.txt")
|
||||||
|
(string-append out "/share/LICENSE.txt"))
|
||||||
|
(for-each delete-file-recursively
|
||||||
|
(list
|
||||||
|
(string-append out "/api")
|
||||||
|
(string-append out "/specs")))
|
||||||
|
(for-each delete-file
|
||||||
|
(list
|
||||||
|
(string-append out "/CODE_OF_CONDUCT.md")
|
||||||
|
(string-append out "/index.php")
|
||||||
|
(string-append out "/README.md"))))
|
||||||
|
#t)))))
|
||||||
|
(synopsis "Embedded Audio Acceleration")
|
||||||
|
(description "OpenSLES is a royalty-free, cross-platform,
|
||||||
|
hardware-accelerated audio API tuned for embedded systems. It provides a
|
||||||
|
standardized, high-performance, low-latency method to access audio
|
||||||
|
functionality for developers of native applications on embedded mobile
|
||||||
|
multimedia devices, enabling straightforward cross-platform deployment of
|
||||||
|
hardware and software audio capabilities, reducing implementation effort, and
|
||||||
|
promoting the market for advanced audio.")
|
||||||
|
(home-page "https://www.khronos.org/opensles/")
|
||||||
|
(license (license:non-copyleft "file:///LICENSE.txt"))))
|
||||||
|
|
||||||
(define-public wildmidi
|
(define-public wildmidi
|
||||||
(package
|
(package
|
||||||
(name "wildmidi")
|
(name "wildmidi")
|
||||||
|
|
|
@ -0,0 +1,45 @@
|
||||||
|
From 3a78134a35b448d9d4136ffbc55175be7fab6644 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Raghav Gururajan <raghavgururajan@disroot.org>
|
||||||
|
Date: Mon, 6 Jul 2020 00:34:20 -0400
|
||||||
|
Subject: [PATCH] [PATCH]: Add license file.
|
||||||
|
|
||||||
|
---
|
||||||
|
LICENSE.txt | 25 +++++++++++++++++++++++++
|
||||||
|
1 file changed, 25 insertions(+)
|
||||||
|
create mode 100644 LICENSE.txt
|
||||||
|
|
||||||
|
diff --git a/LICENSE.txt b/LICENSE.txt
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..0fce823
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/LICENSE.txt
|
||||||
|
@@ -0,0 +1,25 @@
|
||||||
|
+/*
|
||||||
|
+ * Copyright (c) 2007-2011 The Khronos Group Inc.
|
||||||
|
+ *
|
||||||
|
+ * Permission is hereby granted, free of charge, to any person obtaining a copy of
|
||||||
|
+ * this software and /or associated documentation files (the "Materials "), to
|
||||||
|
+ * deal in the Materials without restriction, including without limitation the
|
||||||
|
+ * rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
|
||||||
|
+ * sell copies of the Materials, and to permit persons to whom the Materials are
|
||||||
|
+ * furnished to do so, subject to
|
||||||
|
+ * the following conditions:
|
||||||
|
+ *
|
||||||
|
+ * The above copyright notice and this permission notice shall be included
|
||||||
|
+ * in all copies or substantial portions of the Materials.
|
||||||
|
+ *
|
||||||
|
+ * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
|
||||||
|
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
||||||
|
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
|
||||||
|
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
||||||
|
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||||
|
+ * OUT OF OR IN CONNECTION WITH THE MATERIALS OR THE USE OR OTHER DEALINGS IN THE
|
||||||
|
+ * MATERIALS.
|
||||||
|
+ *
|
||||||
|
+ * OpenSLES_IID.c - OpenSL ES version 1.1
|
||||||
|
+ *
|
||||||
|
+ */
|
||||||
|
\ No newline at end of file
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
Reference in New Issue