me
/
guix
Archived
1
0
Fork 0

gnu: glib-networking: Update to 2.76.1.

* gnu/packages/gnome.scm (glib-networking): Update to 2.76.1.
[patches]: Remove.
[native-inputs]: Add glib-bin.
* gnu/packages/patches/glib-networking-gnutls-binding.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Unregister it.

Change-Id: I1c7249995d07d975ac3d3df8ce1e07ffa4dc240f
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
master
Vivien Kraus 2023-11-14 12:35:10 +01:00 committed by Liliana Marie Prikler
parent 5c43c2ddf3
commit 092bc86a41
No known key found for this signature in database
GPG Key ID: 442A84B8C70E2F87
3 changed files with 4 additions and 27 deletions

View File

@ -1291,7 +1291,6 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
%D%/packages/patches/gklib-suitesparse.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-networking-gnutls-binding.patch \
%D%/packages/patches/glib-skip-failing-test.patch \
%D%/packages/patches/glibc-2.33-riscv64-miscompilation.patch \
%D%/packages/patches/glibc-CVE-2019-7309.patch \

View File

@ -4812,7 +4812,7 @@ indicators etc).")
(define-public glib-networking
(package
(name "glib-networking")
(version "2.72.2")
(version "2.76.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glib-networking/"
@ -4820,12 +4820,11 @@ indicators etc).")
"glib-networking-" version ".tar.xz"))
(sha256
(base32
"0s42l6dkajciqc99zp6dc9l8yv9g8w7d8mgv97l7h7drgd60hand"))
(patches
(search-patches "glib-networking-gnutls-binding.patch"))))
"0ax4h0abi9yxrpmm1p491qjxc8d2k1kaa9hhzgyixrfxjjcqlsaw"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config gettext-minimal))
(list `(,glib "bin") ; for gio-querymodules
pkg-config gettext-minimal))
(inputs
(list glib gnutls gsettings-desktop-schemas libproxy))
(home-page "https://wiki.gnome.org/Projects/GLib")

View File

@ -1,21 +0,0 @@
Skip failing test in 'test_connection_binding_match_tls_unique'
in 'tls/tests/connection.c' when building glib-networking against
GnuTLS 3.7.2. The failure stems from the fact that
'gnutls_session_channel_binding' returns GNUTLS_E_INVALID_REQUEST
is known upstream:
https://gitlab.gnome.org/GNOME/glib-networking/-/issues/164
diff --git a/tls/tests/connection.c b/tls/tests/connection.c
index 036df04..347c7a4 100644
--- a/tls/tests/connection.c
+++ b/tls/tests/connection.c
@@ -3037,8 +3037,6 @@ main (int argc,
setup_connection, test_connection_missing_server_identity, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/peer-certificate-notify", TestConnection, NULL,
setup_connection, test_peer_certificate_notify, teardown_connection);
- g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-unique", TestConnection, NULL,
- setup_connection, test_connection_binding_match_tls_unique, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-server-end-point", TestConnection, NULL,
setup_connection, test_connection_binding_match_tls_server_end_point, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-exporter", TestConnection, NULL,