me
/
guix
Archived
1
0
Fork 0

gnu: ungoogled-chromium: Update to 101.0.4951.41-1.

* gnu/packages/chromium.scm (%preserved-third-party-files): Include bundled
Vulkan headers.
(%chromium-version): Set to 101.0.4951.41.
(%debian-revision): Set to debian/101.0.4951.41-2.
(%debian-patches): Add one new patch.
(%ungoogled-origin, ungoogled-chromium): Update hashes.
* gnu/packages/patches/ungoogled-chromium-system-nspr.patch: Refresh.
master
Marius Bakke 2022-05-01 22:22:20 +02:00
parent fee06d5aaa
commit 098f2eea33
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 15 additions and 12 deletions

View File

@ -129,7 +129,8 @@
"third_party/cros_system_api" ;BSD-3
"third_party/dav1d" ;BSD-2
"third_party/dawn" ;ASL2.0
"third_party/dawn/third_party/khronos/gl.xml" ;ASL2.0
;; TODO: can likely be unbundled when Vulkan is updated.
"third_party/dawn/third_party/khronos" ;ASL2.0
"third_party/dawn/third_party/tint" ;ASL2.0
"third_party/depot_tools/owners.py" ;BSD-3
"third_party/devtools-frontend" ;BSD-3
@ -312,9 +313,9 @@
;; run the Blink performance tests, just remove everything to save ~70MiB.
'("third_party/blink/perf_tests"))
(define %chromium-version "100.0.4896.127")
(define %chromium-version "101.0.4951.41")
(define %ungoogled-revision (string-append %chromium-version "-1"))
(define %debian-revision "debian/100.0.4896.60-1")
(define %debian-revision "debian/101.0.4951.41-2")
(define %ungoogled-origin
(origin
@ -324,7 +325,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
"192kyhr0fa97csciv5kp496y9zwcsknwlrmdr4jic3rvv8ig1q9y"))))
"19m31bd04yvba3w5iymkxfjnmilas3cfp383m9fl6pd4wwhy9md0"))))
(define* (debian-patch name hash #:optional (revision %debian-revision))
(origin
@ -337,7 +338,9 @@
(sha256 (base32 hash))))
(define %debian-patches
(list (debian-patch "system/jsoncpp.patch"
(list (debian-patch "upstream/libxml.patch"
"0fnmidh3sbmi4khw25rpqpd4i9kj8rb42s40n242h55z30hc36qr")
(debian-patch "system/jsoncpp.patch"
"092jkvbkiw474lin62hbkv5vm251qpg0vz3j2qwavqln7qv6mcw1")
(debian-patch "system/zlib.patch"
"1iw4k8in5j6a1qxf12qd5z3sjayvnh5sq5z3qqg8m3cp0v4p947r")
@ -451,7 +454,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
"0kgq38dy9mjyc44556i9gxhlsgd7dfvv1xi1ibk92b4p7i2y6427"))
"0dzsbr309n70jg7fpq2qfnrgcm4553akvdmnzhss1fc85s467609"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)

View File

@ -6,8 +6,8 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
diff --git a/base/BUILD.gn b/base/BUILD.gn
--- a/base/BUILD.gn
+++ b/base/BUILD.gn
@@ -141,6 +141,12 @@ config("perfetto_config") {
}
@@ -184,6 +184,12 @@ buildflag_header("ios_cronet_buildflags") {
flags = [ "CRONET_BUILD=$is_cronet_build" ]
}
+if (is_linux) {
@ -19,7 +19,7 @@ diff --git a/base/BUILD.gn b/base/BUILD.gn
# Base and everything it depends on should be a static library rather than
# a source set. Base is more of a "library" in the classic sense in that many
# small parts of it are used in many different contexts. This combined with a
@@ -759,8 +765,6 @@ component("base") {
@@ -838,8 +844,6 @@ mixed_component("base") {
"third_party/cityhash_v103/src/city_v103.cc",
"third_party/cityhash_v103/src/city_v103.h",
"third_party/icu/icu_utf.h",
@ -31,10 +31,10 @@ diff --git a/base/BUILD.gn b/base/BUILD.gn
diff --git a/base/time/pr_time_unittest.cc b/base/time/pr_time_unittest.cc
--- a/base/time/pr_time_unittest.cc
+++ b/base/time/pr_time_unittest.cc
@@ -7,7 +7,7 @@
@@ -6,7 +6,7 @@
#include <time.h>
#include "base/compiler_specific.h"
#include "base/cxx17_backports.h"
-#include "base/third_party/nspr/prtime.h"
+#include <nspr/prtime.h>
#include "base/time/time.h"
@ -43,7 +43,7 @@ diff --git a/base/time/pr_time_unittest.cc b/base/time/pr_time_unittest.cc
diff --git a/base/time/time.cc b/base/time/time.cc
--- a/base/time/time.cc
+++ b/base/time/time.cc
@@ -18,7 +18,7 @@
@@ -21,7 +21,7 @@
#include <utility>
#include "base/strings/stringprintf.h"