gnu: QEMU: Update to 6.1.0.
* gnu/packages/virtualization.scm (qemu): Update to 6.1.0. [source](patches): Remove obsolete patch. [arguments]: Adjust substitutions for upstream changes. [native-inputs]: Add PYTHON-SPHINX-RTD-THEME. * gnu/packages/patches/qemu-meson-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.master
parent
89ea3ab220
commit
0b5e128750
|
@ -1689,7 +1689,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-waitress-fix-tests.patch \
|
||||
%D%/packages/patches/qemu-build-info-manual.patch \
|
||||
%D%/packages/patches/qemu-CVE-2021-20203.patch \
|
||||
%D%/packages/patches/qemu-meson-compat.patch \
|
||||
%D%/packages/patches/qemu-sphinx-compat.patch \
|
||||
%D%/packages/patches/qemu-glibc-2.27.patch \
|
||||
%D%/packages/patches/qemu-glibc-2.30.patch \
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
Fix a build failure that occurs with newer versions of Meson when
|
||||
gdbus-codegen is unavailable.
|
||||
|
||||
Taken from upstream:
|
||||
https://gitlab.com/qemu-project/qemu/-/commit/5ecfb76ccc056eb6127e44268e475827ae73b9e0
|
||||
|
||||
diff --git a/configure b/configure
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3341,7 +3341,7 @@ if ! test "$gio" = "no"; then
|
||||
gio_cflags=$($pkg_config --cflags gio-2.0)
|
||||
gio_libs=$($pkg_config --libs gio-2.0)
|
||||
gdbus_codegen=$($pkg_config --variable=gdbus_codegen gio-2.0)
|
||||
- if [ ! -x "$gdbus_codegen" ]; then
|
||||
+ if ! has "$gdbus_codegen"; then
|
||||
gdbus_codegen=
|
||||
fi
|
||||
# Check that the libraries actually work -- Ubuntu 18.04 ships
|
||||
@@ -5704,6 +5704,8 @@ if test "$gio" = "yes" ; then
|
||||
echo "CONFIG_GIO=y" >> $config_host_mak
|
||||
echo "GIO_CFLAGS=$gio_cflags" >> $config_host_mak
|
||||
echo "GIO_LIBS=$gio_libs" >> $config_host_mak
|
||||
+fi
|
||||
+if test "$gdbus_codegen" != "" ; then
|
||||
echo "GDBUS_CODEGEN=$gdbus_codegen" >> $config_host_mak
|
||||
fi
|
||||
echo "CONFIG_TLS_PRIORITY=\"$tls_priority\"" >> $config_host_mak
|
|
@ -149,7 +149,7 @@
|
|||
(define-public qemu
|
||||
(package
|
||||
(name "qemu")
|
||||
(version "6.0.0")
|
||||
(version "6.1.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -157,9 +157,8 @@
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1f9hz8rf12jm8baa7kda34yl4hyl0xh0c4ap03krfjx23i3img47"))
|
||||
"15iw7982g6vc4jy1l9kk1z9sl5bm1bdbwr74y7nvwjs1nffhig7f"))
|
||||
(patches (search-patches "qemu-CVE-2021-20203.patch"
|
||||
"qemu-meson-compat.patch"
|
||||
"qemu-sphinx-compat.patch"
|
||||
"qemu-build-info-manual.patch"))
|
||||
(modules '((guix build utils)))
|
||||
|
@ -218,12 +217,10 @@
|
|||
;; Ensure the executables created by these source files reference
|
||||
;; /bin/sh from the store so they work inside the build container.
|
||||
(substitute* '("block/cloop.c" "migration/exec.c"
|
||||
"net/tap.c" "tests/qtest/libqtest.c")
|
||||
"net/tap.c" "tests/qtest/libqtest.c"
|
||||
"tests/qtest/vhost-user-blk-test.c")
|
||||
(("/bin/sh") (which "sh")))
|
||||
(substitute* "Makefile"
|
||||
(("SHELL = /usr/bin/env bash -o pipefail")
|
||||
"SHELL = bash -o pipefail"))
|
||||
(substitute* "tests/qemu-iotests/check"
|
||||
(substitute* "tests/qemu-iotests/testenv.py"
|
||||
(("#!/usr/bin/env python3")
|
||||
(string-append "#!" (which "python3"))))))
|
||||
(add-before 'configure 'fix-optionrom-makefile
|
||||
|
@ -345,6 +342,7 @@ exec smbd $@")))
|
|||
("pkg-config" ,pkg-config)
|
||||
("python-wrapper" ,python-wrapper)
|
||||
("python-sphinx" ,python-sphinx)
|
||||
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
|
||||
("texinfo" ,texinfo)
|
||||
;; The following static libraries are required to build
|
||||
;; the static output of QEMU.
|
||||
|
|
Reference in New Issue