gnu: gcc@4.8: Fix libsanitizer build issue.
Fixes <https://bugs.gnu.org/32397>. Reported by fis trivial <ybbs.daans@hotmail.com>. * gnu/packages/patches/gcc-4.8-libsanitizer-fix.patch: New file. * gnu/packages/gcc.scm (gcc-4.8)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
6d1a7ce8ea
commit
0b93d04ac5
|
@ -695,6 +695,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gcc-asan-missing-include.patch \
|
%D%/packages/patches/gcc-asan-missing-include.patch \
|
||||||
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-fix-texi2pod.patch \
|
%D%/packages/patches/gcc-fix-texi2pod.patch \
|
||||||
|
%D%/packages/patches/gcc-4.8-libsanitizer-fix.patch \
|
||||||
%D%/packages/patches/gcc-4.9-libsanitizer-fix.patch \
|
%D%/packages/patches/gcc-4.9-libsanitizer-fix.patch \
|
||||||
%D%/packages/patches/gcc-libsanitizer-fix.patch \
|
%D%/packages/patches/gcc-libsanitizer-fix.patch \
|
||||||
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
||||||
|
|
|
@ -365,6 +365,7 @@ Go. It also includes runtime support libraries for these languages.")
|
||||||
(base32
|
(base32
|
||||||
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
|
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
|
||||||
(patches (search-patches "gcc-arm-link-spec-fix.patch"
|
(patches (search-patches "gcc-arm-link-spec-fix.patch"
|
||||||
|
"gcc-4.8-libsanitizer-fix.patch"
|
||||||
"gcc-asan-missing-include.patch"
|
"gcc-asan-missing-include.patch"
|
||||||
"gcc-fix-texi2pod.patch"))
|
"gcc-fix-texi2pod.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
|
|
|
@ -0,0 +1,15 @@
|
||||||
|
This is a backport of part of this patch from 6.5 to 4.8:
|
||||||
|
|
||||||
|
https://gcc.gnu.org/git/?p=gcc.git;a=patch;h=8937b94d1a643fd9760714642296d034a45254a8
|
||||||
|
|
||||||
|
--- a/libsanitizer/tsan/tsan_platform_linux.cc
|
||||||
|
+++ b/libsanitizer/tsan/tsan_platform_linux.cc
|
||||||
|
@@ -351,7 +351,7 @@ bool IsGlobalVar(uptr addr) {
|
||||||
|
// closes within glibc. The code is a pure hack.
|
||||||
|
int ExtractResolvFDs(void *state, int *fds, int nfd) {
|
||||||
|
int cnt = 0;
|
||||||
|
- __res_state *statp = (__res_state*)state;
|
||||||
|
+ struct __res_state *statp = (struct __res_state*)state;
|
||||||
|
for (int i = 0; i < MAXNS && cnt < nfd; i++) {
|
||||||
|
if (statp->_u._ext.nsaddrs[i] && statp->_u._ext.nssocks[i] != -1)
|
||||||
|
fds[cnt++] = statp->_u._ext.nssocks[i];
|
Reference in New Issue