me
/
guix
Archived
1
0
Fork 0

gnu: guile-ssh: Fix test failure due to Guile 3.0.7's 'read-error'.

Reported by Marius Bakke.

* gnu/packages/patches/guile-ssh-read-error.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/ssh.scm (guile-ssh)[source]: Use it.
(guile2.0-ssh)[source]: New field.
(guile2.2-ssh)[source]: New field.
master
Ludovic Courtès 2021-05-19 17:45:32 +02:00
parent 7046a8fff7
commit 0fb80f349d
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 28 additions and 2 deletions

View File

@ -1174,6 +1174,7 @@ dist_patch_DATA = \
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
%D%/packages/patches/guile-emacs-fix-configure.patch \
%D%/packages/patches/guile-ssh-fix-test-suite.patch \
%D%/packages/patches/guile-ssh-read-error.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \
%D%/packages/patches/gtk2-theme-paths.patch \

View File

@ -0,0 +1,18 @@
This patch adjusts to slightly different 'read-error' in Guile 3.0.6
compared to earlier versions:
https://github.com/artyom-poptsov/guile-ssh/issues/28
--- a/tests/dist.scm
+++ b/tests/dist.scm
@@ -183,8 +183,8 @@ Unbound variable: e"
rrepl-get-result))
(test-error-with-log/= "rrepl-get-result, unknown # object error"
- 'node-repl-error "Reader error: scm_lreadr: #<unknown port>:1:3: \
-Unknown # object: (#\\<): scheme@(guile-user)> \
+ 'node-repl-error "Reader error: #f: #<unknown port>:1:3: \
+Unknown # object: (\"#<\"): scheme@(guile-user)> \
$4 = #<session #<undefined>@#<undefined>:22 (disconnected) 453fff>"
(call-with-input-string
(string-append "scheme@(guile-user)> $4 = "

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@ -317,7 +317,8 @@ Additionally, various channel-specific options can be negotiated.")
(sha256
(base32
"1xpxkvgj7wgcl450djkcrmrf957mcy2f36hfs5g6kpla1gax2d1g"))
(patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(patches (search-patches "guile-ssh-fix-test-suite.patch"
"guile-ssh-read-error.patch"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@ -383,6 +384,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.0-ssh")
(source (origin
(inherit (package-source guile-ssh))
(patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(native-inputs
`(("guile" ,guile-2.0) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))
@ -393,6 +397,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.2-ssh")
(source (origin
(inherit (package-source guile-ssh))
(patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(native-inputs
`(("guile" ,guile-2.2) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))