gnu: monero: Update to 0.17.3.0.
* gnu/packages/finance.scm (monero): Update to 0.17.3.0. * gnu/packages/patches/monero-use-system-miniupnpc.patch: Update patch.master
parent
c9b42242f9
commit
107481ea0f
|
@ -642,7 +642,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
|
||||||
;; the system's dynamically linked library.
|
;; the system's dynamically linked library.
|
||||||
(package
|
(package
|
||||||
(name "monero")
|
(name "monero")
|
||||||
(version "0.17.2.3")
|
(version "0.17.3.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
|
@ -662,7 +662,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
|
||||||
"external/unbound"))
|
"external/unbound"))
|
||||||
#t))
|
#t))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0nax991fshfh51grhh2ryfrwwws35k16gzl1l3niva28zff2xmq6"))))
|
(base32 "1spsf7m3x4psp9s7mivr6x4886jnbq4i8ll2dl8bv5bsdhcd3pjm"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("doxygen" ,doxygen)
|
`(("doxygen" ,doxygen)
|
||||||
|
|
|
@ -1,14 +1,16 @@
|
||||||
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
|
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
|
||||||
index 7553f87e..8e865c6c 100644
|
index 5b7f69a56..3a353a0f3 100644
|
||||||
--- a/external/CMakeLists.txt
|
--- a/external/CMakeLists.txt
|
||||||
+++ b/external/CMakeLists.txt
|
+++ b/external/CMakeLists.txt
|
||||||
@@ -37,19 +37,7 @@
|
@@ -37,21 +37,7 @@
|
||||||
|
|
||||||
find_package(Miniupnpc REQUIRED)
|
find_package(Miniupnpc REQUIRED)
|
||||||
|
|
||||||
-message(STATUS "Using in-tree miniupnpc")
|
-message(STATUS "Using in-tree miniupnpc")
|
||||||
|
-set(UPNPC_NO_INSTALL TRUE CACHE BOOL "Disable miniupnp installation" FORCE)
|
||||||
-add_subdirectory(miniupnp/miniupnpc)
|
-add_subdirectory(miniupnp/miniupnpc)
|
||||||
-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
|
-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
|
||||||
|
-set_property(TARGET libminiupnpc-static PROPERTY POSITION_INDEPENDENT_CODE ON)
|
||||||
-if(MSVC)
|
-if(MSVC)
|
||||||
- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
|
- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
|
||||||
-elseif(NOT MSVC)
|
-elseif(NOT MSVC)
|
||||||
|
@ -24,12 +26,12 @@ index 7553f87e..8e865c6c 100644
|
||||||
find_package(Unbound)
|
find_package(Unbound)
|
||||||
|
|
||||||
diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
|
diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
|
||||||
index 74924e4f..3554dd0d 100644
|
index d4b39869c..13071d898 100644
|
||||||
--- a/src/p2p/net_node.inl
|
--- a/src/p2p/net_node.inl
|
||||||
+++ b/src/p2p/net_node.inl
|
+++ b/src/p2p/net_node.inl
|
||||||
@@ -49,9 +49,9 @@
|
@@ -61,9 +61,9 @@
|
||||||
#include "storages/levin_abstract_invoke2.h"
|
|
||||||
#include "cryptonote_core/cryptonote_core.h"
|
#include "cryptonote_core/cryptonote_core.h"
|
||||||
|
#include "net/parse.h"
|
||||||
|
|
||||||
-#include <miniupnp/miniupnpc/miniupnpc.h>
|
-#include <miniupnp/miniupnpc/miniupnpc.h>
|
||||||
-#include <miniupnp/miniupnpc/upnpcommands.h>
|
-#include <miniupnp/miniupnpc/upnpcommands.h>
|
||||||
|
|
Reference in New Issue