From 10f43fe7e4b41171f0583cc516f6962764fdab57 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:52:49 +0200
Subject: [PATCH] gnu: Add texlive-idxlayout.

* gnu/packages/tex.scm (texlive-idxlayout): New variable.
---
 gnu/packages/tex.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c141e1afd0..4178dfc24f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -85375,6 +85375,30 @@ compressed to @samp{[1-3]}, where the @samp{1} and the @samp{3} are
      "The package provides commands for adding formatted index entries.")
     (license license:lppl1.3+)))
 
+(define-public texlive-idxlayout
+  (package
+    (name "texlive-idxlayout")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/idxlayout/"
+                   "source/latex/idxlayout/"
+                   "tex/latex/idxlayout/")
+             (base32
+              "1d3ir3rqyr62db82mad09z2xpyyczflrgkjgnkgj45ahd0mhdplr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/idxlayout")
+    (synopsis
+     "Configurable index layout, responsive to KOMA-Script and @code{memoir}")
+    (description
+     "The @code{idxlayout} package offers a key-value interface to configure index
+layout parameters, e.g. allowing for three-column indexes or for parent items
+and their affiliated subitems being typeset as a single paragraph.  The
+package is responsive to the index-related options and commands of the
+KOMA-Script and @code{memoir} classes.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar