gnu: hubbub: Fix build.
* gnu/packages/web.scm (hubbub)[source]: Add patch. * gnu/packages/patches/hubbub-maybe-uninitialized.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Andreas Enge <andreas@enge.fr>master
parent
3c39011114
commit
12fd3a9755
|
@ -58,6 +58,7 @@
|
|||
# Copyright © 2022 jgart <jgart@dismail.de>
|
||||
# Copyright © 2023 Zheng Junjie <873216071@qq.com>
|
||||
# Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
|
||||
# Copyright © 2023 Andy Tai <atai@atai.org>
|
||||
#
|
||||
# This file is part of GNU Guix.
|
||||
#
|
||||
|
@ -1352,6 +1353,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/http-parser-CVE-2020-8287.patch \
|
||||
%D%/packages/patches/htslib-for-stringtie.patch \
|
||||
%D%/packages/patches/hubbub-sort-entities.patch \
|
||||
%D%/packages/patches/hubbub-maybe-uninitialized.patch \
|
||||
%D%/packages/patches/hueplusplus-mbedtls.patch \
|
||||
%D%/packages/patches/hurd-add-without-rump-configure-option.patch \
|
||||
%D%/packages/patches/hurd-fix-types-of-read-write-and-readables-methods-2.patch \
|
||||
|
|
|
@ -0,0 +1,40 @@
|
|||
From 69d81a8a4d4c223aad67cde0fdf64d64351b9802 Mon Sep 17 00:00:00 2001
|
||||
From: Andy Tai <atai@atai.org>
|
||||
Date: Sat, 27 May 2023 00:01:34 -0700
|
||||
Subject: [PATCH] prevent -Werror=maybe-uninitialized build failure with gcc 11
|
||||
when building tests tokeniser2 and tokeniser3
|
||||
|
||||
---
|
||||
test/tokeniser2.c | 2 +-
|
||||
test/tokeniser3.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/test/tokeniser2.c b/test/tokeniser2.c
|
||||
index c8ab9c0..4caae38 100644
|
||||
--- a/test/tokeniser2.c
|
||||
+++ b/test/tokeniser2.c
|
||||
@@ -438,7 +438,7 @@ hubbub_error token_handler(const hubbub_token *token, void *pw)
|
||||
/* Expected token only contained part of the data
|
||||
* Calculate how much is left, then try again with
|
||||
* the next expected token */
|
||||
- hubbub_token t;
|
||||
+ hubbub_token t = { 0 };
|
||||
|
||||
t.type = HUBBUB_TOKEN_CHARACTER;
|
||||
t.data.character.ptr += len;
|
||||
diff --git a/test/tokeniser3.c b/test/tokeniser3.c
|
||||
index e33d018..b3be901 100644
|
||||
--- a/test/tokeniser3.c
|
||||
+++ b/test/tokeniser3.c
|
||||
@@ -447,7 +447,7 @@ hubbub_error token_handler(const hubbub_token *token, void *pw)
|
||||
/* Expected token only contained part of the data
|
||||
* Calculate how much is left, then try again with
|
||||
* the next expected token */
|
||||
- hubbub_token t;
|
||||
+ hubbub_token t = { 0 };
|
||||
|
||||
t.type = HUBBUB_TOKEN_CHARACTER;
|
||||
t.data.character.ptr += len;
|
||||
--
|
||||
2.40.1
|
||||
|
|
@ -5242,7 +5242,9 @@ C. It is developed as part of the NetSurf project.")
|
|||
(sha256
|
||||
(base32
|
||||
"1dimfyblmym98qa1b80c5jslv2zk8r44xbdrgrsrw1n9wr9y4yly"))
|
||||
(patches (search-patches "hubbub-sort-entities.patch"))))
|
||||
(patches (search-patches
|
||||
"hubbub-sort-entities.patch"
|
||||
"hubbub-maybe-uninitialized.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
(list netsurf-buildsystem
|
||||
|
|
Reference in New Issue