me
/
guix
Archived
1
0
Fork 0

gnu: ibus-anthy: Update to 1.5.15.

* gnu/packages/ibus.scm (ibus-anthy): Update to 1.5.15.
* gnu/packages/patches/ibus-anthy-fix-tests.patch: Update patch.
master
Maxim Cournoyer 2023-08-22 10:45:11 -04:00
parent 206b357c01
commit 13425768f7
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
2 changed files with 14 additions and 8 deletions

View File

@ -349,7 +349,7 @@ Chinese pinyin input methods.")
(define-public ibus-anthy
(package
(name "ibus-anthy")
(version "1.5.14")
(version "1.5.15")
(source (origin
(method url-fetch)
(uri (string-append
@ -357,13 +357,13 @@ Chinese pinyin input methods.")
version "/ibus-anthy-" version ".tar.gz"))
(sha256
(base32
"16vd0k8wm13s38869jqs3dnwmjvywgn0snnpyi41m28binhlssf8"))
"12yrgqiq6mqc8jr49dgkk3d7mdnyqic4xs597biwjjkahgaydi2q"))
(patches (search-patches "ibus-anthy-fix-tests.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
;; The test suite hangs (see:
;; https://github.com/ibus/ibus-anthy/issues/28).
;; https://github.com/ibus/ibus-anthy/pull/35).
#:tests? #f
#:configure-flags
;; Use absolute exec path in the anthy.xml.

View File

@ -1,17 +1,14 @@
Submitted upstream: https://github.com/ibus/ibus-anthy/pull/35
diff --git a/tests/test-build.sh b/tests/test-build.sh
index e83b78f..a0efe32 100755
index e83b78f..bbfa7e1 100755
--- a/tests/test-build.sh
+++ b/tests/test-build.sh
@@ -63,26 +63,27 @@ parse_args()
@@ -63,26 +63,33 @@ parse_args()
done;
}
+maybe_install_pycotap() {
+ # Check if pycotap is already available.
+ python3 -m pycotap >/dev/null && return 0
+
+ # Red Hat specific hint.
+ if test -f /etc/redhat-release ; then
+ if ! rpm -q --quiet python3-pycotap; then
@ -19,6 +16,15 @@ index e83b78f..a0efe32 100755
+ exit -1
+ fi
+ fi;
+
+ # Check if pycotap is already available.
+ if ! python3 -m pycotap >/dev/null; then
+ echo "pycotap not found; installing via pip"
+ if ! pip install pycotap --user; then
+ echo "failed to install pycotap"
+ exit -1
+ fi
+ fi
+}
+
init_environment()