me
/
guix
Archived
1
0
Fork 0

gnu: aws-checksums: Replace patch.

* gnu/packages/c.scm (aws-checksums): Replace patch.
[arguments]: Fix CMAKE_PREFIX_PATH.
[source]: Remove patch.
* gnu/packages/patches/aws-checksums-cmake-prefix.patch:
Delete file.
* gnu/local.mk: Remove it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
Greg Hogan 2021-10-18 18:39:15 +00:00 committed by Ludovic Courtès
parent 963ebbc62c
commit 14f540593b
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 5 additions and 17 deletions

View File

@ -871,7 +871,6 @@ dist_patch_DATA = \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-auth-install-private-headers.patch \
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
%D%/packages/patches/bash-completion-directories.patch \

View File

@ -578,6 +578,7 @@ portability.")
(define-public aws-checksums
(package
(name "aws-checksums")
; Update only when updating aws-crt-cpp.
(version "0.1.12")
(source (origin
(method git-fetch)
@ -587,12 +588,13 @@ portability.")
(file-name (git-file-name name version))
(sha256
(base32
"054f2hkmkxhw83q7zsz349k82xk6bkrvlsab088pf7kn9wd4hy4k"))
(patches (search-patches "aws-checksums-cmake-prefix.patch"))))
"054f2hkmkxhw83q7zsz349k82xk6bkrvlsab088pf7kn9wd4hy4k"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(list "-DBUILD_SHARED_LIBS=ON"
(string-append "-DCMAKE_PREFIX_PATH="
(assoc-ref %build-inputs "aws-c-common")))))
(inputs
`(("aws-c-common" ,aws-c-common)))
(synopsis "Amazon Web Services checksum library")

View File

@ -1,13 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,10 @@
cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
endif()
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
if (DEFINED CMAKE_PREFIX_PATH)
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
endif()