gnu: python-tinycss2: Fix test failure.
Fixes <https://bugs.gnu.org/42372>. Reported by Michael Rohleder <mike@rohleder.de>. * gnu/packages/patches/python-tinycss2-flake8-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-web.scm (python-tinycss2)[source](patches): New field.master
parent
dec0217f6e
commit
1507636906
|
@ -1466,6 +1466,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch \
|
||||
%D%/packages/patches/python-slugify-depend-on-unidecode.patch \
|
||||
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
||||
%D%/packages/patches/python-tinycss2-flake8-compat.patch \
|
||||
%D%/packages/patches/python-unittest2-python3-compat.patch \
|
||||
%D%/packages/patches/python-unittest2-remove-argparse.patch \
|
||||
%D%/packages/patches/python-waitress-fix-tests.patch \
|
||||
|
|
|
@ -0,0 +1,36 @@
|
|||
Fix test failure that occurs with recent versions of Flake8.
|
||||
|
||||
Taken from upstream:
|
||||
https://github.com/Kozea/tinycss2/commit/6556604fb98c2153412384d6f0f705db2da1aa60
|
||||
|
||||
diff --git a/tinycss2/css-parsing-tests/make_color3_hsl.py b/tinycss2/css-parsing-tests/make_color3_hsl.py
|
||||
index d1fd3a6..56fda0c 100644
|
||||
--- a/tinycss2/css-parsing-tests/make_color3_hsl.py
|
||||
+++ b/tinycss2/css-parsing-tests/make_color3_hsl.py
|
||||
@@ -8,16 +8,17 @@ def trim(s):
|
||||
print('[')
|
||||
print(',\n'.join(
|
||||
'"hsl%s(%s, %s%%, %s%%%s)", [%s, %s, %s, %s]' % (
|
||||
- ('a' if a is not None else '', h,
|
||||
- trim(str(s / 10.)), trim(str(l / 10.)),
|
||||
- ', %s' % a if a is not None else '') +
|
||||
+ ('a' if alpha is not None else '', hue,
|
||||
+ trim(str(saturation / 10.)), trim(str(light / 10.)),
|
||||
+ ', %s' % alpha if alpha is not None else '') +
|
||||
tuple(trim(str(round(v, 10)))
|
||||
- for v in colorsys.hls_to_rgb(h / 360., l / 1000., s / 1000.)) +
|
||||
- (a if a is not None else 1,)
|
||||
+ for v in colorsys.hls_to_rgb(
|
||||
+ hue / 360., light / 1000., saturation / 1000.)) +
|
||||
+ (alpha if alpha is not None else 1,)
|
||||
)
|
||||
- for a in [None, 1, .2, 0]
|
||||
- for l in range(0, 1001, 125)
|
||||
- for s in range(0, 1001, 125)
|
||||
- for h in range(0, 360, 30)
|
||||
+ for alpha in [None, 1, .2, 0]
|
||||
+ for light in range(0, 1001, 125)
|
||||
+ for saturation in range(0, 1001, 125)
|
||||
+ for hue in range(0, 360, 30)
|
||||
))
|
||||
print(']')
|
|
@ -3411,6 +3411,7 @@ library to create slugs from unicode strings while keeping it DRY.")
|
|||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "tinycss2" version))
|
||||
(patches (search-patches "python-tinycss2-flake8-compat.patch"))
|
||||
(sha256
|
||||
(base32 "1kw84y09lggji4krkc58jyhsfj31w8npwhznr7lf19d0zbix09v4"))))
|
||||
(build-system python-build-system)
|
||||
|
|
Reference in New Issue