gnu: emacs-helpful: Update to 0.19-1.1c98f6f.
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19-1.1c98f6f. [source]: Remove fix-docstring-test.patch. [propagated-inputs]: Remove EMACS-SHUT-UP. * gnu/packages/patches/emacs-helpful-fix-docstring-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Apply removal. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>master
parent
1b64641955
commit
156aac1b36
|
@ -1068,7 +1068,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
||||
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||
%D%/packages/patches/emacs-helpful-fix-docstring-test.patch \
|
||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
|
||||
%D%/packages/patches/emacs-native-comp-driver-options.patch \
|
||||
|
|
|
@ -23374,23 +23374,23 @@ downloading manager for Emacs.")
|
|||
(license license:gpl3+))))
|
||||
|
||||
(define-public emacs-helpful
|
||||
(let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
|
||||
(revision "1"))
|
||||
(package
|
||||
(name "emacs-helpful")
|
||||
(version "0.19")
|
||||
(version (git-version "0.19" revision commit))
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/Wilfred/helpful")
|
||||
(commit version)))
|
||||
(commit commit)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0qwsifzsjw95l83m7z07fr9h1sqbhggwmcps1qgbddpan2a8ab8a"))
|
||||
;; Cherry-picked from upstream, remove when bumping to 0.20.
|
||||
(patches (search-patches "emacs-helpful-fix-docstring-test.patch"))))
|
||||
(base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
|
||||
(build-system emacs-build-system)
|
||||
(propagated-inputs
|
||||
(list emacs-elisp-refs emacs-dash emacs-s emacs-f emacs-shut-up))
|
||||
(list emacs-dash emacs-elisp-refs emacs-f emacs-s))
|
||||
(native-inputs
|
||||
(list emacs-ert-runner emacs-undercover))
|
||||
(arguments
|
||||
|
@ -23417,7 +23417,7 @@ functions.
|
|||
@item Trace, disassemble functions from inside Helpful. This is discoverable
|
||||
and doesn't require memorisation of commands.
|
||||
@end itemize\n")
|
||||
(license license:gpl3+)))
|
||||
(license license:gpl3+))))
|
||||
|
||||
(define-public emacs-logview
|
||||
(package
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
This patch fixing a build failure has been cherry-picked from upstream.
|
||||
Originally submitted as pull request by Erik Šabič.
|
||||
See also <https://github.com/Wilfred/helpful/pull/296>.
|
||||
diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
|
||||
index a07aa8e..8a95129 100644
|
||||
--- a/test/helpful-unit-test.el
|
||||
+++ b/test/helpful-unit-test.el
|
||||
@@ -119,7 +119,9 @@ bar")))
|
||||
(should
|
||||
(equal
|
||||
(helpful--docstring #'test-foo-advised t)
|
||||
- "Docstring here too.")))
|
||||
+ (if (version< emacs-version "28")
|
||||
+ "Docstring here too."
|
||||
+ "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
|
||||
|
||||
(defun test-foo-no-docstring ()
|
||||
nil)
|
Reference in New Issue