gnu: ocaml-4.09: Fix signal handling with newer glibc.
* gnu/packages/patches/ocaml-4.09-dynamically-allocate-signal-stack.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ocaml.scm (ocaml-4.09): Use it.master
parent
0825162a35
commit
15bce0144b
|
@ -1580,6 +1580,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ocaml-dose3-dont-make-printconf.patch \
|
||||
%D%/packages/patches/ocaml-dose3-Install-mli-cmx-etc.patch \
|
||||
%D%/packages/patches/ocaml-multiple-definitions.patch \
|
||||
%D%/packages/patches/ocaml-4.09-dynamically-allocate-signal-stack.patch \
|
||||
%D%/packages/patches/ocaml-4.09-multiple-definitions.patch \
|
||||
%D%/packages/patches/omake-fix-non-determinism.patch \
|
||||
%D%/packages/patches/oneko-remove-nonfree-characters.patch \
|
||||
|
|
|
@ -316,7 +316,9 @@ functional, imperative and object-oriented styles of programming.")
|
|||
"http://caml.inria.fr/pub/distrib/ocaml-"
|
||||
(version-major+minor version)
|
||||
"/ocaml-" version ".tar.xz"))
|
||||
(patches (search-patches "ocaml-4.09-multiple-definitions.patch"))
|
||||
(patches (search-patches
|
||||
"ocaml-4.09-multiple-definitions.patch"
|
||||
"ocaml-4.09-dynamically-allocate-signal-stack.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1v3z5ar326f3hzvpfljg4xj8b9lmbrl53fn57yih1bkbx3gr3yzj"))))
|
||||
|
|
|
@ -0,0 +1,52 @@
|
|||
From 95f5016955e519c392c746e38e0c9460f2c1aa0c Mon Sep 17 00:00:00 2001
|
||||
From: Julien Lepiller <julien@lepiller.eu>
|
||||
Date: Sun, 19 Feb 2023 09:58:57 +0100
|
||||
Subject: [PATCH] Dynamically allocate the alternate signal stack.
|
||||
|
||||
This patch is a backport of https://github.com/ocaml/ocaml/pull/10266.
|
||||
---
|
||||
runtime/signals_nat.c | 19 +++++++++++--------
|
||||
1 file changed, 11 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/runtime/signals_nat.c b/runtime/signals_nat.c
|
||||
index 29a5f49..a193fc2 100644
|
||||
--- a/runtime/signals_nat.c
|
||||
+++ b/runtime/signals_nat.c
|
||||
@@ -182,7 +182,6 @@ DECLARE_SIGNAL_HANDLER(trap_handler)
|
||||
#ifdef HAS_STACK_OVERFLOW_DETECTION
|
||||
|
||||
static char * system_stack_top;
|
||||
-static char sig_alt_stack[SIGSTKSZ];
|
||||
|
||||
#if defined(SYS_linux)
|
||||
/* PR#4746: recent Linux kernels with support for stack randomization
|
||||
@@ -274,15 +273,19 @@ void caml_init_signals(void)
|
||||
#ifdef HAS_STACK_OVERFLOW_DETECTION
|
||||
{
|
||||
stack_t stk;
|
||||
- struct sigaction act;
|
||||
- stk.ss_sp = sig_alt_stack;
|
||||
+ stk.ss_sp = malloc(SIGSTKSZ);
|
||||
stk.ss_size = SIGSTKSZ;
|
||||
stk.ss_flags = 0;
|
||||
- SET_SIGACT(act, segv_handler);
|
||||
- act.sa_flags |= SA_ONSTACK | SA_NODEFER;
|
||||
- sigemptyset(&act.sa_mask);
|
||||
- system_stack_top = (char *) &act;
|
||||
- if (sigaltstack(&stk, NULL) == 0) { sigaction(SIGSEGV, &act, NULL); }
|
||||
+ if (stk.ss_sp != NULL) {
|
||||
+ if (sigaltstack(&stk, NULL) != -1) {
|
||||
+ struct sigaction act;
|
||||
+ SET_SIGACT(act, segv_handler);
|
||||
+ act.sa_flags |= SA_ONSTACK | SA_NODEFER;
|
||||
+ sigemptyset(&act.sa_mask);
|
||||
+ system_stack_top = (char *) &act;
|
||||
+ sigaction(SIGSEGV, &act, NULL);
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
#endif
|
||||
}
|
||||
--
|
||||
2.38.1
|
||||
|
Reference in New Issue