gnu: supertuxkart: Update to 0.9.3.
* gnu/packages/games.scm (supertuxkart): Update to 0.9.3. [arguments] <#:configure-flags>: Pass -DBUILD_RECORDER=0. * gnu/packages/patches/supertuxkart-angelscript-ftbfs.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>master
parent
5864f1c1ee
commit
17c3f77641
|
@ -1069,7 +1069,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/spice-CVE-2017-7506.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/superlu-dist-scotchmetis.patch \
|
||||
%D%/packages/patches/supertuxkart-angelscript-ftbfs.patch \
|
||||
%D%/packages/patches/swish-e-search.patch \
|
||||
%D%/packages/patches/swish-e-format-security.patch \
|
||||
%D%/packages/patches/synfigstudio-fix-ui-with-gtk3.patch \
|
||||
|
|
|
@ -1461,7 +1461,7 @@ This game is based on the GPL version of the famous game TuxRacer.")
|
|||
(define-public supertuxkart
|
||||
(package
|
||||
(name "supertuxkart")
|
||||
(version "0.9.2")
|
||||
(version "0.9.3")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -1469,8 +1469,7 @@ This game is based on the GPL version of the famous game TuxRacer.")
|
|||
version "/supertuxkart-" version "-src.tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"10l2ljmd7mv8f9ylarqmxxryicdnph2qkm3g5maxnsm2k2q0n20b"))
|
||||
(patches (search-patches "supertuxkart-angelscript-ftbfs.patch"))
|
||||
"1c4w47ibj87lgwiqygq8qi7jiz6gklj4dwf5bs5zk15s0rqlw0fq"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; Delete bundled library sources
|
||||
|
@ -1495,6 +1494,8 @@ This game is based on the GPL version of the famous game TuxRacer.")
|
|||
(list "-DUSE_WIIUSE=0"
|
||||
;; Do not use the bundled zlib
|
||||
"-DNO_IRR_COMPILE_WITH_ZLIB_=TRUE"
|
||||
;; FIXME: needs libopenglrecorder
|
||||
"-DBUILD_RECORDER=0"
|
||||
;; Irrlicht returns an integer instead of a boolean
|
||||
"-DCMAKE_C_FLAGS=-fpermissive")
|
||||
#:phases
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
https://github.com/supertuxkart/stk-code/commit/5e05f1178ce6bc5f3a653b55ab3dc6d016196341.patch
|
||||
|
||||
From 5e05f1178ce6bc5f3a653b55ab3dc6d016196341 Mon Sep 17 00:00:00 2001
|
||||
From: Deve <deveee@gmail.com>
|
||||
Date: Mon, 3 Oct 2016 23:26:09 +0200
|
||||
Subject: [PATCH] Fixed compiler error on Linux with non-x86 64bit platforms,
|
||||
e.g. arm64, mips, and s390x architectures
|
||||
|
||||
This modification is already applied in upstream angelscript repository:
|
||||
https://sourceforge.net/p/angelscript/code/2353/
|
||||
|
||||
Thanks to Adrian Bunk and Andreas Jonsson
|
||||
---
|
||||
lib/angelscript/projects/cmake/CMakeLists.txt | 1 +
|
||||
lib/angelscript/source/as_config.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/angelscript/projects/cmake/CMakeLists.txt b/lib/angelscript/projects/cmake/CMakeLists.txt
|
||||
index e93971315e..755d8378c3 100644
|
||||
--- a/lib/angelscript/projects/cmake/CMakeLists.txt
|
||||
+++ b/lib/angelscript/projects/cmake/CMakeLists.txt
|
||||
@@ -67,6 +67,7 @@ set(ANGELSCRIPT_SOURCE
|
||||
../../source/as_builder.cpp
|
||||
../../source/as_bytecode.cpp
|
||||
../../source/as_callfunc.cpp
|
||||
+ ../../source/as_callfunc_mips.cpp
|
||||
../../source/as_callfunc_x86.cpp
|
||||
../../source/as_callfunc_x64_gcc.cpp
|
||||
../../source/as_callfunc_x64_msvc.cpp
|
||||
diff --git a/lib/angelscript/source/as_config.h b/lib/angelscript/source/as_config.h
|
||||
index cb05bffbd5..5bb5b8e800 100644
|
||||
--- a/lib/angelscript/source/as_config.h
|
||||
+++ b/lib/angelscript/source/as_config.h
|
||||
@@ -844,7 +844,7 @@
|
||||
#define THISCALL_PASS_OBJECT_POINTER_ON_THE_STACK
|
||||
#define AS_X86
|
||||
#undef AS_NO_THISCALL_FUNCTOR_METHOD
|
||||
- #elif defined(__LP64__) && !defined(__arm64__)
|
||||
+ #elif defined(__x86_64__)
|
||||
#define AS_X64_GCC
|
||||
#undef AS_NO_THISCALL_FUNCTOR_METHOD
|
||||
#define HAS_128_BIT_PRIMITIVES
|
Reference in New Issue