gnu: Add nss.
* gnu/packages/patches/nss-pkgconfig.patch: New file. * gnu-system.scm (dist_patch_DATA): Add it. * gnu/packages/gnuzilla.scm (nss): New variable.master
parent
4923e06f21
commit
1aaaff1a7b
|
@ -422,6 +422,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/mupdf-buildsystem-fix.patch \
|
gnu/packages/patches/mupdf-buildsystem-fix.patch \
|
||||||
gnu/packages/patches/mutt-CVE-2014-9116.patch \
|
gnu/packages/patches/mutt-CVE-2014-9116.patch \
|
||||||
gnu/packages/patches/net-tools-bitrot.patch \
|
gnu/packages/patches/net-tools-bitrot.patch \
|
||||||
|
gnu/packages/patches/nss-pkgconfig.patch \
|
||||||
gnu/packages/patches/nvi-assume-preserve-path.patch \
|
gnu/packages/patches/nvi-assume-preserve-path.patch \
|
||||||
gnu/packages/patches/orpheus-cast-errors-and-includes.patch \
|
gnu/packages/patches/orpheus-cast-errors-and-includes.patch \
|
||||||
gnu/packages/patches/ots-no-include-missing-file.patch \
|
gnu/packages/patches/ots-no-include-missing-file.patch \
|
||||||
|
|
|
@ -2,6 +2,7 @@
|
||||||
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
||||||
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
||||||
|
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -24,6 +25,7 @@
|
||||||
#:use-module (guix packages)
|
#:use-module (guix packages)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
|
#:use-module (gnu packages databases)
|
||||||
#:use-module (gnu packages glib)
|
#:use-module (gnu packages glib)
|
||||||
#:use-module (gnu packages gstreamer)
|
#:use-module (gnu packages gstreamer)
|
||||||
#:use-module (gnu packages gtk)
|
#:use-module (gnu packages gtk)
|
||||||
|
@ -114,6 +116,100 @@ platform-neutral API for system level and libc-like functions. It is used
|
||||||
in the Mozilla clients.")
|
in the Mozilla clients.")
|
||||||
(license license:mpl2.0)))
|
(license license:mpl2.0)))
|
||||||
|
|
||||||
|
(define-public nss
|
||||||
|
(package
|
||||||
|
(name "nss")
|
||||||
|
(version "3.17.3")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append
|
||||||
|
"ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/"
|
||||||
|
"releases/NSS_3_17_3_RTM/src/nss-3.17.3.tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1m91z80x4zh1mxgf53bl33lp43gn1wxxx0y26mgz511gb81ykmgl"))
|
||||||
|
;; Create nss.pc and nss-config.
|
||||||
|
(patches (list (search-patch "nss-pkgconfig.patch")))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(outputs '("out" "bin"))
|
||||||
|
(arguments
|
||||||
|
'(#:parallel-build? #f ; failed
|
||||||
|
#:make-flags
|
||||||
|
(let* ((out (assoc-ref %outputs "out"))
|
||||||
|
(nspr (string-append (assoc-ref %build-inputs "nspr")))
|
||||||
|
(rpath (string-append "-Wl,-rpath=" out "/lib/nss")))
|
||||||
|
(list "-C" "nss" (string-append "PREFIX=" out)
|
||||||
|
"NSDISTMODE=copy"
|
||||||
|
"NSS_USE_SYSTEM_SQLITE=1"
|
||||||
|
(string-append "NSPR_INCLUDE_DIR=" nspr "/include/nspr")
|
||||||
|
;; Add $out/lib/nss to RPATH.
|
||||||
|
(string-append "RPATH=" rpath)
|
||||||
|
(string-append "LDFLAGS=" rpath)))
|
||||||
|
#:modules ((guix build gnu-build-system)
|
||||||
|
(guix build utils)
|
||||||
|
(ice-9 ftw)
|
||||||
|
(ice-9 match)
|
||||||
|
(srfi srfi-26))
|
||||||
|
#:imported-modules ((guix build gnu-build-system)
|
||||||
|
(guix build utils))
|
||||||
|
#:phases
|
||||||
|
(alist-replace
|
||||||
|
'configure
|
||||||
|
(lambda* (#:key system inputs #:allow-other-keys)
|
||||||
|
;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
|
||||||
|
(when (string-prefix? "x86_64" system)
|
||||||
|
(setenv "USE_64" "1"))
|
||||||
|
#t)
|
||||||
|
(alist-replace
|
||||||
|
'check
|
||||||
|
(lambda _
|
||||||
|
;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for testing.
|
||||||
|
;; The later requires a working DNS or /etc/hosts.
|
||||||
|
(setenv "DOMSUF" "(none)")
|
||||||
|
(setenv "USE_IP" "TRUE")
|
||||||
|
(setenv "IP_ADDRESS" "127.0.0.1")
|
||||||
|
(zero? (system* "./nss/tests/all.sh")))
|
||||||
|
(alist-replace
|
||||||
|
'install
|
||||||
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
|
(let* ((out (assoc-ref outputs "out"))
|
||||||
|
(bin (string-append (assoc-ref outputs "bin") "/bin"))
|
||||||
|
(inc (string-append out "/include/nss"))
|
||||||
|
(lib (string-append out "/lib/nss"))
|
||||||
|
(obj (match (scandir "dist" (cut string-suffix? "OBJ" <>))
|
||||||
|
((obj) (string-append "dist/" obj)))))
|
||||||
|
;; Install nss-config to $out/bin.
|
||||||
|
(mkdir-p (string-append out "/bin"))
|
||||||
|
(copy-file (string-append obj "/bin/nss-config")
|
||||||
|
(string-append out "/bin/nss-config"))
|
||||||
|
(delete-file (string-append obj "/bin/nss-config"))
|
||||||
|
;; Install nss.pc to $out/lib/pkgconfig.
|
||||||
|
(mkdir-p (string-append out "/lib/pkgconfig"))
|
||||||
|
(copy-file (string-append obj "/lib/pkgconfig/nss.pc")
|
||||||
|
(string-append out "/lib/pkgconfig/nss.pc"))
|
||||||
|
(delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
|
||||||
|
(rmdir (string-append obj "/lib/pkgconfig"))
|
||||||
|
;; Install other files.
|
||||||
|
(copy-recursively "dist/public/nss" inc)
|
||||||
|
(copy-recursively (string-append obj "/bin") bin)
|
||||||
|
(copy-recursively (string-append obj "/lib") lib)))
|
||||||
|
%standard-phases)))))
|
||||||
|
(inputs
|
||||||
|
`(("sqlite" ,sqlite)
|
||||||
|
("zlib" ,zlib)))
|
||||||
|
(propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
|
||||||
|
(native-inputs `(("perl" ,perl)))
|
||||||
|
(home-page
|
||||||
|
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
|
||||||
|
(synopsis "Network Security Services")
|
||||||
|
(description
|
||||||
|
"Network Security Services (NSS) is a set of libraries designed to support
|
||||||
|
cross-platform development of security-enabled client and server applications.
|
||||||
|
Applications built with NSS can support SSL v2 and v3, TLS, PKCS #5, PKCS #7,
|
||||||
|
PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other security
|
||||||
|
standards.")
|
||||||
|
(license license:mpl2.0)))
|
||||||
|
|
||||||
(define-public icecat
|
(define-public icecat
|
||||||
(package
|
(package
|
||||||
(name "icecat")
|
(name "icecat")
|
||||||
|
|
|
@ -0,0 +1,225 @@
|
||||||
|
Description: Create nss.pc and nss-config
|
||||||
|
Author: Lars Wendler <polynomial-c@gentoo.org>
|
||||||
|
Source: http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-libs/nss/files/nss-3.17.1-gentoo-fixups.patch
|
||||||
|
|
||||||
|
Modifications:
|
||||||
|
Change libdir from ${prefix}/lib64 to ${prefix}/lib/nss.
|
||||||
|
Remove optional patching in nss/Makefile.
|
||||||
|
|
||||||
|
--- nss-3.17.1/nss/config/Makefile
|
||||||
|
+++ nss-3.17.1/nss/config/Makefile
|
||||||
|
@@ -0,0 +1,40 @@
|
||||||
|
+CORE_DEPTH = ..
|
||||||
|
+DEPTH = ..
|
||||||
|
+
|
||||||
|
+include $(CORE_DEPTH)/coreconf/config.mk
|
||||||
|
+
|
||||||
|
+NSS_MAJOR_VERSION = `grep "NSS_VMAJOR" ../lib/nss/nss.h | awk '{print $$3}'`
|
||||||
|
+NSS_MINOR_VERSION = `grep "NSS_VMINOR" ../lib/nss/nss.h | awk '{print $$3}'`
|
||||||
|
+NSS_PATCH_VERSION = `grep "NSS_VPATCH" ../lib/nss/nss.h | awk '{print $$3}'`
|
||||||
|
+PREFIX = /usr
|
||||||
|
+
|
||||||
|
+all: export libs
|
||||||
|
+
|
||||||
|
+export:
|
||||||
|
+ # Create the nss.pc file
|
||||||
|
+ mkdir -p $(DIST)/lib/pkgconfig
|
||||||
|
+ sed -e "s,@prefix@,$(PREFIX)," \
|
||||||
|
+ -e "s,@exec_prefix@,\$${prefix}," \
|
||||||
|
+ -e "s,@libdir@,\$${prefix}/lib/nss," \
|
||||||
|
+ -e "s,@includedir@,\$${prefix}/include/nss," \
|
||||||
|
+ -e "s,@NSS_MAJOR_VERSION@,$(NSS_MAJOR_VERSION),g" \
|
||||||
|
+ -e "s,@NSS_MINOR_VERSION@,$(NSS_MINOR_VERSION)," \
|
||||||
|
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
|
||||||
|
+ nss.pc.in > nss.pc
|
||||||
|
+ chmod 0644 nss.pc
|
||||||
|
+ cp nss.pc $(DIST)/lib/pkgconfig
|
||||||
|
+
|
||||||
|
+ # Create the nss-config script
|
||||||
|
+ mkdir -p $(DIST)/bin
|
||||||
|
+ sed -e "s,@prefix@,$(PREFIX)," \
|
||||||
|
+ -e "s,@NSS_MAJOR_VERSION@,$(NSS_MAJOR_VERSION)," \
|
||||||
|
+ -e "s,@NSS_MINOR_VERSION@,$(NSS_MINOR_VERSION)," \
|
||||||
|
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
|
||||||
|
+ nss-config.in > nss-config
|
||||||
|
+ chmod 0755 nss-config
|
||||||
|
+ cp nss-config $(DIST)/bin
|
||||||
|
+
|
||||||
|
+libs:
|
||||||
|
+
|
||||||
|
+dummy: all export libs
|
||||||
|
+
|
||||||
|
--- nss-3.17.1/nss/config/nss-config.in
|
||||||
|
+++ nss-3.17.1/nss/config/nss-config.in
|
||||||
|
@@ -0,0 +1,145 @@
|
||||||
|
+#!/bin/sh
|
||||||
|
+
|
||||||
|
+prefix=@prefix@
|
||||||
|
+
|
||||||
|
+major_version=@NSS_MAJOR_VERSION@
|
||||||
|
+minor_version=@NSS_MINOR_VERSION@
|
||||||
|
+patch_version=@NSS_PATCH_VERSION@
|
||||||
|
+
|
||||||
|
+usage()
|
||||||
|
+{
|
||||||
|
+ cat <<EOF
|
||||||
|
+Usage: nss-config [OPTIONS] [LIBRARIES]
|
||||||
|
+Options:
|
||||||
|
+ [--prefix[=DIR]]
|
||||||
|
+ [--exec-prefix[=DIR]]
|
||||||
|
+ [--includedir[=DIR]]
|
||||||
|
+ [--libdir[=DIR]]
|
||||||
|
+ [--version]
|
||||||
|
+ [--libs]
|
||||||
|
+ [--cflags]
|
||||||
|
+Dynamic Libraries:
|
||||||
|
+ nss
|
||||||
|
+ ssl
|
||||||
|
+ smime
|
||||||
|
+ nssutil
|
||||||
|
+EOF
|
||||||
|
+ exit $1
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+if test $# -eq 0; then
|
||||||
|
+ usage 1 1>&2
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+lib_ssl=yes
|
||||||
|
+lib_smime=yes
|
||||||
|
+lib_nss=yes
|
||||||
|
+lib_nssutil=yes
|
||||||
|
+
|
||||||
|
+while test $# -gt 0; do
|
||||||
|
+ case "$1" in
|
||||||
|
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
|
||||||
|
+ *) optarg= ;;
|
||||||
|
+ esac
|
||||||
|
+
|
||||||
|
+ case $1 in
|
||||||
|
+ --prefix=*)
|
||||||
|
+ prefix=$optarg
|
||||||
|
+ ;;
|
||||||
|
+ --prefix)
|
||||||
|
+ echo_prefix=yes
|
||||||
|
+ ;;
|
||||||
|
+ --exec-prefix=*)
|
||||||
|
+ exec_prefix=$optarg
|
||||||
|
+ ;;
|
||||||
|
+ --exec-prefix)
|
||||||
|
+ echo_exec_prefix=yes
|
||||||
|
+ ;;
|
||||||
|
+ --includedir=*)
|
||||||
|
+ includedir=$optarg
|
||||||
|
+ ;;
|
||||||
|
+ --includedir)
|
||||||
|
+ echo_includedir=yes
|
||||||
|
+ ;;
|
||||||
|
+ --libdir=*)
|
||||||
|
+ libdir=$optarg
|
||||||
|
+ ;;
|
||||||
|
+ --libdir)
|
||||||
|
+ echo_libdir=yes
|
||||||
|
+ ;;
|
||||||
|
+ --version)
|
||||||
|
+ echo ${major_version}.${minor_version}.${patch_version}
|
||||||
|
+ ;;
|
||||||
|
+ --cflags)
|
||||||
|
+ echo_cflags=yes
|
||||||
|
+ ;;
|
||||||
|
+ --libs)
|
||||||
|
+ echo_libs=yes
|
||||||
|
+ ;;
|
||||||
|
+ ssl)
|
||||||
|
+ lib_ssl=yes
|
||||||
|
+ ;;
|
||||||
|
+ smime)
|
||||||
|
+ lib_smime=yes
|
||||||
|
+ ;;
|
||||||
|
+ nss)
|
||||||
|
+ lib_nss=yes
|
||||||
|
+ ;;
|
||||||
|
+ nssutil)
|
||||||
|
+ lib_nssutil=yes
|
||||||
|
+ ;;
|
||||||
|
+ *)
|
||||||
|
+ usage 1 1>&2
|
||||||
|
+ ;;
|
||||||
|
+ esac
|
||||||
|
+ shift
|
||||||
|
+done
|
||||||
|
+
|
||||||
|
+# Set variables that may be dependent upon other variables
|
||||||
|
+if test -z "$exec_prefix"; then
|
||||||
|
+ exec_prefix=`pkg-config --variable=exec_prefix nss`
|
||||||
|
+fi
|
||||||
|
+if test -z "$includedir"; then
|
||||||
|
+ includedir=`pkg-config --variable=includedir nss`
|
||||||
|
+fi
|
||||||
|
+if test -z "$libdir"; then
|
||||||
|
+ libdir=`pkg-config --variable=libdir nss`
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$echo_prefix" = "yes"; then
|
||||||
|
+ echo $prefix
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$echo_exec_prefix" = "yes"; then
|
||||||
|
+ echo $exec_prefix
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$echo_includedir" = "yes"; then
|
||||||
|
+ echo $includedir
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$echo_libdir" = "yes"; then
|
||||||
|
+ echo $libdir
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$echo_cflags" = "yes"; then
|
||||||
|
+ echo -I$includedir
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$echo_libs" = "yes"; then
|
||||||
|
+ libdirs=""
|
||||||
|
+ if test -n "$lib_ssl"; then
|
||||||
|
+ libdirs="$libdirs -lssl${major_version}"
|
||||||
|
+ fi
|
||||||
|
+ if test -n "$lib_smime"; then
|
||||||
|
+ libdirs="$libdirs -lsmime${major_version}"
|
||||||
|
+ fi
|
||||||
|
+ if test -n "$lib_nss"; then
|
||||||
|
+ libdirs="$libdirs -lnss${major_version}"
|
||||||
|
+ fi
|
||||||
|
+ if test -n "$lib_nssutil"; then
|
||||||
|
+ libdirs="$libdirs -lnssutil${major_version}"
|
||||||
|
+ fi
|
||||||
|
+ echo $libdirs
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
--- nss-3.17.1/nss/config/nss.pc.in
|
||||||
|
+++ nss-3.17.1/nss/config/nss.pc.in
|
||||||
|
@@ -0,0 +1,12 @@
|
||||||
|
+prefix=@prefix@
|
||||||
|
+exec_prefix=@exec_prefix@
|
||||||
|
+libdir=@libdir@
|
||||||
|
+includedir=@includedir@
|
||||||
|
+
|
||||||
|
+Name: NSS
|
||||||
|
+Description: Network Security Services
|
||||||
|
+Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@
|
||||||
|
+Requires: nspr >= 4.8
|
||||||
|
+Libs: -L${libdir} -lssl3 -lsmime3 -lnss3 -lnssutil3
|
||||||
|
+Cflags: -I${includedir}
|
||||||
|
+
|
||||||
|
--- nss-3.17.1/nss/manifest.mn
|
||||||
|
+++ nss-3.17.1/nss/manifest.mn
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
|
||||||
|
RELEASE = nss
|
||||||
|
|
||||||
|
-DIRS = coreconf lib cmd
|
||||||
|
+DIRS = coreconf lib cmd config
|
||||||
|
|
||||||
|
ifdef NSS_BUILD_GTESTS
|
||||||
|
DIRS += external_tests
|
Reference in New Issue