me
/
guix
Archived
1
0
Fork 0

gnu: spdlog: Fix tests.

* gnu/packages/patches/spdlog-fix-tests.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/logging.scm (spdlog)[source]: Use patch.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Greg Hogan 2023-08-07 20:12:34 +00:00 committed by Christopher Baines
parent 68b3d71806
commit 1ae56be99e
No known key found for this signature in database
GPG Key ID: 5E28A33B0B84F577
3 changed files with 28 additions and 0 deletions

View File

@ -1964,6 +1964,7 @@ dist_patch_DATA = \
%D%/packages/patches/source-highlight-gcc-compat.patch \
%D%/packages/patches/softhsm-fix-openssl3-tests.patch \
%D%/packages/patches/spectre-meltdown-checker-externalize-fwdb.patch \
%D%/packages/patches/spdlog-fix-tests.patch \
%D%/packages/patches/spectre-meltdown-checker-find-kernel.patch \
%D%/packages/patches/sphinxbase-fix-doxygen.patch \
%D%/packages/patches/sssd-system-directories.patch \

View File

@ -220,6 +220,7 @@ output in multiple windows in a terminal.")
(url "https://github.com/gabime/spdlog")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(patches (search-patches "spdlog-fix-tests.patch"))
(sha256
(base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))))
(build-system cmake-build-system)

View File

@ -0,0 +1,26 @@
Remove after next release and package update:
https://github.com/gabime/spdlog/commit/2ee8bac78e6525a8ad9a9196e65d502ce390d83a
From 2ee8bac78e6525a8ad9a9196e65d502ce390d83a Mon Sep 17 00:00:00 2001
From: xvitaly <vitaly@easycoding.org>
Date: Sun, 23 Jul 2023 10:15:25 +0200
Subject: [PATCH] Added missing square bracket to fix the level_to_string_view
test. (#2827)
---
tests/test_misc.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/test_misc.cpp b/tests/test_misc.cpp
index 9f3cb1744..6199641ff 100644
--- a/tests/test_misc.cpp
+++ b/tests/test_misc.cpp
@@ -43,7 +43,7 @@ TEST_CASE("log_levels", "[log_levels]")
REQUIRE(log_info("Hello", spdlog::level::trace) == "Hello");
}
-TEST_CASE("level_to_string_view", "[convert_to_string_view")
+TEST_CASE("level_to_string_view", "[convert_to_string_view]")
{
REQUIRE(spdlog::level::to_string_view(spdlog::level::trace) == "trace");
REQUIRE(spdlog::level::to_string_view(spdlog::level::debug) == "debug");