gnu: wxwidgets: Update to 3.0.3.
* gnu/packages/wxwidgets.scm (wxwidgets): Update to 3.0.3. [source]: Remove 'wxwidgets-fix-windowGTK.patch'. * gnu/packages/patches/wxwidgets-fix-windowGTK.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
2999dcd5b7
commit
1c059a6e16
|
@ -1093,7 +1093,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
|
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
|
||||||
%D%/packages/patches/xcb-proto-python3-print.patch \
|
%D%/packages/patches/xcb-proto-python3-print.patch \
|
||||||
%D%/packages/patches/xcb-proto-python3-whitespace.patch \
|
%D%/packages/patches/xcb-proto-python3-whitespace.patch \
|
||||||
%D%/packages/patches/wxwidgets-fix-windowGTK.patch \
|
|
||||||
%D%/packages/patches/xdotool-fix-makefile.patch \
|
%D%/packages/patches/xdotool-fix-makefile.patch \
|
||||||
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||||
%D%/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
%D%/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
This patch allow Filezilla client to resize window.
|
|
||||||
The patch was adapted from upstream source repository:
|
|
||||||
'<http://trac.wxwidgets.org/changeset/4793e5b0a4e189e492287305859b278fed780080/git-wxWidgets>'
|
|
||||||
|
|
||||||
--- a/src/gtk/toplevel.cpp 2014-10-06 16:33:44.000000000 -0500
|
|
||||||
+++ b/src/gtk/toplevel.cpp 2017-02-16 21:33:27.779907810 -0600
|
|
||||||
@@ -1216,8 +1216,9 @@
|
|
||||||
int hints_mask = GDK_HINT_MIN_SIZE | GDK_HINT_MAX_SIZE;
|
|
||||||
hints.min_width = 1;
|
|
||||||
hints.min_height = 1;
|
|
||||||
- hints.max_width = INT_MAX;
|
|
||||||
- hints.max_height = INT_MAX;
|
|
||||||
+ // using INT_MAX for size will lead to integer overflow with HiDPI scaling
|
|
||||||
+ hints.max_width = INT_MAX / 16;
|
|
||||||
+ hints.max_height = INT_MAX / 16;
|
|
||||||
const int decorSize_x = m_decorSize.left + m_decorSize.right;
|
|
||||||
const int decorSize_y = m_decorSize.top + m_decorSize.bottom;
|
|
||||||
if (minSize.x > decorSize_x)
|
|
|
@ -48,7 +48,7 @@
|
||||||
(define-public wxwidgets
|
(define-public wxwidgets
|
||||||
(package
|
(package
|
||||||
(name "wxwidgets")
|
(name "wxwidgets")
|
||||||
(version "3.0.2")
|
(version "3.0.3")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -56,9 +56,7 @@
|
||||||
"releases/download/v" version
|
"releases/download/v" version
|
||||||
"/wxWidgets-" version ".tar.bz2"))
|
"/wxWidgets-" version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0paq27brw4lv8kspxh9iklpa415mxi8zc117vbbbhfjgapf7js1l"))
|
(base32 "0yrhp5cs2g33cpbdwdzicmm5m4mfnlvxwv031x9266zc90zh7j08"))))
|
||||||
(patches (search-patches
|
|
||||||
"wxwidgets-fix-windowGTK.patch"))))
|
|
||||||
(build-system glib-or-gtk-build-system)
|
(build-system glib-or-gtk-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
`(("glu" ,glu)
|
`(("glu" ,glu)
|
||||||
|
|
Reference in New Issue