gnu: inkscape: New module
* gnu/packages/inkscape.scm, gnu/packages/patches/inkscape-stray-comma.patch: New files. * gnu-system.am (GNU_SYSTEM_MODULES): Add inkscape.scm. (dist_patch_DATA): Add inkscape-stray-comma.patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>master
parent
2a72eeeea1
commit
1d07e9316a
|
@ -109,6 +109,7 @@ GNU_SYSTEM_MODULES = \
|
|||
gnu/packages/idutils.scm \
|
||||
gnu/packages/imagemagick.scm \
|
||||
gnu/packages/indent.scm \
|
||||
gnu/packages/inkscape.scm \
|
||||
gnu/packages/irssi.scm \
|
||||
gnu/packages/iso-codes.scm \
|
||||
gnu/packages/kde.scm \
|
||||
|
@ -269,6 +270,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/gtkglext-remove-pangox-dependency.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/inkscape-stray-comma.patch \
|
||||
gnu/packages/patches/libevent-dns-tests.patch \
|
||||
gnu/packages/patches/libffi-mips-n32-fix.patch \
|
||||
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
|
||||
|
|
|
@ -0,0 +1,79 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
;;; GNU Guix is free software; you can redistribute it and/or modify it
|
||||
;;; under the terms of the GNU General Public License as published by
|
||||
;;; the Free Software Foundation; either version 3 of the License, or (at
|
||||
;;; your option) any later version.
|
||||
;;;
|
||||
;;; GNU Guix is distributed in the hope that it will be useful, but
|
||||
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
;;; GNU General Public License for more details.
|
||||
;;;
|
||||
;;; You should have received a copy of the GNU General Public License
|
||||
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
(define-module (gnu packages inkscape)
|
||||
#:use-module ((guix licenses)
|
||||
#:renamer (symbol-prefix-proc 'license:))
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages aspell)
|
||||
#:use-module (gnu packages bdw-gc)
|
||||
#:use-module (gnu packages boost)
|
||||
#:use-module (gnu packages glib)
|
||||
#:use-module (gnu packages gtk)
|
||||
#:use-module (gnu packages maths)
|
||||
#:use-module (gnu packages perl)
|
||||
#:use-module (gnu packages pdf)
|
||||
#:use-module (gnu packages popt)
|
||||
#:use-module (gnu packages python)
|
||||
#:use-module (gnu packages xml)
|
||||
#:use-module (gnu packages ghostscript)
|
||||
#:use-module (gnu packages fontutils)
|
||||
#:use-module (gnu packages libpng)
|
||||
#:use-module (gnu packages pkg-config))
|
||||
|
||||
(define-public inkscape
|
||||
(package
|
||||
(name "inkscape")
|
||||
(version "0.48.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/inkscape/inkscape-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0nhxsgrgsx6zrgpkd1akxjvmdqjp8ccnsvlwxh62l0brg84fw6bf"))
|
||||
(patches (list (search-patch "inkscape-stray-comma.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("aspell" ,aspell)
|
||||
("gtkmm" ,gtkmm-2)
|
||||
("gtk" ,gtk+-2)
|
||||
("gsl" ,gsl)
|
||||
("poppler" ,poppler)
|
||||
("libpng" ,libpng)
|
||||
("libxml2" ,libxml2)
|
||||
("libxslt" ,libxslt)
|
||||
("libgc" ,libgc)
|
||||
("freetype" ,freetype)
|
||||
("popt" ,popt)
|
||||
("python" ,python-2)
|
||||
("lcms" ,lcms)
|
||||
("boost" ,boost)))
|
||||
(native-inputs
|
||||
`(("intltool" ,intltool)
|
||||
("perl" ,perl)
|
||||
("pkg-config" ,pkg-config)))
|
||||
(home-page "http://inkscape.org/")
|
||||
(synopsis "Vector graphics editor")
|
||||
(description "Inkscape is a vector graphics editor. What sets Inkscape
|
||||
apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
|
||||
as the native format.")
|
||||
(license license:gpl2+)))
|
|
@ -0,0 +1,13 @@
|
|||
This is verbatim from Upstream: http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_48_BRANCH/diff/9943
|
||||
--- a/src/widgets/desktop-widget.h 2011-06-06 06:43:00 +0000
|
||||
+++ b/src/widgets/desktop-widget.h 2013-01-05 14:34:09 +0000
|
||||
@@ -239,7 +239,7 @@
|
||||
private:
|
||||
GtkWidget *tool_toolbox;
|
||||
GtkWidget *aux_toolbox;
|
||||
- GtkWidget *commands_toolbox,;
|
||||
+ GtkWidget *commands_toolbox;
|
||||
GtkWidget *snap_toolbox;
|
||||
|
||||
static void init(SPDesktopWidget *widget);
|
||||
|
Reference in New Issue