gnu: libtool and libltdl: Update to 2.4.7.
* gnu/packages/autotools.scm (libtool, libltdl): Update to 2.4.7. [arguments]: Remove trailing #t from phases. Remove unnecessary file field from find-files. (libltdl)[arguments]: Remove trailing #t. * gnu/packages/patches/libtool-skip-tests2.patch: Update patch.master
parent
3acb615a38
commit
1da2834720
|
@ -6,7 +6,7 @@
|
||||||
;;; Copyright © 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
|
||||||
;;; Copyright © 2016 David Thompson <davet@gnu.org>
|
;;; Copyright © 2016 David Thompson <davet@gnu.org>
|
||||||
;;; Copyright © 2017 Nikita <nikita@n0.is>
|
;;; Copyright © 2017 Nikita <nikita@n0.is>
|
||||||
;;; Copyright © 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
|
;;; Copyright © 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
|
||||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||||
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
|
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
|
||||||
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
|
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
|
||||||
|
@ -451,14 +451,14 @@ Makefile, simplifying the entire process for the developer.")
|
||||||
(define-public libtool
|
(define-public libtool
|
||||||
(package
|
(package
|
||||||
(name "libtool")
|
(name "libtool")
|
||||||
(version "2.4.6")
|
(version "2.4.7")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/libtool/libtool-"
|
(uri (string-append "mirror://gnu/libtool/libtool-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
|
"0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))
|
||||||
(patches (search-patches "libtool-skip-tests2.patch"))))
|
(patches (search-patches "libtool-skip-tests2.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(propagated-inputs (list m4))
|
(propagated-inputs (list m4))
|
||||||
|
@ -495,8 +495,7 @@ Makefile, simplifying the entire process for the developer.")
|
||||||
(let ((bash (assoc-ref (or native-inputs inputs) "bash")))
|
(let ((bash (assoc-ref (or native-inputs inputs) "bash")))
|
||||||
(substitute* "tests/testsuite"
|
(substitute* "tests/testsuite"
|
||||||
(("/bin/sh")
|
(("/bin/sh")
|
||||||
(string-append bash "/bin/sh")))
|
(string-append bash "/bin/sh"))))))
|
||||||
#t)))
|
|
||||||
;; These files may be copied into source trees by libtoolize,
|
;; These files may be copied into source trees by libtoolize,
|
||||||
;; therefore they must not point to store file names that would be
|
;; therefore they must not point to store file names that would be
|
||||||
;; leaked with tarballs generated by make dist.
|
;; leaked with tarballs generated by make dist.
|
||||||
|
@ -508,8 +507,7 @@ Makefile, simplifying the entire process for the developer.")
|
||||||
(format #t "restoring shebang on `~a'~%" file)
|
(format #t "restoring shebang on `~a'~%" file)
|
||||||
(substitute* file
|
(substitute* file
|
||||||
(("^#!.*/bin/sh") "#!/bin/sh")))
|
(("^#!.*/bin/sh") "#!/bin/sh")))
|
||||||
(find-files dir ".*"))
|
(find-files dir))))))))
|
||||||
#t))))))
|
|
||||||
|
|
||||||
(synopsis "Generic shared library support tools")
|
(synopsis "Generic shared library support tools")
|
||||||
(description
|
(description
|
||||||
|
@ -573,20 +571,20 @@ configuration in nearly all GNU packages (and many others).")
|
||||||
;; Libtool's extensive test suite isn't run.
|
;; Libtool's extensive test suite isn't run.
|
||||||
(package
|
(package
|
||||||
(name "libltdl")
|
(name "libltdl")
|
||||||
(version "2.4.6")
|
(version "2.4.7")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/libtool/libtool-"
|
(uri (string-append "mirror://gnu/libtool/libtool-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))))
|
"0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:configure-flags '("--enable-ltdl-install") ;really install it
|
'(#:configure-flags '("--enable-ltdl-install") ;really install it
|
||||||
#:phases (modify-phases %standard-phases
|
#:phases (modify-phases %standard-phases
|
||||||
(add-before 'configure 'change-directory
|
(add-before 'configure 'change-directory
|
||||||
(lambda _ (chdir "libltdl") #t)))))
|
(lambda _ (chdir "libltdl"))))))
|
||||||
|
|
||||||
(synopsis "System-independent dlopen wrapper of GNU libtool")
|
(synopsis "System-independent dlopen wrapper of GNU libtool")
|
||||||
(description (package-description libtool))
|
(description (package-description libtool))
|
||||||
|
|
|
@ -16,7 +16,7 @@ Skip the nopic test on ARM, MIPS and RISC-V systems.
|
||||||
@@ -8741,7 +8741,7 @@
|
@@ -8741,7 +8741,7 @@
|
||||||
|
|
||||||
{ set +x
|
{ set +x
|
||||||
$as_echo "$at_srcdir/demo.at:535: case \$host in
|
$as_echo "$at_srcdir/demo.at:513: case \$host in
|
||||||
-hppa*|x86_64*|s390*)
|
-hppa*|x86_64*|s390*)
|
||||||
+hppa*|x86_64*|s390*|arm*|mips*|riscv*)
|
+hppa*|x86_64*|s390*|arm*|mips*|riscv*)
|
||||||
# These hosts cannot use non-PIC shared libs
|
# These hosts cannot use non-PIC shared libs
|
||||||
|
@ -24,7 +24,7 @@ Skip the nopic test on ARM, MIPS and RISC-V systems.
|
||||||
*-solaris*|*-sunos*)
|
*-solaris*|*-sunos*)
|
||||||
@@ -8766,7 +8766,7 @@
|
@@ -8766,7 +8766,7 @@
|
||||||
"
|
"
|
||||||
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
|
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:513"
|
||||||
( $at_check_trace; case $host in
|
( $at_check_trace; case $host in
|
||||||
-hppa*|x86_64*|s390*)
|
-hppa*|x86_64*|s390*)
|
||||||
+hppa*|x86_64*|s390*|arm*|mips*|riscv*)
|
+hppa*|x86_64*|s390*|arm*|mips*|riscv*)
|
||||||
|
|
Reference in New Issue