me
/
guix
Archived
1
0
Fork 0

gnu: vtk-7: Fix build.

* gnu/packages/patches/vtk-7-gcc-11-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/image-processing.scm (vtk-7)[source]: Add patch for gcc-11.
master
宋文武 2023-08-29 22:06:02 +08:00
parent 6609f2f4a7
commit 1dc8cdaa72
No known key found for this signature in database
GPG Key ID: D415BF253B515976
3 changed files with 14 additions and 1 deletions

View File

@ -2085,6 +2085,7 @@ dist_patch_DATA = \
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
%D%/packages/patches/vtk-7-gcc-10-compat.patch \
%D%/packages/patches/vtk-7-gcc-11-compat.patch \
%D%/packages/patches/vtk-7-hdf5-compat.patch \
%D%/packages/patches/vtk-7-python-compat.patch \
%D%/packages/patches/wacomtablet-add-missing-includes.patch \

View File

@ -473,7 +473,8 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
"0nm7xwwj7rnsxjdv2ssviys8nhci4n9iiiqm2y14s520hl2dsp1d"))
(patches (search-patches "vtk-7-python-compat.patch"
"vtk-7-hdf5-compat.patch"
"vtk-7-gcc-10-compat.patch"))))
"vtk-7-gcc-10-compat.patch"
"vtk-7-gcc-11-compat.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments vtk)
((#:configure-flags flags)

View File

@ -0,0 +1,11 @@
Description: GCC 11 now enforces that comparison objects be invocable as const.
--- a/Rendering/Label/vtkLabelHierarchy.cxx
+++ b/Rendering/Label/vtkLabelHierarchy.cxx
@@ -525,1 +525,1 @@
- const vtkHierarchyNode & b)
+ const vtkHierarchyNode & b) const
--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
+++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
@@ -66,1 +66,1 @@
- bool operator () ( const vtkIdType& a, const vtkIdType& b )
+ bool operator () ( const vtkIdType& a, const vtkIdType& b ) const