gnu: crawl: Update to 0.29.0.
* gnu/packages/games.scm (crawl): Update to 0.29.0. [source]<origin>: Use GIT-FETCH method. [arguments]<#:make-flags>: Match new directory layout. <#:phases>: Add a phase to set version without calling GIT. * gnu/packages/patches/crawl-upgrade-saves.patch: Match new directory layout.master
parent
f323f04326
commit
1e16af13b0
|
@ -6515,14 +6515,16 @@ fish. The whole game is accompanied by quiet, comforting music.")
|
||||||
(define-public crawl
|
(define-public crawl
|
||||||
(package
|
(package
|
||||||
(name "crawl")
|
(name "crawl")
|
||||||
(version "0.28.0")
|
(version "0.29.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method git-fetch)
|
||||||
(uri (string-append "https://github.com/crawl/crawl/releases/download/"
|
(uri (git-reference
|
||||||
version "/stone_soup-" version "-nodeps.tar.xz"))
|
(url "https://github.com/crawl/crawl")
|
||||||
|
(commit version)))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0irg5w4m127fxcj037kyp9vnyqyq1fi4q64rn6yq92w8z1lf2sss"))
|
(base32 "0cx67ln5qr4bawidi48ss63wflx7x22901da683c9wvy6m41vks8"))
|
||||||
(patches (search-patches "crawl-upgrade-saves.patch"))))
|
(patches (search-patches "crawl-upgrade-saves.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
|
@ -6552,12 +6554,17 @@ fish. The whole game is accompanied by quiet, comforting music.")
|
||||||
"BUILD_LUA="
|
"BUILD_LUA="
|
||||||
"BUILD_SQLITE="
|
"BUILD_SQLITE="
|
||||||
"BUILD_ZLIB="
|
"BUILD_ZLIB="
|
||||||
"-Csource")
|
"-Ccrawl-ref/source")
|
||||||
#:phases
|
#:phases
|
||||||
#~(modify-phases %standard-phases
|
#~(modify-phases %standard-phases
|
||||||
|
(add-after 'unpack 'set-version
|
||||||
|
(lambda _
|
||||||
|
(call-with-output-file "crawl-ref/source/util/release_ver"
|
||||||
|
(lambda (port)
|
||||||
|
(display #$version port)))))
|
||||||
(add-after 'unpack 'find-SDL-image
|
(add-after 'unpack 'find-SDL-image
|
||||||
(lambda _
|
(lambda _
|
||||||
(substitute* "source/windowmanager-sdl.cc"
|
(substitute* "crawl-ref/source/windowmanager-sdl.cc"
|
||||||
(("SDL_image.h") "SDL2/SDL_image.h"))))
|
(("SDL_image.h") "SDL2/SDL_image.h"))))
|
||||||
(delete 'configure)
|
(delete 'configure)
|
||||||
(replace 'check
|
(replace 'check
|
||||||
|
|
|
@ -6,8 +6,8 @@ upgrade is required, but guix nulls all file dates,
|
||||||
and crawl would never upgrade saves.
|
and crawl would never upgrade saves.
|
||||||
|
|
||||||
diff -ur a/source/database.cc b/source/database.cc
|
diff -ur a/source/database.cc b/source/database.cc
|
||||||
--- a/source/database.cc 2018-08-09 21:49:26.000000000 -0400
|
--- a/crawl-ref/source/database.cc 2018-08-09 21:49:26.000000000 -0400
|
||||||
+++ b/source/database.cc 2018-10-07 18:06:41.022445789 -0400
|
+++ b/crawl-ref/source/database.cc 2018-10-07 18:06:41.022445789 -0400
|
||||||
@@ -24,6 +24,7 @@
|
@@ -24,6 +24,7 @@
|
||||||
#include "stringutil.h"
|
#include "stringutil.h"
|
||||||
#include "syscalls.h"
|
#include "syscalls.h"
|
||||||
|
|
Reference in New Issue