me
/
guix
Archived
1
0
Fork 0

gnu: qpdfview: Fix qt-5.15 compatibility.

* gnu/packages/pdf.scm (qpdfview)[source]: Add patch to include a missing
header.
* gnu/packages/patches/qpdfview-qt515-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Leo Famulari <leo@famulari.name>
master
Timotej Lazar 2021-02-08 16:40:17 +01:00 committed by Leo Famulari
parent e6034e3cf8
commit 1e9f667708
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 20 additions and 1 deletions

View File

@ -1560,6 +1560,7 @@ dist_patch_DATA = \
%D%/packages/patches/pypy3-7.3.1-fix-tests.patch \ %D%/packages/patches/pypy3-7.3.1-fix-tests.patch \
%D%/packages/patches/qemu-build-info-manual.patch \ %D%/packages/patches/qemu-build-info-manual.patch \
%D%/packages/patches/qemu-glibc-2.27.patch \ %D%/packages/patches/qemu-glibc-2.27.patch \
%D%/packages/patches/qpdfview-qt515-compat.patch \
%D%/packages/patches/qrcodegen-cpp-make-install.patch \ %D%/packages/patches/qrcodegen-cpp-make-install.patch \
%D%/packages/patches/qt4-ldflags.patch \ %D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-absolute-runpath.patch \ %D%/packages/patches/qtbase-absolute-runpath.patch \

View File

@ -0,0 +1,17 @@
Fix compatibility with Qt 5.15.
Patch copied from upstream source repository:
https://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/revision/2104
--- a/sources/model.h 2017-04-19 21:01:25 +0000
+++ b/sources/model.h 2020-06-09 06:24:11 +0000
@@ -24,6 +24,7 @@
#define DOCUMENTMODEL_H
#include <QList>
+#include <QPainterPath>
#include <QtPlugin>
#include <QWidget>
#include <QVector>

View File

@ -869,7 +869,8 @@ program capable of converting PDF into other formats.")
"trunk/" version "/+download/" "trunk/" version "/+download/"
"qpdfview-" version ".tar.gz")) "qpdfview-" version ".tar.gz"))
(sha256 (sha256
(base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c")))) (base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c"))
(patches (search-patches "qpdfview-qt515-compat.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config))) `(("pkg-config" ,pkg-config)))