gnu: parted: Complete the 3.3 update.
Fixes <https://bugs.gnu.org/37721>.
Reported by Jesse Gibbons <jgibbons2357@gmail.com>.
This is a follow-up to commit 6ad7e3578b
.
* gnu/packages/patches/parted-glibc-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/disk.scm (parted)[source](patches): Remove.
[native-inputs]: Add E2FSPROGS.
master
parent
b51c402f23
commit
20e0157333
|
@ -1187,7 +1187,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/p7zip-CVE-2016-9296.patch \
|
||||
%D%/packages/patches/p7zip-CVE-2017-17969.patch \
|
||||
%D%/packages/patches/p7zip-remove-unused-code.patch \
|
||||
%D%/packages/patches/parted-glibc-compat.patch \
|
||||
%D%/packages/patches/patchelf-page-size.patch \
|
||||
%D%/packages/patches/patchelf-rework-for-arm.patch \
|
||||
%D%/packages/patches/patchutils-test-perms.patch \
|
||||
|
|
|
@ -83,7 +83,6 @@
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/parted/parted-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "parted-glibc-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0i1xp367wpqw75b20c3jnism3dg3yqj4a7a22p2jb1h1hyyv9qjp"))))
|
||||
|
@ -105,6 +104,7 @@
|
|||
(native-inputs
|
||||
`(("gettext" ,gettext-minimal)
|
||||
;; For the tests.
|
||||
("e2fsprogs" ,e2fsprogs)
|
||||
("perl" ,perl)
|
||||
("python" ,python-2)))
|
||||
(home-page "https://www.gnu.org/software/parted/")
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Include <sys/sysmacros.h> for "major" and "minor".
|
||||
|
||||
Taken from upstream:
|
||||
https://git.savannah.gnu.org/cgit/parted.git/commit/?id=ba5e0451b51c983e40afd123b6e0d3eddb55e610
|
||||
|
||||
diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
|
||||
index 31b98ab..7e86b51 100644
|
||||
--- a/libparted/arch/linux.c
|
||||
+++ b/libparted/arch/linux.c
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <sys/utsname.h> /* for uname() */
|
||||
#include <scsi/scsi.h>
|
||||
#include <assert.h>
|
||||
+#include <sys/sysmacros.h>
|
||||
#ifdef ENABLE_DEVICE_MAPPER
|
||||
#include <libdevmapper.h>
|
||||
#endif
|
Reference in New Issue