gnu: qtdeclarative: Update to 6.6.2.
* gnu/packages/qt.scm (qtdeclarative): Update to 6.6.2. [arguments]<#:phases>: Disable flaky tst_qmltyperegistrar test. Disable failing tst_qquickiconimage test. * gnu/packages/patches/qtdeclarative-disable-qmlcache.patch: Adjust it. Change-Id: Ic7ddb603524ff07916d57b2ce92b7ffa407a5004 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>master
parent
4605bc67d3
commit
2202f440e6
|
@ -1,16 +1,31 @@
|
||||||
Retrieved from
|
Retrieved from
|
||||||
https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/libraries/qt-6/patches/qtdeclarative-default-disable-qmlcache.patch
|
https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/libraries/qt-6/patches/qtdeclarative-default-disable-qmlcache.patch
|
||||||
|
|
||||||
|
From 2d561e0a80f2d123a7348187975ee845f9dcd9e0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nick Cao <nickcao@nichi.co>
|
||||||
|
Date: Tue, 10 Oct 2023 11:12:27 -0400
|
||||||
|
Subject: [PATCH] qtdeclarative: disable qml disk cache
|
||||||
|
|
||||||
|
---
|
||||||
|
src/qml/jsruntime/qv4engine.cpp | 6 +-----
|
||||||
|
1 file changed, 1 insertion(+), 5 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/qml/jsruntime/qv4engine.cpp b/src/qml/jsruntime/qv4engine.cpp
|
diff --git a/src/qml/jsruntime/qv4engine.cpp b/src/qml/jsruntime/qv4engine.cpp
|
||||||
index 852cde9e..165f1b57 100644
|
index d1b4c4fff6..50f8a07420 100644
|
||||||
--- a/src/qml/jsruntime/qv4engine.cpp
|
--- a/src/qml/jsruntime/qv4engine.cpp
|
||||||
+++ b/src/qml/jsruntime/qv4engine.cpp
|
+++ b/src/qml/jsruntime/qv4engine.cpp
|
||||||
@@ -2093,7 +2093,7 @@ void ExecutionEngine::registerModule(const QString &_name, const QJSValue &modul
|
@@ -2232,11 +2232,7 @@ ExecutionEngine::DiskCacheOptions ExecutionEngine::diskCacheOptions() const
|
||||||
|
|
||||||
bool ExecutionEngine::diskCacheEnabled() const
|
|
||||||
{
|
{
|
||||||
- return (!disableDiskCache() && !debugger()) || forceDiskCache();
|
if (forceDiskCache())
|
||||||
+ return forceDiskCache();
|
return DiskCache::Enabled;
|
||||||
|
- if (disableDiskCache() || debugger())
|
||||||
|
- return DiskCache::Disabled;
|
||||||
|
- static const DiskCacheOptions options = qmlGetConfigOption<
|
||||||
|
- DiskCacheOptions, transFormDiskCache>("QML_DISK_CACHE");
|
||||||
|
- return options;
|
||||||
|
+ return DiskCache::Disabled;
|
||||||
}
|
}
|
||||||
|
|
||||||
void ExecutionEngine::callInContext(QV4::Function *function, QObject *self,
|
void ExecutionEngine::callInContext(QV4::Function *function, QObject *self,
|
||||||
|
--
|
||||||
|
2.42.0
|
||||||
|
|
|
@ -1491,14 +1491,14 @@ with JavaScript and C++.")))
|
||||||
(define-public qtdeclarative
|
(define-public qtdeclarative
|
||||||
(package
|
(package
|
||||||
(name "qtdeclarative")
|
(name "qtdeclarative")
|
||||||
(version "6.5.2")
|
(version "6.6.2")
|
||||||
;; TODO: Package 'masm' and unbundle from sources.
|
;; TODO: Package 'masm' and unbundle from sources.
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (qt-url name version))
|
(uri (qt-url name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"06c7xfqn2a5s2m8j1bcvx3pyjqg1rgqkjvp49737gb4z9vjiz8gk"))
|
"0k6qndjvkkx3g8lr7f64xx86b3cwxzkgpl6fr6cp73s6qjkyk763"))
|
||||||
(patches (search-patches "qtdeclarative-disable-qmlcache.patch"))))
|
(patches (search-patches "qtdeclarative-disable-qmlcache.patch"))))
|
||||||
(outputs '("out" "debug"))
|
(outputs '("out" "debug"))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
|
@ -1568,6 +1568,10 @@ with JavaScript and C++.")))
|
||||||
"("
|
"("
|
||||||
(string-join
|
(string-join
|
||||||
(list
|
(list
|
||||||
|
;; The 'tst_qmltyperegistrar' tests may fail
|
||||||
|
;; non-deterministically (see:
|
||||||
|
;; https://bugreports.qt.io/browse/QTBUG-123634).
|
||||||
|
"tst_qmltyperegistrar"
|
||||||
;; This test is marked as flaky upstream (see:
|
;; This test is marked as flaky upstream (see:
|
||||||
;; https://bugreports.qt.io/browse/QTBUG-101488).
|
;; https://bugreports.qt.io/browse/QTBUG-101488).
|
||||||
"tst_qquickfiledialogimpl"
|
"tst_qquickfiledialogimpl"
|
||||||
|
@ -1610,7 +1614,11 @@ with JavaScript and C++.")))
|
||||||
"tst_dom_all"
|
"tst_dom_all"
|
||||||
"tst_qmlls"
|
"tst_qmlls"
|
||||||
"tst_qmllscompletions"
|
"tst_qmllscompletions"
|
||||||
) "|")
|
|
||||||
|
;; This test fails starting with 6.6.2 (see:
|
||||||
|
;; https://bugreports.qt.io/browse/QTBUG-123748), for
|
||||||
|
;; unknown reasons.
|
||||||
|
"tst_qquickiconimage") "|")
|
||||||
")")))))
|
")")))))
|
||||||
(add-after 'install 'delete-installed-tests
|
(add-after 'install 'delete-installed-tests
|
||||||
(lambda _
|
(lambda _
|
||||||
|
|
Reference in New Issue