gnu: strace: Fix test failures on some systems.
* gnu/packages/patches/strace-ipc-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/linux.scm (strace)[source](patches): New field. [arguments]: Add 'regenerate-tests' phase. Co-Authored-By: Mark H Weaver <mhw@netris.org>master
parent
96681d4be1
commit
2426e2c94c
|
@ -1305,6 +1305,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
||||||
%D%/packages/patches/sssd-curl-compat.patch \
|
%D%/packages/patches/sssd-curl-compat.patch \
|
||||||
%D%/packages/patches/steghide-fixes.patch \
|
%D%/packages/patches/steghide-fixes.patch \
|
||||||
|
%D%/packages/patches/strace-ipc-tests.patch \
|
||||||
%D%/packages/patches/streamlink-update-test.patch \
|
%D%/packages/patches/streamlink-update-test.patch \
|
||||||
%D%/packages/patches/stumpwm-fix-broken-read-one-line.patch \
|
%D%/packages/patches/stumpwm-fix-broken-read-one-line.patch \
|
||||||
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
||||||
|
|
|
@ -1408,6 +1408,9 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append home-page "/files/" version
|
(uri (string-append home-page "/files/" version
|
||||||
"/strace-" version ".tar.xz"))
|
"/strace-" version ".tar.xz"))
|
||||||
|
;; XXX Remove the 'regenerate-tests' phase below when
|
||||||
|
;; "strace-ipc-tests.patch" is no longer applied.
|
||||||
|
(patches (search-patches "strace-ipc-tests.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1li49i75wrdw91hchyyd8spnzfcmxcfyfb5g9zbaza89aq4bq4ym"))))
|
"1li49i75wrdw91hchyyd8spnzfcmxcfyfb5g9zbaza89aq4bq4ym"))))
|
||||||
|
@ -1419,7 +1422,14 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
|
||||||
(lambda _
|
(lambda _
|
||||||
(substitute* "strace.c"
|
(substitute* "strace.c"
|
||||||
(("/bin/sh") (which "sh")))
|
(("/bin/sh") (which "sh")))
|
||||||
#t)))
|
#t))
|
||||||
|
(add-before 'configure 'regenerate-tests
|
||||||
|
;; XXX Remove this phase when "strace-ipc-tests.patch" is no longer
|
||||||
|
;; applied in the 'source' field above. This phase is needed to
|
||||||
|
;; regenerate many other files from tests/gen_tests.in, which is
|
||||||
|
;; modified by the aforementioned patch.
|
||||||
|
(lambda _
|
||||||
|
(invoke "tests/gen_tests.sh"))))
|
||||||
;; Don't fail if the architecture doesn't support different personalities.
|
;; Don't fail if the architecture doesn't support different personalities.
|
||||||
#:configure-flags '("--enable-mpers=check")
|
#:configure-flags '("--enable-mpers=check")
|
||||||
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.
|
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.
|
||||||
|
|
|
@ -0,0 +1,30 @@
|
||||||
|
Fix a test failure on some systems.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://github.com/strace/strace/commit/4377e3a1535a0ec3a42da8a1366ad6943f4efa0e
|
||||||
|
|
||||||
|
diff --git a/tests/gen_tests.in b/tests/gen_tests.in
|
||||||
|
index 4a506b94c..4fdf4722c 100644
|
||||||
|
--- a/tests/gen_tests.in
|
||||||
|
+++ b/tests/gen_tests.in
|
||||||
|
@@ -168,16 +168,16 @@ ipc_msg-Xabbrev +ipc.sh -Xabbrev -a26
|
||||||
|
ipc_msg-Xraw +ipc.sh -Xraw -a16
|
||||||
|
ipc_msg-Xverbose +ipc.sh -Xverbose -a34
|
||||||
|
ipc_msgbuf-Xabbrev +ipc_msgbuf.test -Xabbrev
|
||||||
|
-ipc_msgbuf-Xraw +ipc_msgbuf.test -Xraw -a22
|
||||||
|
+ipc_msgbuf-Xraw +ipc_msgbuf.test -Xraw -a20
|
||||||
|
ipc_msgbuf-Xverbose +ipc_msgbuf.test -Xverbose
|
||||||
|
ipc_sem +ipc.sh -a29
|
||||||
|
ipc_sem-Xabbrev +ipc.sh -Xabbrev -a29
|
||||||
|
ipc_sem-Xraw +ipc.sh -Xraw -a19
|
||||||
|
ipc_sem-Xverbose +ipc.sh -Xverbose -a36
|
||||||
|
-ipc_shm +ipc.sh -a29
|
||||||
|
-ipc_shm-Xabbrev +ipc.sh -Xabbrev -a29
|
||||||
|
+ipc_shm +ipc.sh -a26
|
||||||
|
+ipc_shm-Xabbrev +ipc.sh -Xabbrev -a26
|
||||||
|
ipc_shm-Xraw +ipc.sh -Xraw -a19
|
||||||
|
-ipc_shm-Xverbose +ipc.sh -Xverbose -a36
|
||||||
|
+ipc_shm-Xverbose +ipc.sh -Xverbose -a34
|
||||||
|
kcmp -a22
|
||||||
|
kcmp-y -a22 -y -e trace=kcmp
|
||||||
|
kern_features -a16
|
Reference in New Issue