me
/
guix
Archived
1
0
Fork 0

gnu: qtbase: Patch the 'moc' executable to cope with GCCs C++ headers.

* gnu/packages/patches/qtbase-moc-ignore-gcc-macro.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/qt.scm (qtbase)[source](patches): Add it.
master
Marius Bakke 2020-03-29 11:35:04 +02:00
parent 58f705c18e
commit 26e92a3025
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 19 additions and 0 deletions

View File

@ -1385,6 +1385,7 @@ dist_patch_DATA = \
%D%/packages/patches/qemu-fix-documentation-build-failure.patch \
%D%/packages/patches/qrcodegen-cpp-make-install.patch \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-moc-ignore-gcc-macro.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtbase-QTBUG-81715.patch \
%D%/packages/patches/qtscript-disable-tests.patch \

View File

@ -0,0 +1,17 @@
The moc executable loops through headers on CPLUS_INCLUDE_PATH and stumbles
on the GCC internal _GLIBCXX_VISIBILITY macro. Tell it to ignore it as it is
not supposed to be looking there to begin with.
Upstream report: https://bugreports.qt.io/browse/QTBUG-83160
diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp
--- a/src/tools/moc/main.cpp
+++ b/src/tools/moc/main.cpp
@@ -188,6 +188,7 @@ int runMoc(int argc, char **argv)
dummyVariadicFunctionMacro.arguments += Symbol(0, PP_IDENTIFIER, "__VA_ARGS__");
pp.macros["__attribute__"] = dummyVariadicFunctionMacro;
pp.macros["__declspec"] = dummyVariadicFunctionMacro;
+ pp.macros["_GLIBCXX_VISIBILITY"] = dummyVariadicFunctionMacro;
QString filename;
QString output;

View File

@ -352,6 +352,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"0pb68d30clksdhgy8n6rrs838bb3qcsfq4pv463yy2nr4p5kk2di"))
;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch"
"qtbase-moc-ignore-gcc-macro.patch"
"qtbase-QTBUG-81715.patch"))
(modules '((guix build utils)))
(snippet