gnu: mesa: Fix test failure on 32-bit systems.
* gnu/packages/patches/mesa-timespec-test-32bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gl.scm (mesa)[source](patches): Add it.master
parent
531b63eba7
commit
2737c7fe8a
|
@ -1110,6 +1110,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
|
||||
%D%/packages/patches/mesa-timespec-test-32bit.patch \
|
||||
%D%/packages/patches/mescc-tools-boot.patch \
|
||||
%D%/packages/patches/meson-for-build-rpath.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
|
|
|
@ -243,7 +243,8 @@ also known as DXTn or DXTC) for Mesa.")
|
|||
(base32
|
||||
"1s81kwcjkkahnf5y5mshmd3q9j057hhsai7awpq6yb6im2hkriac"))
|
||||
(patches
|
||||
(search-patches "mesa-skip-disk-cache-test.patch"))))
|
||||
(search-patches "mesa-skip-disk-cache-test.patch"
|
||||
"mesa-timespec-test-32bit.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(propagated-inputs
|
||||
`(;; The following are in the Requires.private field of gl.pc.
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
Fix a test failure on 32-bit systems.
|
||||
|
||||
Taken from upstream:
|
||||
https://gitlab.freedesktop.org/mesa/mesa/commit/dd1dba80b9ee74ec8b90761285a8262e374bf8ef
|
||||
|
||||
diff --git a/src/util/tests/timespec/timespec_test.cpp b/src/util/tests/timespec/timespec_test.cpp
|
||||
--- a/src/util/tests/timespec/timespec_test.cpp
|
||||
+++ b/src/util/tests/timespec/timespec_test.cpp
|
||||
@@ -206,7 +206,7 @@ TEST(timespec_test, timespec_from_nsec)
|
||||
|
||||
timespec_from_nsec(&a, UINT64_MAX);
|
||||
EXPECT_EQ(a.tv_nsec, UINT64_MAX % NSEC_PER_SEC);
|
||||
- EXPECT_EQ(a.tv_sec, UINT64_MAX / NSEC_PER_SEC);
|
||||
+ EXPECT_EQ(a.tv_sec, (time_t)(UINT64_MAX / NSEC_PER_SEC));
|
||||
}
|
||||
|
||||
TEST(timespec_test, timespec_from_usec)
|
Reference in New Issue