From 278c533b093edc0d67cf2eddb5fc9c626c03e5f2 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Thu, 13 Jul 2023 00:31:53 +0200
Subject: [PATCH] gnu: Add texlive-grafcet.

* gnu/packages/tex.scm (texlive-grafcet): New variable.
---
 gnu/packages/tex.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7335bb8c83..ce2c2fd3f6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17376,6 +17376,25 @@ files.")
 The gradients of the frames are drawn using the @code{color} package.")
     (license license:lppl1.3+)))
 
+(define-public texlive-grafcet
+  (package
+    (name "texlive-grafcet")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/grafcet/" "tex/latex/grafcet/")
+             (base32
+              "1swrap90i4l3a6azvy40b991zkqvyfw2z3mk6cq727yplmr1hkwk")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/grafcet")
+    (synopsis "Draw Grafcet/SFC with TikZ")
+    (description
+     "The package provides a library (GRAFCET) that can draw Grafcet
+Sequential Function Chart (SFC) diagrams, in accordance with EN 60848, using
+PGF/TikZ.")
+    (license license:lppl1.0+)))
+
 (define-public texlive-inlinedef
   (package
     (name "texlive-inlinedef")