gnu: Remove libvpx@1.7.
* gnu/packages/patches/libvpx-use-after-free-in-postproc.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/video.scm (libvpx-1.7): Remove variable.master
parent
07fc1c0d44
commit
27ed894851
|
@ -1161,7 +1161,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libvnc-CVE-2018-20750.patch \
|
%D%/packages/patches/libvnc-CVE-2018-20750.patch \
|
||||||
%D%/packages/patches/libvnc-CVE-2019-15681.patch \
|
%D%/packages/patches/libvnc-CVE-2019-15681.patch \
|
||||||
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
|
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
|
||||||
%D%/packages/patches/libvpx-use-after-free-in-postproc.patch \
|
|
||||||
%D%/packages/patches/libxslt-generated-ids.patch \
|
%D%/packages/patches/libxslt-generated-ids.patch \
|
||||||
%D%/packages/patches/libxt-guix-search-paths.patch \
|
%D%/packages/patches/libxt-guix-search-paths.patch \
|
||||||
%D%/packages/patches/lierolibre-check-unaligned-access.patch \
|
%D%/packages/patches/lierolibre-check-unaligned-access.patch \
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
From 52add5896661d186dec284ed646a4b33b607d2c7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jerome Jiang <jianj@google.com>
|
|
||||||
Date: Wed, 23 May 2018 15:43:00 -0700
|
|
||||||
Subject: [PATCH] VP8: Fix use-after-free in postproc.
|
|
||||||
|
|
||||||
The pointer in vp8 postproc refers to show_frame_mi which is only
|
|
||||||
updated on show frame. However, when there is a no-show frame which also
|
|
||||||
changes the size (thus new frame buffers allocated), show_frame_mi is
|
|
||||||
not updated with new frame buffer memory.
|
|
||||||
|
|
||||||
Change the pointer in postproc to mi which is always updated.
|
|
||||||
|
|
||||||
Bug: 842265
|
|
||||||
Change-Id: I33874f2112b39f74562cba528432b5f239e6a7bd
|
|
||||||
---
|
|
||||||
vp8/common/postproc.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/vp8/common/postproc.c b/vp8/common/postproc.c
|
|
||||||
index d67ee8a57..8c292d616 100644
|
|
||||||
--- a/vp8/common/postproc.c
|
|
||||||
+++ b/vp8/common/postproc.c
|
|
||||||
@@ -65,7 +65,7 @@ void vp8_deblock(VP8_COMMON *cm, YV12_BUFFER_CONFIG *source,
|
|
||||||
double level = 6.0e-05 * q * q * q - .0067 * q * q + .306 * q + .0065;
|
|
||||||
int ppl = (int)(level + .5);
|
|
||||||
|
|
||||||
- const MODE_INFO *mode_info_context = cm->show_frame_mi;
|
|
||||||
+ const MODE_INFO *mode_info_context = cm->mi;
|
|
||||||
int mbr, mbc;
|
|
||||||
|
|
||||||
/* The pixel thresholds are adjusted according to if or not the macroblock
|
|
||||||
--
|
|
||||||
2.19.0
|
|
||||||
|
|
|
@ -1622,25 +1622,6 @@ To load this plugin, specify the following option when starting mpv:
|
||||||
(license license:bsd-3)
|
(license license:bsd-3)
|
||||||
(home-page "https://www.webmproject.org/")))
|
(home-page "https://www.webmproject.org/")))
|
||||||
|
|
||||||
;; GNU IceCat fails to build against 1.8.0, so keep this version for now.
|
|
||||||
(define-public libvpx-1.7
|
|
||||||
(package
|
|
||||||
(inherit libvpx)
|
|
||||||
(version "1.7.0")
|
|
||||||
(source (origin
|
|
||||||
(inherit (package-source libvpx))
|
|
||||||
(uri (git-reference
|
|
||||||
(url "https://chromium.googlesource.com/webm/libvpx")
|
|
||||||
(commit (string-append "v" version))))
|
|
||||||
(file-name (git-file-name "libvpx" version))
|
|
||||||
(sha256
|
|
||||||
(base32
|
|
||||||
"0vvh89hvp8qg9an9vcmwb7d9k3nixhxaz6zi65qdjnd0i56kkcz6"))
|
|
||||||
(patches
|
|
||||||
(append
|
|
||||||
(origin-patches (package-source libvpx))
|
|
||||||
(search-patches "libvpx-use-after-free-in-postproc.patch")))))))
|
|
||||||
|
|
||||||
(define-public youtube-dl
|
(define-public youtube-dl
|
||||||
(package
|
(package
|
||||||
(name "youtube-dl")
|
(name "youtube-dl")
|
||||||
|
|
Reference in New Issue