gnu: rust-rspec-1: Remove dependency on clippy.
* gnu/packages/crates-io.scm (rust-rspec-1)[source]: Add patch. [cargo-inputs]: Remove rust-clippy-0.0.153. * gnu/packages/patches/rust-rspec-1-remove-clippy.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: Ia6cc5e2fa798986b93ccba5f8907de79676fd1b0master
parent
5d205402d9
commit
27f4d9a2c0
|
@ -2008,6 +2008,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \
|
||||
%D%/packages/patches/rust-ndarray-0.14-remove-blas-src.patch \
|
||||
%D%/packages/patches/rust-nettle-disable-vendor.patch \
|
||||
%D%/packages/patches/rust-rspec-1-remove-clippy.patch \
|
||||
%D%/packages/patches/rust-trash-2-update-windows.patch \
|
||||
%D%/packages/patches/rust-webbrowser-remove-unsupported-os.patch \
|
||||
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
|
||||
|
|
|
@ -65217,12 +65217,12 @@ can handle huge texts and memory-incoherent edits with ease.")
|
|||
(uri (crate-uri "rspec" version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "02hfwxqjdc39ygnjysvn5qz343fahmwm16rxvxayh403d5y9wf49"))))
|
||||
(base32 "02hfwxqjdc39ygnjysvn5qz343fahmwm16rxvxayh403d5y9wf49"))
|
||||
(patches (search-patches "rust-rspec-1-remove-clippy.patch"))))
|
||||
(build-system cargo-build-system)
|
||||
(arguments
|
||||
`(#:cargo-inputs
|
||||
(("rust-clippy" ,rust-clippy-0.0.153)
|
||||
("rust-colored" ,rust-colored-2)
|
||||
(("rust-colored" ,rust-colored-2)
|
||||
("rust-derive-new" ,rust-derive-new-0.5)
|
||||
("rust-derive-builder" ,rust-derive-builder-0.9)
|
||||
("rust-expectest" ,rust-expectest-0.12)
|
||||
|
|
|
@ -0,0 +1,16 @@
|
|||
Remove the dependency on clippy
|
||||
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 177cb80..7260c34 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -39,9 +39,6 @@ version = "1.5"
|
||||
|
||||
[dependencies.time]
|
||||
version = "0.2"
|
||||
-[build-dependencies.clippy]
|
||||
-version = "0.0.153"
|
||||
-optional = true
|
||||
|
||||
[features]
|
||||
default = []
|
Reference in New Issue