gnu: Add go-github-com-bwesterb-go-ristretto.
* gnu/packages/golang.scm (go-github-com-bwesterb-go-ristretto): New variable. Change-Id: Icbe3bc2808776d6451ad154653245439173424d5master
parent
08e7d92f5e
commit
281f899c21
|
@ -10022,6 +10022,29 @@ package is intended for interoperability with the standard library and the
|
|||
@@url{https://filippo.io/edwards25519,edwards25519} package as much as possible.")
|
||||
(license license:bsd-3))))
|
||||
|
||||
(define-public go-github-com-bwesterb-go-ristretto
|
||||
(package
|
||||
(name "go-github-com-bwesterb-go-ristretto")
|
||||
(version "1.2.3")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/bwesterb/go-ristretto")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0h508v790wk6g8jq0gh18296xl87vmgc4fhwnac7mk6i5g3mz6v4"))))
|
||||
(build-system go-build-system)
|
||||
(arguments
|
||||
'(#:unpack-path "github.com/bwesterb/go-ristretto"
|
||||
#:import-path "github.com/bwesterb/go-ristretto/edwards25519"))
|
||||
(home-page "https://github.com/bwesterb/go-ristretto")
|
||||
(synopsis "operations on the Ristretto prime-order group")
|
||||
(description "This is a pure Go implementation of the group operations on
|
||||
the Ristretto prime-order group built from Edwards25519.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public go-github-com-rogpeppe-go-internal
|
||||
(package
|
||||
(name "go-github-com-rogpeppe-go-internal")
|
||||
|
|
Reference in New Issue