gnu: libsigrokdecode: Update to 0.5.3-0.e6962b3, fix build.
* gnu/packages/electronics.scm (libsigrokdecode): Update to 0.5.3-0.e6962b3. [source]: Use git-fetch. Remove patches. [native-inputs]: Add libtool. [arguments]<#:phases>: Remove bootstrap phase. * gnu/packages/patches/libsigrokdecode-python3.9-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>master
parent
1dce887776
commit
28fdf6cc16
|
@ -1598,7 +1598,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/libmemcached-build-with-gcc7.patch \
|
||||
%D%/packages/patches/libmhash-hmac-fix-uaf.patch \
|
||||
%D%/packages/patches/libsigrokdecode-python3.9-fix.patch \
|
||||
%D%/packages/patches/maturin-no-cross-compile.patch \
|
||||
%D%/packages/patches/mecab-variable-param.patch \
|
||||
%D%/packages/patches/memtest86+-build-reproducibly.patch \
|
||||
|
|
|
@ -79,49 +79,48 @@ to take care of the OS-specific details when writing software that uses serial p
|
|||
(license license:lgpl3+)))
|
||||
|
||||
(define-public libsigrokdecode
|
||||
(package
|
||||
(name "libsigrokdecode")
|
||||
(version "0.5.3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://sigrok.org/download/source/libsigrokdecode/libsigrokdecode-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1h1zi1kpsgf6j2z8j8hjpv1q7n49i3fhqjn8i178rka3cym18265"))
|
||||
(patches
|
||||
(search-patches "libsigrokdecode-python3.9-fix.patch"))))
|
||||
(outputs '("out" "doc"))
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(replace 'bootstrap
|
||||
(lambda _
|
||||
(invoke "autoconf")
|
||||
(invoke "aclocal")
|
||||
(invoke "automake" "-ac")))
|
||||
(add-after 'build 'build-doc
|
||||
(lambda _
|
||||
(invoke "doxygen")
|
||||
#t))
|
||||
(add-after 'install 'install-doc
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(copy-recursively "doxy/html-api"
|
||||
(string-append (assoc-ref outputs "doc")
|
||||
"/share/doc/libsigrokdecode"))
|
||||
#t)))))
|
||||
(native-inputs
|
||||
(list check doxygen graphviz pkg-config automake autoconf))
|
||||
;; libsigrokdecode.pc lists "python" in Requires.private, and "glib" in Requires.
|
||||
(propagated-inputs
|
||||
(list glib python))
|
||||
(build-system gnu-build-system)
|
||||
(home-page "https://www.sigrok.org/wiki/Libsigrokdecode")
|
||||
(synopsis "Library providing (streaming) protocol decoding functionality")
|
||||
(description "Libsigrokdecode is a shared library written in C, which provides
|
||||
(let ((commit "e6962b3fe8260382bb9932a1cfdd7ee7090ce267")
|
||||
(revision "0"))
|
||||
(package
|
||||
(name "libsigrokdecode")
|
||||
(version (git-version "0.5.3" revision commit))
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/sigrokproject/libsigrokdecode")
|
||||
(commit commit)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0ik93p6k8hpv8ahchjnmir8paz2w718y1j8pnmrmagjx8vvqd9y6"))))
|
||||
(outputs '("out" "doc"))
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'build 'build-doc
|
||||
(lambda _
|
||||
(invoke "doxygen")
|
||||
#t))
|
||||
(add-after 'install 'install-doc
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(copy-recursively "doxy/html-api"
|
||||
(string-append (assoc-ref outputs "doc")
|
||||
"/share/doc/libsigrokdecode"))
|
||||
#t)))))
|
||||
(native-inputs
|
||||
(list check doxygen graphviz pkg-config automake autoconf libtool))
|
||||
;; libsigrokdecode.pc lists "python" in Requires.private, and "glib" in
|
||||
;; Requires.
|
||||
(propagated-inputs
|
||||
(list glib python))
|
||||
(build-system gnu-build-system)
|
||||
(home-page "https://www.sigrok.org/wiki/Libsigrokdecode")
|
||||
(synopsis
|
||||
"Library providing (streaming) protocol decoding functionality")
|
||||
(description
|
||||
"Libsigrokdecode is a shared library written in C, which provides
|
||||
(streaming) protocol decoding functionality.")
|
||||
(license license:gpl3+)))
|
||||
(license license:gpl3+))))
|
||||
|
||||
(define-public sigrok-firmware-fx2lafw
|
||||
(package
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
From: Dan Horák <dan@danny.cz>
|
||||
Subject: Add support for Python 3.9
|
||||
|
||||
Origin: upstream, https://sigrok.org/gitweb/?p=libsigrokdecode.git;a=commitdiff;h=9b0ad5177bd692f7556a4756bdbd2da81d9c34ce
|
||||
Bug-Debian: https://bugs.debian.org/972769
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f9958b3..2917cb3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
|
||||
# first, since usually only that variant will add "-lpython3.8".
|
||||
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
|
||||
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
|
||||
- [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
||||
+ [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
||||
AS_IF([test "x$sr_have_python3" = xno],
|
||||
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])
|
||||
|
Reference in New Issue