gnu: KDE PIM: Update all packages to 21.12.3.
* gnu/packages/kde-pim.scm (KDE PIM): Update to 21.12.3. (akonadi, akonadi-calendar, akonadi-contacts, akonadi-mime, akonadi-notes, akonadi-search, kaddressbook, kalarmcal, kcalendarsupport, kcalutils, kdepim-runtime, keventviews, kgpg, kidentitymanagement, kimap, kincidenceeditor, kldap, kleopatra, kmail, kmailcommon, kmailimporter, kmailtransport, kmbox, kmessagelib, kmime, knotes, kontactinterface, korganizer, kpeoplevcard, kpimcommon, kpimtextedit, ksmtp, ktnef, libgravatar, libkdepim, libkgapi, libkleo, libksieve): Update to 21.12.3. (kblog): Update to 20.04.3. * gnu/packages/patches/akonadi-not-relocatable.patch * gnu/packages/patches/akonadi-paths.patch * gnu/packages/patches/akonadi-timestamps.patch Fix patches to apply to latest code. (akonadi-calendar): [inputs]: Add new dependencies. (akonadi-contacts): [inputs]: Add new dependencies. (akonadi-search): [arguments]: Disable failing tests. (kcalendarsupport): [inputs]: Add new dependency, remove obsolete kdepim-apps-lib. (libksieve): [arguments]: Enable test that works now. * gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch: Fix patch. (kaddressbook): [inputs]: Remove obsolete kdepim-apps-libs. Move kdocstools to native-inputs. (kmessagelib): [inputs]: Remove obsolete kdepim-appslibs, add kguiaddons. [arguments]: Fix findind header file. (kmailimporter): [inputs]: Add new dependencies. (kmailtransport): [inputs]: Add qtkeychain. (knotes): [inputs]: Move kdocstools to native-inputs. (kincidenceeditor): [inputs]: Add new dependencies. Remove obsolete kdepim-apps-libs [arguments]: Disable failing test. (kldap): [inputs]: Add qtkeychain. (kgpg)[arguments]: Disable failing tests. (libkleo): [propagated-inputs]: Propagate gpgme, qgpgme. [arguments]: Disable failing tests. (kdepim-runtime): [inputs]: Add new dependencies grantlee, grantleetheme, kcmutils, kldap, libkdepim, qtkeychain [arguments]: Enable all the tests that pass. We need to use the old hack instead of search-input-directory to workaround a mysterious include error. (kdepim-apps-lib): Remove obsolete package. (kmail): [origin]: Remove patch. Don't think it is needed anymore. [inputs]: Add new dependencies, delete obsolete kdepim-apps-libs and duplicate kmime. [arguments]: Disable failing tests. * gnu/packages/patches/kmail-Fix-missing-link-libraries.patch: Delete file. * gnu/local.mk: Remove reference to patch. (kmailcommon): [inputs]: Add new dependencies. Signed-off-by: Marius Bakke <marius@gnu.org>master
parent
568d167649
commit
298b349a05
|
@ -1371,7 +1371,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/kinit-kdeinit-extra_libs.patch \
|
||||
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
|
||||
%D%/packages/patches/kismet-unbundle-boost.patch \
|
||||
%D%/packages/patches/kmail-Fix-missing-link-libraries.patch \
|
||||
%D%/packages/patches/kmod-module-directory.patch \
|
||||
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
|
||||
%D%/packages/patches/kmplayer-aarch64.patch \
|
||||
|
|
File diff suppressed because it is too large
Load Diff
|
@ -1,19 +1,18 @@
|
|||
From bc018b4bc816a3b51deb9739bedbf8a2268d0684 Mon Sep 17 00:00:00 2001
|
||||
From: gnidorah <gnidorah@users.noreply.github.com>
|
||||
Date: Fri, 22 Dec 2017 17:36:03 +0300
|
||||
Subject: [PATCH] Revert "Make Akonadi installation properly relocatable"
|
||||
From 4b90a0bd4411a66bbe6ecf85ce89a60a58bee969 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Tuegel <ttuegel@mailbox.org>
|
||||
Date: Sun, 25 Apr 2021 08:01:21 -0500
|
||||
Subject: [PATCH 3/3] akonadi revert make relocatable
|
||||
|
||||
This reverts commit b2bb55f13f2ac783f89cc414de8c39f62fa2096a.
|
||||
---
|
||||
CMakeLists.txt | 3 ---
|
||||
KF5AkonadiConfig.cmake.in | 6 +++---
|
||||
2 files changed, 3 insertions(+), 6 deletions(-)
|
||||
|
||||
Index: akonadi-19.08.0/CMakeLists.txt
|
||||
===================================================================
|
||||
--- akonadi-19.08.0.orig/CMakeLists.txt
|
||||
+++ akonadi-19.08.0/CMakeLists.txt
|
||||
@@ -306,9 +306,6 @@ configure_package_config_file(
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 4e8cc81..63161b7 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -368,9 +368,6 @@ configure_package_config_file(
|
||||
"${CMAKE_CURRENT_SOURCE_DIR}/KF5AkonadiConfig.cmake.in"
|
||||
"${CMAKE_CURRENT_BINARY_DIR}/KF5AkonadiConfig.cmake"
|
||||
INSTALL_DESTINATION ${CMAKECONFIG_INSTALL_DIR}
|
||||
|
@ -23,27 +22,23 @@ Index: akonadi-19.08.0/CMakeLists.txt
|
|||
)
|
||||
|
||||
install(FILES
|
||||
Index: akonadi-19.08.0/KF5AkonadiConfig.cmake.in
|
||||
===================================================================
|
||||
--- akonadi-19.08.0.orig/KF5AkonadiConfig.cmake.in
|
||||
+++ akonadi-19.08.0/KF5AkonadiConfig.cmake.in
|
||||
@@ -26,8 +26,8 @@ if(BUILD_TESTING)
|
||||
find_dependency(Qt5Test "@QT_REQUIRED_VERSION@")
|
||||
endif()
|
||||
diff --git a/KF5AkonadiConfig.cmake.in b/KF5AkonadiConfig.cmake.in
|
||||
index bcf7320..1574319 100644
|
||||
--- a/KF5AkonadiConfig.cmake.in
|
||||
+++ b/KF5AkonadiConfig.cmake.in
|
||||
@@ -1,10 +1,10 @@
|
||||
@PACKAGE_INIT@
|
||||
|
||||
-set_and_check(AKONADI_DBUS_INTERFACES_DIR "@PACKAGE_AKONADI_DBUS_INTERFACES_INSTALL_DIR@")
|
||||
-set_and_check(AKONADI_INCLUDE_DIR "@PACKAGE_AKONADI_INCLUDE_DIR@")
|
||||
+set_and_check(AKONADI_DBUS_INTERFACES_DIR "@AKONADI_DBUS_INTERFACES_INSTALL_DIR@")
|
||||
+set_and_check(AKONADI_INCLUDE_DIR "@AKONADI_INCLUDE_DIR@")
|
||||
|
||||
find_dependency(Boost "@Boost_MINIMUM_VERSION@")
|
||||
|
||||
@@ -35,7 +35,7 @@ include(${CMAKE_CURRENT_LIST_DIR}/KF5Ako
|
||||
include(${CMAKE_CURRENT_LIST_DIR}/KF5AkonadiMacros.cmake)
|
||||
|
||||
# The directory where akonadi-xml.xsd and kcfg2dbus.xsl are installed
|
||||
-set(KF5Akonadi_DATA_DIR "@PACKAGE_KF5Akonadi_DATA_DIR@")
|
||||
+set(KF5Akonadi_DATA_DIR "@KF5Akonadi_DATA_DIR@")
|
||||
|
||||
####################################################################################
|
||||
# CMAKE_AUTOMOC
|
||||
# set the directories
|
||||
if(NOT AKONADI_INSTALL_DIR)
|
||||
--
|
||||
2.31.1
|
||||
|
|
|
@ -1,24 +1,24 @@
|
|||
This is based on the respectve patch from NixPkgs, but with the parts pinning
|
||||
mysql and postgresql executables removed. The our package definition on why.
|
||||
mysql and postgresql executables removed. See our package definition on why.
|
||||
|
||||
diff --git a/src/akonadicontrol/agentmanager.cpp b/src/akonadicontrol/agentmanager.cpp
|
||||
--- a/src/akonadicontrol/agentmanager.cpp
|
||||
+++ b/src/akonadicontrol/agentmanager.cpp
|
||||
@@ -61,7 +61,7 @@ public:
|
||||
[]() {
|
||||
@@ -47,7 +47,7 @@ public:
|
||||
connect(this, &Akonadi::ProcessControl::unableToStart, this, []() {
|
||||
QCoreApplication::instance()->exit(255);
|
||||
});
|
||||
- start(QStringLiteral("akonadiserver"), args, RestartOnCrash);
|
||||
+ start(QLatin1String(NIX_OUT "/bin/akonadiserver"), args, RestartOnCrash);
|
||||
+ start(QStringLiteral(NIX_OUT "/bin/akonadiserver"), args, RestartOnCrash);
|
||||
}
|
||||
|
||||
~StorageProcessControl() override
|
||||
@@ -84,7 +84,7 @@ public:
|
||||
[]() {
|
||||
@@ -69,7 +69,7 @@ public:
|
||||
connect(this, &Akonadi::ProcessControl::unableToStart, this, []() {
|
||||
qCCritical(AKONADICONTROL_LOG) << "Failed to start AgentServer!";
|
||||
});
|
||||
- start(QStringLiteral("akonadi_agent_server"), args, RestartOnCrash);
|
||||
+ start(QLatin1String(NIX_OUT "/bin/akonadi_agent_server"), args, RestartOnCrash);
|
||||
+ start(QStringLiteral(NIX_OUT "/bin/akonadi_agent_server"), args, RestartOnCrash);
|
||||
}
|
||||
|
||||
~AgentServerProcessControl() override
|
||||
|
@ -37,7 +37,7 @@ diff --git a/src/akonadicontrol/agentprocessinstance.cpp b/src/akonadicontrol/ag
|
|||
diff --git a/src/server/storage/dbconfigmysql.cpp b/src/server/storage/dbconfigmysql.cpp
|
||||
--- a/src/server/storage/dbconfigmysql.cpp
|
||||
+++ b/src/server/storage/dbconfigmysql.cpp
|
||||
@@ -209,7 +209,7 @@ bool DbConfigMysql::startInternalServer()
|
||||
@@ -215,7 +215,7 @@ bool DbConfigMysql::startInternalServer()
|
||||
#endif
|
||||
|
||||
// generate config file
|
||||
|
|
|
@ -2,12 +2,12 @@ Index: akonadi-19.08.0/src/server/storage/dbconfigmysql.cpp
|
|||
===================================================================
|
||||
--- akonadi-19.08.0.orig/src/server/storage/dbconfigmysql.cpp
|
||||
+++ akonadi-19.08.0/src/server/storage/dbconfigmysql.cpp
|
||||
@@ -235,8 +235,7 @@ bool DbConfigMysql::startInternalServer(
|
||||
@@ -260,8 +260,7 @@ bool DbConfigMysql::startInternalServer(
|
||||
bool confUpdate = false;
|
||||
QFile actualFile(actualConfig);
|
||||
// update conf only if either global (or local) is newer than actual
|
||||
- if ((QFileInfo(globalConfig).lastModified() > QFileInfo(actualFile).lastModified()) ||
|
||||
- (QFileInfo(localConfig).lastModified() > QFileInfo(actualFile).lastModified())) {
|
||||
- if ((QFileInfo(globalConfig).lastModified() > QFileInfo(actualFile).lastModified())
|
||||
- || (QFileInfo(localConfig).lastModified() > QFileInfo(actualFile).lastModified())) {
|
||||
+ if (true) {
|
||||
QFile globalFile(globalConfig);
|
||||
QFile localFile(localConfig);
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
From 6b0a3a60870499b20ce9ae2ea07cbc5ee53cbdd2 Mon Sep 17 00:00:00 2001
|
||||
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
|
||||
Date: Tue, 21 Jan 2020 23:23:38 +0100
|
||||
Subject: [PATCH] Fix missing link libraries.
|
||||
|
||||
See <https://phabricator.kde.org/D26821>
|
||||
|
||||
These are only actually missing if the libraries reside in different
|
||||
prefixes, as it is the case in Guix or Nix.
|
||||
---
|
||||
agents/archivemailagent/CMakeLists.txt | 1 +
|
||||
agents/followupreminderagent/CMakeLists.txt | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/agents/archivemailagent/CMakeLists.txt b/agents/archivemailagent/CMakeLists.txt
|
||||
index 95c6249de..d0ddcd475 100644
|
||||
--- a/agents/archivemailagent/CMakeLists.txt
|
||||
+++ b/agents/archivemailagent/CMakeLists.txt
|
||||
@@ -22,6 +22,7 @@ ki18n_wrap_ui(libarchivemailagent_SRCS ui/archivemailwidget.ui )
|
||||
add_library(archivemailagent STATIC ${libarchivemailagent_SRCS})
|
||||
target_link_libraries(archivemailagent
|
||||
KF5::MailCommon
|
||||
+ KF5::Libkdepim
|
||||
KF5::I18n
|
||||
KF5::Notifications
|
||||
KF5::KIOWidgets
|
||||
diff --git a/agents/followupreminderagent/CMakeLists.txt b/agents/followupreminderagent/CMakeLists.txt
|
||||
index 9ae7eaa29..527044807 100644
|
||||
--- a/agents/followupreminderagent/CMakeLists.txt
|
||||
+++ b/agents/followupreminderagent/CMakeLists.txt
|
||||
@@ -27,6 +27,7 @@ target_link_libraries(followupreminderagent
|
||||
KF5::AkonadiMime
|
||||
KF5::AkonadiAgentBase
|
||||
KF5::DBusAddons
|
||||
+ KF5::FollowupReminder
|
||||
KF5::XmlGui
|
||||
KF5::KIOWidgets
|
||||
KF5::Notifications
|
||||
--
|
||||
2.21.1
|
||||
|
|
@ -1,59 +1,23 @@
|
|||
From 732861dda9c466841a09329a0b2c992f2b78c40a Mon Sep 17 00:00:00 2001
|
||||
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
|
||||
Date: Tue, 21 Jan 2020 23:15:23 +0100
|
||||
Subject: [PATCH] Fix missing link libraries.
|
||||
|
||||
See <https://phabricator.kde.org/D26818>
|
||||
|
||||
These are only actually missing if the libraries reside in different
|
||||
prefixes, as it is the case in Guix or Nix.
|
||||
---
|
||||
src/ksieveui/autocreatescripts/tests/CMakeLists.txt | 2 ++
|
||||
src/ksieveui/scriptsparsing/autotests/CMakeLists.txt | 2 +-
|
||||
src/ksieveui/scriptsparsing/tests/CMakeLists.txt | 8 ++++++--
|
||||
3 files changed, 9 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/ksieveui/autocreatescripts/tests/CMakeLists.txt b/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
|
||||
index 8a482b4..c43216c 100644
|
||||
--- a/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
|
||||
+++ b/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
|
||||
@@ -15,6 +16,7 @@ set(parsingscript_gui_SRCS parsingscript_gui.cpp ../../tests/capability.cpp)
|
||||
add_executable(parsingscript_gui ${parsingscript_gui_SRCS})
|
||||
target_link_libraries(parsingscript_gui
|
||||
KF5::KIOCore
|
||||
+ KF5::SyntaxHighlighting
|
||||
KF5::KSieveUi
|
||||
diff --git a/src/ksieveui/CMakeLists.txt b/src/ksieveui/CMakeLists.txt
|
||||
--- a/src/ksieveui/CMakeLists.txt
|
||||
+++ b/src/ksieveui/CMakeLists.txt
|
||||
@@ -255,6 +255,7 @@ target_link_libraries(KF5KSieveUi
|
||||
KF5::KManageSieve
|
||||
KF5::KSieve
|
||||
KF5::PimCommon
|
||||
diff --git a/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt b/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
|
||||
index e41a74e..31703ef 100644
|
||||
--- a/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
|
||||
+++ b/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
|
||||
@@ -5,7 +5,7 @@ macro(add_sieveeditor_xmlprintingscriptbuilding _source _extrasource)
|
||||
ecm_add_test(${_test}
|
||||
TEST_NAME ${_name}
|
||||
NAME_PREFIX "sieveeditor-xmlprintingscriptbuilding-"
|
||||
- LINK_LIBRARIES Qt5::Test KF5::I18n KF5::KSieveUi
|
||||
+ LINK_LIBRARIES Qt5::Test KF5::I18n KF5::KSieveUi KF5::SyntaxHighlighting
|
||||
)
|
||||
endmacro()
|
||||
add_sieveeditor_xmlprintingscriptbuilding(xmlprintingscriptbuildertest.cpp "" "")
|
||||
diff --git a/src/ksieveui/scriptsparsing/tests/CMakeLists.txt b/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
|
||||
index a252039..99a1aaa 100644
|
||||
--- a/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
|
||||
+++ b/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
|
||||
@@ -9,5 +9,9 @@ set(xmlsieveparsing_SRCS
|
||||
)
|
||||
|
||||
add_executable(xmlsieveparsing ${xmlsieveparsing_SRCS} )
|
||||
-target_link_libraries(xmlsieveparsing KF5::KSieveUi KF5::KSieve KF5::I18n)
|
||||
-
|
||||
+target_link_libraries(xmlsieveparsing
|
||||
+ KF5::KSieveUi
|
||||
+ KF5::SyntaxHighlighting
|
||||
+ KF5::KSieve
|
||||
+ KF5::I18n
|
||||
+)
|
||||
--
|
||||
2.21.1
|
||||
PRIVATE
|
||||
KF5::Libkdepim
|
||||
KF5::Archive
|
||||
@@ -269,7 +270,6 @@ target_link_libraries(KF5KSieveUi
|
||||
KF5::I18n
|
||||
KF5::SonnetUi
|
||||
Qt::PrintSupport
|
||||
- KF5::SyntaxHighlighting
|
||||
)
|
||||
|
||||
set_target_properties(KF5KSieveUi PROPERTIES
|
||||
--
|
||||
2.33.0
|
||||
|
|
Reference in New Issue