me
/
guix
Archived
1
0
Fork 0

gnu: guile-sqlite3: Update to 0.1.1.

* gnu/packages/guile.scm (guile-sqlite3): Update to 0.1.1.
[source]: Remove 'patches', 'modules', and 'snippet'.
* gnu/packages/patches/guile-sqlite3-fix-cross-compilation.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
master
Ludovic Courtès 2020-06-12 18:52:36 +02:00
parent 52c529ff20
commit 29e4d3ea06
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 3 additions and 69 deletions

View File

@ -1061,7 +1061,6 @@ dist_patch_DATA = \
%D%/packages/patches/guile-present-coding.patch \
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
%D%/packages/patches/guile-emacs-fix-configure.patch \
%D%/packages/patches/guile-sqlite3-fix-cross-compilation.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \
%D%/packages/patches/gtk2-theme-paths.patch \

View File

@ -633,7 +633,7 @@ Guile's foreign function interface.")
(define-public guile-sqlite3
(package
(name "guile-sqlite3")
(version "0.1.0")
(version "0.1.1")
(home-page "https://notabug.org/guile-sqlite3/guile-sqlite3.git")
(source (origin
(method git-fetch)
@ -642,18 +642,8 @@ Guile's foreign function interface.")
(commit (string-append "v" version))))
(sha256
(base32
"1nv8j7wk6b5n4p22szyi8lv8fs31rrzxhzz16gyj8r38c1fyp9qp"))
(file-name (string-append name "-" version "-checkout"))
(patches
(search-patches "guile-sqlite3-fix-cross-compilation.patch"))
(modules '((guix build utils)))
(snippet
'(begin
;; Allow builds with Guile 3.0.
(substitute* "configure.ac"
(("^GUILE_PKG.*")
"GUILE_PKG([3.0 2.2 2.0])\n"))
#t))))
"0f7lgqkyli8gc2gifrabxnqrqixkpwsridhx9sm2wc7djxdafccb"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)

View File

@ -1,55 +0,0 @@
From a6e9e62a77ecc5012929613e20da23b2636450a5 Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <mathieu.othacehe@parrot.com>
Date: Mon, 25 Mar 2019 11:00:38 +0100
Subject: [PATCH] cross compile
---
build-aux/guile.am | 2 +-
configure.ac | 19 ++++++++++++-------
2 files changed, 13 insertions(+), 8 deletions(-)
diff --git a/build-aux/guile.am b/build-aux/guile.am
index dc1e63f..3126372 100644
--- a/build-aux/guile.am
+++ b/build-aux/guile.am
@@ -16,4 +16,4 @@ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
SUFFIXES = .scm .go
.scm.go:
- $(AM_V_GEN)$(top_builddir)/env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+ $(AM_V_GEN)$(top_builddir)/env $(GUILE_TOOLS) compile $(GUILE_TARGET) $(GUILE_WARNINGS) -o "$@" "$<"
diff --git a/configure.ac b/configure.ac
index f648fcb..2d34d0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,15 +21,20 @@ PKG_CHECK_MODULES([SQLITE], [sqlite3])
SQLITE_LIBDIR="`"$PKG_CONFIG" sqlite3 --variable libdir`"
AC_SUBST([SQLITE_LIBDIR])
-AC_MSG_CHECKING([whether '$SQLITE_LIBDIR/libsqlite3' is usable])
-GUILE_CHECK([retval],
- [(dynamic-func \"sqlite3_open_v2\"
+if test "$cross_compiling" = "no"; then
+ AC_MSG_CHECKING([whether '$SQLITE_LIBDIR/libsqlite3' is usable])
+ GUILE_CHECK([retval],
+ [(dynamic-func \"sqlite3_open_v2\"
(dynamic-link \"$SQLITE_LIBDIR/libsqlite3\"))])
-if test "$retval" != 0; then
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([failed to load '$SQLITE_LIBDIR/libsqlite3'])
+ if test "$retval" != 0; then
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([failed to load '$SQLITE_LIBDIR/libsqlite3'])
+ else
+ AC_MSG_RESULT([yes])
+ fi
else
- AC_MSG_RESULT([yes])
+ GUILE_TARGET="--target=$host_alias"
+ AC_SUBST([GUILE_TARGET])
fi
AC_CONFIG_FILES([Makefile sqlite3.scm])
--
2.17.1